HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   General (http://www.howtoforge.com/forums/forumdisplay.php?f=25)
-   -   CLAM AV upgrade failed (nothing will apt-get upgrade) (http://www.howtoforge.com/forums/showthread.php?t=37642)

gjcomputer 22nd July 2009 21:33

CLAM AV upgrade failed (nothing will apt-get upgrade)
 
debian 5.0.1, running ispconfig 3, apt-get upgrade pulls this...
Code:

clamav (0.95.2+dfsg-1~volatile1) unstable; urgency=low

  This release of clamav-milter requires you to amend your configuration.
  It's against the Debian volatile policy, but due to upstream changes, we
  decided that it was the best way forward, rather than maintaining an
  outdated version.

  Here is a summary of the required changes:

  * clamav-milter configuration has been moved from
    command-line options to the file /etc/clamav/clamav-milter.conf. The
    following is a map of commonly used options:

      -l                LocalNet
      -o                No longer needed/supported
      -q                No longer needed/supported
      --noreject        OnInfected (Blackhole|Accept|Quarantine)
      --dont-wait      No longer needed/supported
      --max-children    No longer needed/supported

  * While at it, /etc/default/clamav-milter was reworked. If you've previously
    set $USE_POSTFIX in that file, please make sure to set the new option
    SOCKET_RWGROUP=postfix now.

    Also, ensure that the MilterSocket setting in
    /etc/clamav/clamav-milter.conf includes /var/spool/postfix, if you are
    using a chroot'ed smtpd instance (which is the default).

 -- martin f. krafft <madduck@debian.org>  Mon, 15 Jun 2009 08:20:10 +0200

i then have to break the upgrade and nothing is changed, any ideas?

falko 23rd July 2009 14:21

On ISPConfig 3 systems, ClamAV is invoked by amavisd, not clamav-milter, so you can ignore this message.

gjcomputer 23rd July 2009 15:47

understandable, but i have the break the operation, and that kills the upgrade, how can i run the upgrade without upgrading the clam?

falko 25th July 2009 00:15

Is there no option to accept what apt proposes?

lano 25th July 2009 17:10

Quote:

Originally Posted by gjcomputer (Post 198902)
debian 5.0.1, running ispconfig 3, apt-get upgrade pulls this...
Code:

clamav (0.95.2+dfsg-1~volatile1) unstable; urgency=low

  This release of clamav-milter requires you to amend your configuration.
  It's against the Debian volatile policy, but due to upstream changes, we
  decided that it was the best way forward, rather than maintaining an
  outdated version.

  Here is a summary of the required changes:

  * clamav-milter configuration has been moved from
    command-line options to the file /etc/clamav/clamav-milter.conf. The
    following is a map of commonly used options:

      -l                LocalNet
      -o                No longer needed/supported
      -q                No longer needed/supported
      --noreject        OnInfected (Blackhole|Accept|Quarantine)
      --dont-wait      No longer needed/supported
      --max-children    No longer needed/supported

  * While at it, /etc/default/clamav-milter was reworked. If you've previously
    set $USE_POSTFIX in that file, please make sure to set the new option
    SOCKET_RWGROUP=postfix now.

    Also, ensure that the MilterSocket setting in
    /etc/clamav/clamav-milter.conf includes /var/spool/postfix, if you are
    using a chroot'ed smtpd instance (which is the default).

 -- martin f. krafft <madduck@debian.org>  Mon, 15 Jun 2009 08:20:10 +0200

i then have to break the upgrade and nothing is changed, any ideas?

Just press "q" , and it should proceed with upgrade.


All times are GMT +2. The time now is 07:20.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.