HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=27)
-   -   stats makes: Error: forbidden by Options directive (http://www.howtoforge.com/forums/showthread.php?t=37298)

tom 8th July 2009 14:16

stats makes: Error: forbidden by Options directive
 
After login in the stats folder no stats are shown but this error in error.log
Code:

[Wed Jul 08 12:44:37 2009] [error] [client1.2.3.4] Directory index forbidden by Options directive:
Any Ideas why? It's a fresch ISPConfig installation and the webalizer files are produced in the stats folder. All stats folders are owned by root. This was differend in ISPConfig 2.

Mark_NL 8th July 2009 15:22

It's a fresh install, so it could be that there are no stats files in that dir yet, thus the servers wants to show the dir contents in a list (dirlisting) which is not allowed .. so i'd say you're stats dir is empty and you've to wait until the cronjob creates the first stats for you :)

tom 8th July 2009 15:45

weblizer files are already in the stats folder. It's a some days old fresh installation :-)

dzudzu 8th July 2009 16:57

if i get you right u have files like these in /stats folder in root of site? What files u got there and with what permissions?

[root@eontek stats]# ls -l
total 212
1 root root 3167 Jul 1 00:30 ctry_usage_200906.png
1 root root 3739 Jul 8 00:30 ctry_usage_200907.png
1 root root 3026 Jul 1 00:30 daily_usage_200906.png
1 root root 2870 Jul 8 00:30 daily_usage_200907.png
1 root root 1896 Jul 1 00:30 hourly_usage_200906.png
1 root root 1937 Jul 8 00:30 hourly_usage_200907.png
1 root root 4279 Jul 8 00:30 index.html
1 root root 88922 Jul 1 00:30 usage_200906.html
1 root root 78994 Jul 8 00:30 usage_200907.html
1 root root 2335 Jul 8 00:30 usage.png

and what comes up in browser when u go site.com/stats ?

tom 8th July 2009 19:44

The permissions are as yours
Quote:

Originally Posted by dzudzu (Post 197731)
...
[root@eontek stats]# ls -l
total 212
1 root root 3167 Jul 1 00:30 ctry_usage_200906.png
1 root root 3739 Jul 8 00:30 ctry_usage_200907.png
1 root root 3026 Jul 1 00:30 daily_usage_200906.png
1 root root 2870 Jul 8 00:30 daily_usage_200907.png
1 root root 1896 Jul 1 00:30 hourly_usage_200906.png
1 root root 1937 Jul 8 00:30 hourly_usage_200907.png
1 root root 4279 Jul 8 00:30 index.html
1 root root 88922 Jul 1 00:30 usage_200906.html
1 root root 78994 Jul 8 00:30 usage_200907.html
1 root root 2335 Jul 8 00:30 usage.png

and what comes up in browser when u go site.com/stats ?

Error 403

dzudzu 8th July 2009 20:19

u might try to make another folder with index file in it and see does it load it up? I would check .htaccess files and .vhost files becouse something is maybe geting override. U might want to try also to change site info in ispconfig so it remakes the .vhost file or try adding the

<Directory "/path/to/dir">
Options Indexes FollowSymLinks
</Directory>

or try with this command

DirectoryIndex index.html

to force loading of that file before listing directory.

Hope it helps


All times are GMT +2. The time now is 00:18.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.