HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   General (http://www.howtoforge.com/forums/forumdisplay.php?f=25)
-   -   Problem with alias/forward to multiple addresses (http://www.howtoforge.com/forums/showthread.php?t=37275)

pwcr 7th July 2009 20:10

Problem with alias/forward to multiple addresses
 
Hi,

like the person in this topic: http://www.howtoforge.com/forums/showthread.php?t=34447 I'm trying to create alias/forward which would deliver emails to two local mailboxes.

I tried:
- adding 2 aliases with same source address and different destination addresses
- adding a forward with multiple addresses in destination field, separated by whitespace

Test mails to alias address are not delivered to mailboxes.
Mail log shows no problems.

After I send the test email, a new folder appears in /var/vmail, named like the first destination address, for example testuser@example.com.
This doesn't seem right.

The system is Debian Lenny, ISPConfig 3.0.1.3. Mail is setup using this how-to: http://www.howtoforge.com/perfect-se...nny-ispconfig3

Mail server is ISPConfig *slave* server, the web interface is hosted elsewhere. Mail works ok otherwise, even forwards/aliases to one destination email work ok.

Any ideas?

Regards,
Peter

till 8th July 2009 00:23

Make sure that the alias address is not the sma ethen the mailbox address.

pwcr 8th July 2009 01:58

Alias address in not the same as any of mailbox addresses.
I did some more testing, interesting results.

If I create (in ISPConfig) aliases testusers@domain1.com > testuser@domain1.com and testusers@domain1.com > someuser@domain2.com, the mail sent to testusers@domain1.com is delivered to both mailboxes.

However, if I create aliases testusers@domain1.com > testuser@domain1.com and testusers@domain1.com > someuser@domain1.com, the mail sent to testusers@domain1.com is not delivered to these mailboxes. Instead, the folder /var/vmail/testuser@domain1.com is automatically created, and inside it another folder someuser@domain1.com, and inside that folder the usual "cur" and "new" subfolders.

Apparently there is a problem with 2 aliases with the same name pointing to 2 different mailboxes in same domain.


All times are GMT +2. The time now is 15:16.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.