HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   General (http://www.howtoforge.com/forums/forumdisplay.php?f=25)
-   -   I screwed up my email on centos (http://www.howtoforge.com/forums/showthread.php?t=37157)

Doug G 2nd July 2009 04:39

I screwed up my email on centos
 
I was trying to get centos 5.3 to do a yum update, kept getting a dependency problem with lzop so I uninstalled and reinstalled amavis and lzop*. Now email doesn't work, first postfix didn't start on bootup and I can't seem to receive mail either.

What's the best way to put all the email configuration settings back the way they were?

tia

till 2nd July 2009 10:55

Download the latest ispconfig 3 version, enter the install folder and then run

php update.php

and select to reconfigure the services.

Doug G 3rd July 2009 01:33

Thanks till

Doug G 4th July 2009 01:22

A quick update on the problem. After re-running ispconfig3 update.php email was still not functioning. It turned out that the CentOS yum update I did updated postfix, which removed the postfix built during the perfect server setup and replaced it with the repository postfix that doesn't seem to have mysql compiled in.

yum remove postfix, then rpm -ivh on the postfix rpm built during install, then re-run the ispconfig3 update.php and finally email is back.

If you're like me and regularly update the os using yum, I suspect the thing to do is to always exclude postfix from yum updates in the future,


All times are GMT +2. The time now is 14:44.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.