HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Server Operation (http://www.howtoforge.com/forums/forumdisplay.php?f=5)
-   -   postfix/smtpd[3112]: connect from unknown ERROR on mail.log (http://www.howtoforge.com/forums/showthread.php?t=37125)

frost10torres 30th June 2009 14:46

postfix/smtpd[3112]: connect from unknown ERROR on mail.log
 
Hi to all, im a newbie on this Forum.
Will appreciate all help and assistance on my problem.

I setupped a mail server and i can receive mail on my domain, But cannot send email from any other domains. I followed the "Howto: ISP-style Email Server..." by Christoph Haas.



##my postconf -n
alias_database = hash:/etc/aliases
alias_maps = hash:/etc/aliases
append_dot_mydomain = no
biff = no
broken_sasl_auth_clients = yes
config_directory = /etc/postfix
content_filter = smtp-amavis:[127.0.0.1]:10024
inet_interfaces = all
mailbox_size_limit = 0
mydestination = hostname.mydomain.com, localhost.mydomain.com, localhost
myhostname = hostname.mydomain.com
mynetworks = 192.168.1.0/24
myorigin = /etc/mailname
receive_override_options = no_address_mappings
recipient_delimiter = +
relayhost =
smtp_tls_session_cache_database = btree:${queue_directory}/smtp_scache
smtpd_banner = $myhostname ESMTP $mail_name (Debian/GNU)
smtpd_recipient_restrictions = permit_mynetworks,permit_sasl_authenticated,reject _unauth_destination
smtpd_sasl_auth_enable = yes
smtpd_sasl_path = private/auth
smtpd_sasl_type = dovecot
smtpd_tls_auth_only = yes
smtpd_tls_cert_file = /etc/ssl/certs/postfix.pem
smtpd_tls_key_file = /etc/ssl/private/postfix.pem
smtpd_tls_session_cache_database = btree:${queue_directory}/smtpd_scache
smtpd_use_tls = yes
virtual_alias_maps = mysql:/etc/postfix/mysql-virtual-alias-maps.cf,mysql:/etc/postfix/mysql-email2email.cf
virtual_gid_maps = static:5000
virtual_mailbox_domains = mysql:/etc/postfix/mysql-virtual-mailbox-domains.cf
virtual_mailbox_maps = mysql:/etc/postfix/mysql-virtual-mailbox-maps.cf
virtual_transport = dovecot
virtual_uid_maps = static:5000
###end




When i try to use MS outlook and send email from outside my home network, to 3 recipients at different domains, it wont send and has an error message that: "...- Sending reported error (0x800CCC80) : None of the authentication methods supported by this client are supported by your server"

##my mail.log
dovecot: pop3-login: Login: user=<me@mydomain.com>, method=PLAIN, rip=87.5.144.18, lip=192.168.1.4
Jun 30 19:57:30 hostname postfix/smtpd[3112]: warning: 87.5.144.18: hostname dynamic.dsl.nesma.net.au verification failed: Name or service not known
Jun 30 19:57:30 hostname postfix/smtpd[3112]: connect from unknown[87.5.144.18]
Jun 30 19:57:30 hostname postfix/smtpd[3112]: lost connection after EHLO from unknown[87.5.144.18]
Jun 30 19:57:30 hostname postfix/smtpd[3112]: disconnect from unknown[87.5.144.18]
Jun 30 19:57:30 hostname dovecot: POP3(me@mydomain.com): Disconnected: Logged out top=0/0, retr=0/0, del=0/15, size=101512
##end



Im not yet technically knowledgeable in troubleshooting this kind of problem and i am working for this 3 days i a roow but to no avail. What do you think is the cause of the problem??.....Thanks in advance!

falko 1st July 2009 14:26

Quote:

Originally Posted by frost10torres (Post 196984)
Jun 30 19:57:30 hostname postfix/smtpd[3112]: warning: 87.5.144.18: hostname dynamic.dsl.nesma.net.au verification failed: Name or service not known

This is the hostname I get for the IP 87.5.144.18:
Code:

mh1:~# dig -x 87.5.144.18

; <<>> DiG 9.3.4 <<>> -x 87.5.144.18
;; global options:  printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 11499
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;18.144.5.87.in-addr.arpa.      IN      PTR

;; ANSWER SECTION:
18.144.5.87.in-addr.arpa. 43200 IN      PTR    host18-144-dynamic.5-87-r.retail.telecomitalia.it.

;; Query time: 37 msec
;; SERVER: 213.133.98.98#53(213.133.98.98)
;; WHEN: Wed Jul  1 14:40:54 2009
;; MSG SIZE  rcvd: 105

mh1:~#

What's in /etc/resolv.conf?


All times are GMT +2. The time now is 21:45.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.