HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Server Operation (http://www.howtoforge.com/forums/forumdisplay.php?f=5)
-   -   Postfix with mysql problem (http://www.howtoforge.com/forums/showthread.php?t=37021)

Snake 26th June 2009 03:58

Postfix with mysql problem
 
Hello,

I have followed this guide: http://howtoforge.com/virtual-users-...-mysql-fedora8

I have installed the releases but when I trying check the Postfix, Telnet shows:

Quote:

[root@serv1 log]# telnet localhost 25
Trying 127.0.0.1...
telnet: connect to address 127.0.0.1: Connection refused
And dnsstuff shows:

Quote:

ERROR: I could not complete a connection to any of your mailservers!

correo.domain.tld: Timed out [Last data sent: [Did not connect]]

If this is a timeout problem, note that the DNSreport only waits about 40 seconds for responses, so your mail *may* work fine in this case but you will need to use testing tools specifically designed for such situations to be certain.
Maillog and Message not show anything :S

Can you help me please?

Thanks and regards!

topdog 26th June 2009 11:03

Whats the output of the following

Code:

service postfix status
iptables -vnL


Snake 26th June 2009 17:57

Hello,

Quote:

[root@serv1 ~]# service postfix status
master is stopped
[root@serv1 ~]# iptables -vnL
Chain INPUT (policy ACCEPT 1 packets, 54 bytes)
pkts bytes target prot opt in out source destination

Chain FORWARD (policy ACCEPT 0 packets, 0 bytes)
pkts bytes target prot opt in out source destination

Chain OUTPUT (policy ACCEPT 0 packets, 0 bytes)
pkts bytes target prot opt in out source destination
I have started the Postfix and telnet now shows:

Quote:

[root@serv1 ~]# telnet localhost 25
Trying 127.0.0.1...
Connected to localhost.
Escape character is '^]'.
Connection closed by foreign host.
Thanks and regards.

topdog 26th June 2009 17:59

postfix is not running

Code:

service postfix start
chkconfig --add postfix
chkconfig --level 35 postfix on


Snake 26th June 2009 18:00

Hello,

I have edited my before post xD

Regards.

topdog 26th June 2009 18:03

Code:

tail -f /var/log/maillog -n 40

Snake 26th June 2009 18:07

Hello,

Quote:

Jun 26 17:58:07 serv1 sendmail[21561]: alias database /etc/aliases rebuilt by root
Jun 26 17:58:07 serv1 sendmail[21561]: /etc/aliases: 76 aliases, longest 10 bytes, 765 bytes total
Jun 26 17:58:08 serv1 postfix/postfix-script[21608]: starting the Postfix mail system
Jun 26 17:58:08 serv1 postfix/master[21609]: daemon started -- version 2.5.5, configuration /etc/postfix
Jun 26 17:58:19 serv1 postfix/smtpd[21615]: warning: xsasl_cyrus_server_get_mechanism_list: no applicable SASL mechanisms
Jun 26 17:58:19 serv1 postfix/smtpd[21615]: fatal: no SASL authentication mechanisms
Jun 26 17:58:20 serv1 postfix/master[21609]: warning: process /usr/libexec/postfix/smtpd pid 21615 exit status 1
Jun 26 17:58:20 serv1 postfix/master[21609]: warning: /usr/libexec/postfix/smtpd: bad command startup -- throttling
Jun 26 18:01:08 serv1 postfix/smtpd[21797]: warning: xsasl_cyrus_server_get_mechanism_list: no applicable SASL mechanisms
Jun 26 18:01:08 serv1 postfix/smtpd[21797]: fatal: no SASL authentication mechanisms
Jun 26 18:01:09 serv1 postfix/master[21609]: warning: process /usr/libexec/postfix/smtpd pid 21797 exit status 1
Jun 26 18:01:09 serv1 postfix/master[21609]: warning: /usr/libexec/postfix/smtpd: bad command startup -- throttling
Note: I installed sendmail and sendmail-devel after of Postfix because I needed a sendmail-devel library, but Sendmail must to be off.

Regards and thanks!

topdog 26th June 2009 18:09

you have a problem with your SASL configuration, go back to the howto and see what you have missed.

Snake 26th June 2009 18:30

Hello,

My /usr/lib/sasl2/smtpd.conf shows:

Quote:

pwcheck_method: authdaemond
log_level: 3
mech_list: PLAIN LOGIN
authdaemond_path:/var/spool/authdaemon/socket
Is it ok? Or I must to put:

Quote:

pwcheck_method: saslauthd
mech_list: plain login
I needed install some software, now telnet shows:

Quote:

[root@serv1 ~]# telnet localhost 25
Trying 127.0.0.1...
Connected to localhost.
Escape character is '^]'.
220 serv1.domain.tld ESMTP Postfix
ehlo localhost
250-serv1.domain.tld
250-PIPELINING
250-SIZE 10240000
250-VRFY
250-ETRN
250-STARTTLS
250-AUTH PLAIN LOGIN
250-AUTH=PLAIN LOGIN
250-ENHANCEDSTATUSCODES
250-8BITMIME
250 DSN
quit
221 2.0.0 Bye
Connection closed by foreign host.
Thanks very much!
Thanks and regards!

Snake 26th June 2009 18:38

Hello,

I have other problem, I have added the user postmaster to the database but DNSstuff shows:

Quote:

ERROR: One or more of your mailservers does not accept mail to postmaster@domain.tld. Mailservers are required (RFC822 6.3, RFC1123 5.2.7, and RFC2821 4.5.1) to accept mail to postmaster.

correo.domain.tld's postmaster response:<br /> >>> RCPT TO:<postmaster@domain.tld><br /> <<< 554 5.7.1 <postmaster@domain.tld>: Relay access denied <br />
And:

Quote:

WARNING: One or more of your mailservers does not accept mail to abuse@domain.tld. Mailservers are expected by RFC2142 to accept mail to abuse.

correo.domain.tld's abuse response:<br /> >>> RCPT TO:<abuse@domain.tld><br /> <<< 554 5.7.1 <abuse@domain.tld>: Relay access denied <br />
And maillog:

Quote:

Jun 26 18:34:19 serv1 postfix/smtpd[23895]: NOQUEUE: reject: RCPT from plum.dnsstuff.com[174.133.202.226]: 554 5.7.1 <postmaster@domain.tld>: Relay access denied; from=<> to=<postmaster@domain.tld> proto=SMTP helo=<test.DNSreport.com>
Jun 26 18:34:19 serv1 postfix/smtpd[23895]: NOQUEUE: reject: RCPT from plum.dnsstuff.com[174.133.202.226]: 554 5.7.1 <abuse@domain.tld>: Relay access denied; from=<> to=<abuse@domain.tld> proto=SMTP helo=<test.DNSreport.com>
Jun 26 18:34:19 serv1 postfix/smtpd[23895]: C4A0B150059: client=plum.dnsstuff.com[174.133.202.226]
Jun 26 18:34:19 serv1 postfix/smtpd[23895]: C4A0B150059: reject: RCPT from plum.dnsstuff.com[174.133.202.226]: 554 5.7.1 <Not.abuse.see.www.DNSreport.com.from.IP.83.54.33. 45@DNSreport.com>: Relay access denied; from=<> to=<Not.abuse.see.www.DNSreport.com.from.IP.83.54. 33.45@DNSreport.com> proto=SMTP helo=<test.DNSreport.com>
Jun 26 18:34:19 serv1 postfix/smtpd[23895]: disconnect from plum.dnsstuff.com[174.133.202.226]


All times are GMT +2. The time now is 17:34.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.