HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=27)
-   -   Ispconfig web adding mailbox problem and postfix not send and recieve (http://www.howtoforge.com/forums/showthread.php?t=36843)

Stown 20th June 2009 19:38

Ispconfig web adding mailbox problem and postfix not send and recieve
 
Hi,


First of all ispconfig 3 rocks! Its a verry nice control panel. Keep up the good work! BTW: My english is not so good (i speak dutch).

I have a centOS 5.3 server where i installed everything through ssh from the plain text centos 5.2 ispconfig 3 install.

http://www.ispconfig.org/docs/INSTALL_CENTOS_5.2.txt

I got really no errors setting up following this plain text file.

Everything works, except i got email problems.

1. When i log in to ispconfig on my website :8080 and want to create a new email mailbox the ajax request takes so long when i click on "Save" that the page not says something back like "Succesful created or Not created". And when i go back to the page of email mailboxes then i see its created but..

1.1 First when i log in on squirrelmail using that mailbox i succesfully logged in but it says on the left frame "Error creating sent mailbox" and now i got when trying to inlogging again "You must be logged in to access this page.".
1.2 When i send from gmail account a email it dont komes through.

DNS settings are good btw.

Please help me.

EDIT: this is some last text of /var/log/maillog

Jun 20 13:42:16 s-projects amavis[2417]: Lookup::LDAP code NOT loaded
Jun 20 13:42:16 s-projects amavis[2417]: AM.PDP-in proto code loaded
Jun 20 13:42:16 s-projects amavis[2417]: SMTP-in proto code loaded
Jun 20 13:42:16 s-projects amavis[2417]: Courier proto code NOT loaded
Jun 20 13:42:16 s-projects amavis[2417]: SMTP-out proto code loaded
Jun 20 13:42:16 s-projects amavis[2417]: Pipe-out proto code NOT loaded
Jun 20 13:42:16 s-projects amavis[2417]: BSMTP-out proto code NOT loaded
Jun 20 13:42:16 s-projects amavis[2417]: Local-out proto code loaded
Jun 20 13:42:16 s-projects amavis[2417]: OS_Fingerprint code NOT loaded
Jun 20 13:42:16 s-projects amavis[2417]: ANTI-VIRUS code loaded
Jun 20 13:42:16 s-projects amavis[2417]: ANTI-SPAM code loaded
Jun 20 13:42:16 s-projects amavis[2417]: ANTI-SPAM-SA code loaded
Jun 20 13:42:16 s-projects amavis[2417]: Unpackers code loaded
Jun 20 13:42:16 s-projects amavis[2417]: Found $file at /usr/bin/file
Jun 20 13:42:16 s-projects amavis[2417]: No $dspam, not using it
Jun 20 13:42:16 s-projects amavis[2417]: No $altermime, not using it
Jun 20 13:42:16 s-projects amavis[2417]: Internal decoder for .mail
Jun 20 13:42:16 s-projects amavis[2417]: Internal decoder for .asc
Jun 20 13:42:16 s-projects amavis[2417]: Internal decoder for .uue
Jun 20 13:42:16 s-projects amavis[2417]: Internal decoder for .hqx
Jun 20 13:42:16 s-projects amavis[2417]: Internal decoder for .ync
Jun 20 13:42:16 s-projects amavis[2417]: Found decoder for .F at /usr/bin/unfreeze
Jun 20 13:42:16 s-projects amavis[2417]: Found decoder for .Z at /usr/bin/uncompress
Jun 20 13:42:16 s-projects amavis[2417]: Found decoder for .gz at /usr/bin/gzip -d
Jun 20 13:42:16 s-projects amavis[2417]: Internal decoder for .gz (backup, not used)
Jun 20 13:42:16 s-projects amavis[2417]: Found decoder for .bz2 at /usr/bin/bzip2 -d
Jun 20 13:42:16 s-projects amavis[2417]: Found decoder for .lzo at /usr/bin/lzop -d
Jun 20 13:42:16 s-projects amavis[2417]: Found decoder for .rpm at /usr/bin/rpm2cpio
Jun 20 13:42:16 s-projects amavis[2417]: Found decoder for .cpio at /usr/bin/pax
Jun 20 13:42:16 s-projects amavis[2417]: Found decoder for .tar at /usr/bin/pax
Jun 20 13:42:16 s-projects amavis[2417]: Found decoder for .deb at /usr/bin/ar
Jun 20 13:42:16 s-projects amavis[2417]: Internal decoder for .zip
Jun 20 13:42:16 s-projects amavis[2417]: No decoder for .7z tried: 7zr, 7za, 7z
Jun 20 13:42:16 s-projects amavis[2417]: Found decoder for .rar at /usr/bin/unrar
Jun 20 13:42:16 s-projects amavis[2417]: Found decoder for .arj at /usr/bin/arj
Jun 20 13:42:16 s-projects amavis[2417]: Found decoder for .arc at /usr/bin/nomarch
Jun 20 13:42:16 s-projects amavis[2417]: Found decoder for .zoo at /usr/bin/zoo
Jun 20 13:42:16 s-projects amavis[2417]: Found decoder for .lha at /usr/bin/lha
Jun 20 13:42:16 s-projects amavis[2417]: Found decoder for .cab at /usr/bin/cabextract
Jun 20 13:42:16 s-projects amavis[2417]: No decoder for .tnef tried: tnef
Jun 20 13:42:16 s-projects amavis[2417]: Internal decoder for .tnef
Jun 20 13:42:16 s-projects amavis[2417]: Found decoder for .exe at /usr/bin/unrar; /usr/bin/lha; /usr/bin/arj
Jun 20 13:42:16 s-projects amavis[2417]: Using primary internal av scanner code for ClamAV-clamd
Jun 20 13:42:17 s-projects amavis[2417]: No primary av scanner: KasperskyLab AVP - aveclient
Jun 20 13:42:17 s-projects amavis[2417]: No primary av scanner: KasperskyLab AntiViral Toolkit Pro (AVP)
Jun 20 13:42:17 s-projects amavis[2417]: No primary av scanner: KasperskyLab AVPDaemonClient
Jun 20 13:42:17 s-projects amavis[2417]: No primary av scanner: CentralCommand Vexira (new) vascan
Jun 20 13:42:17 s-projects amavis[2417]: No primary av scanner: Avira AntiVir
Jun 20 13:42:17 s-projects amavis[2417]: No primary av scanner: Command AntiVirus for Linux
Jun 20 13:42:17 s-projects amavis[2417]: No primary av scanner: Symantec CarrierScan via Symantec CommandLineScanner
Jun 20 13:42:17 s-projects amavis[2417]: No primary av scanner: Symantec AntiVirus Scan Engine
Jun 20 13:42:17 s-projects amavis[2417]: No primary av scanner: F-Secure Antivirus for Linux servers
Jun 20 13:42:17 s-projects amavis[2417]: No primary av scanner: CAI InoculateIT
Jun 20 13:42:17 s-projects amavis[2417]: No primary av scanner: CAI eTrust Antivirus
Jun 20 13:42:17 s-projects amavis[2417]: No primary av scanner: MkS_Vir for Linux (beta)
Jun 20 13:42:17 s-projects amavis[2417]: No primary av scanner: MkS_Vir daemon
Jun 20 13:42:17 s-projects amavis[2417]: No primary av scanner: ESET NOD32 Linux Mail Server - command line interface
Jun 20 13:42:17 s-projects amavis[2417]: No primary av scanner: ESET NOD32 for Linux File servers
Jun 20 13:42:17 s-projects amavis[2417]: No primary av scanner: Norman Virus Control v5 / Linux
Jun 20 13:42:17 s-projects amavis[2417]: No primary av scanner: Panda CommandLineSecure 9 for Linux
Jun 20 13:42:17 s-projects amavis[2417]: No primary av scanner: NAI McAfee AntiVirus (uvscan)
Jun 20 13:42:17 s-projects amavis[2417]: No primary av scanner: VirusBuster
Jun 20 13:42:17 s-projects amavis[2417]: No primary av scanner: CyberSoft VFind
Jun 20 13:42:17 s-projects amavis[2417]: No primary av scanner: avast! Antivirus
Jun 20 13:42:17 s-projects amavis[2417]: No primary av scanner: Ikarus AntiVirus for Linux
Jun 20 13:42:17 s-projects amavis[2417]: No primary av scanner: BitDefender
Jun 20 13:42:17 s-projects amavis[2417]: No primary av scanner: ArcaVir for Linux
Jun 20 13:42:17 s-projects amavis[2417]: Found secondary av scanner ClamAV-clamscan at /usr/bin/clamscan
Jun 20 13:42:17 s-projects amavis[2417]: No secondary av scanner: FRISK F-Prot Antivirus
Jun 20 13:42:17 s-projects amavis[2417]: No secondary av scanner: Trend Micro FileScanner
Jun 20 13:42:17 s-projects amavis[2417]: No secondary av scanner: drweb - DrWeb Antivirus
Jun 20 13:42:17 s-projects amavis[2417]: No secondary av scanner: Kaspersky Antivirus v5.5
Jun 20 13:42:17 s-projects amavis[2417]: Creating db in /var/spool/amavisd/db/; BerkeleyDB 0.36, libdb 4.3
Jun 20 13:42:17 s-projects amavis[2417]: SpamControl: initializing Mail::SpamAssassin
Jun 20 13:42:17 s-projects amavis[2417]: SpamControl: init_pre_fork done
Jun 20 13:42:17 s-projects amavis[2417]: Net::Server: Beginning prefork (2 processes)
Jun 20 13:42:17 s-projects amavis[2417]: Net::Server: Starting "2" children
Jun 20 13:42:17 s-projects amavis[2460]: Net::Server: Child Preforked (2460)
Jun 20 13:42:17 s-projects amavis[2461]: Net::Server: Child Preforked (2461)
Jun 20 13:42:17 s-projects amavis[2417]: Net::Server: Parent ready for children.
Jun 20 13:42:17 s-projects amavis[2460]: TIMING [total 15 ms] - bdb-open: 15 (100%)100, rundown: 0 (0%)100
Jun 20 13:42:17 s-projects amavis[2461]: TIMING [total 12 ms] - bdb-open: 12 (100%)100, rundown: 0 (0%)100
Jun 20 13:42:22 s-projects sendmail[2459]: alias database /etc/aliases rebuilt by root
Jun 20 13:42:22 s-projects sendmail[2459]: /etc/aliases: 77 aliases, longest 10 bytes, 779 bytes total
Jun 20 13:42:22 s-projects postfix/postfix-script: starting the Postfix mail system
Jun 20 13:42:23 s-projects postfix/master[2507]: daemon started -- version 2.3.3, configuration /etc/postfix
Jun 20 13:42:23 s-projects postfix/qmgr[2522]: fatal: unsupported dictionary type: mysql
Jun 20 13:42:24 s-projects postfix/master[2507]: warning: process /usr/libexec/postfix/qmgr pid 2522 exit status 1
Jun 20 13:42:24 s-projects postfix/master[2507]: warning: /usr/libexec/postfix/qmgr: bad command startup -- throttling
Jun 20 13:43:24 s-projects postfix/qmgr[2883]: fatal: unsupported dictionary type: mysql
Jun 20 13:43:25 s-projects postfix/master[2507]: warning: process /usr/libexec/postfix/qmgr pid 2883 exit status 1
Jun 20 13:43:25 s-projects postfix/master[2507]: warning: /usr/libexec/postfix/qmgr: bad command startup -- throttling
Jun 20 13:44:25 s-projects postfix/qmgr[2921]: fatal: unsupported dictionary type: mysql
Jun 20 13:44:26 s-projects postfix/master[2507]: warning: process /usr/libexec/postfix/qmgr pid 2921 exit status 1
Jun 20 13:44:26 s-projects postfix/master[2507]: warning: /usr/libexec/postfix/qmgr: bad command startup -- throttling
Jun 20 13:45:01 s-projects pop3d: Connection, ip=[::ffff:127.0.0.1]
Jun 20 13:45:01 s-projects pop3d: Disconnected, ip=[::ffff:127.0.0.1]
Jun 20 13:45:01 s-projects imapd: Connection, ip=[::ffff:127.0.0.1]
Jun 20 13:45:01 s-projects imapd: Disconnected, ip=[::ffff:127.0.0.1], time=0
Jun 20 13:45:01 s-projects postfix/smtpd[2966]: fatal: unsupported dictionary type: mysql

till 21st June 2009 12:46

The postfix you installed does not support mysql, most likely because you used the wrong guide. You installed centos 5.3 with the 5.2 guide instead of using the 5.3 guide:

http://www.howtoforge.com/perfect-se...64-ispconfig-3

Stown 21st June 2009 12:52

ispconfig
 
Yes, but i did it because the guide for centos 5.3 is graphical based and i need plain text based.. I log in on my server because it at a company.

I thought the configs are the same.. but what is now the correct way to fix this? its only postfix problem. is there not a way to correct this?

Thank you for helping.

till 21st June 2009 12:53

Quote:

I thought the configs are the same.. but what is now the correct way to fix this? its only postfix problem. is there not a way to correct this?
install a postfix rpm that supports mysql.


All times are GMT +2. The time now is 15:17.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.