HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=27)
-   -   Many "Received: from" in header. (http://www.howtoforge.com/forums/showthread.php?t=36793)

Nicke 20th June 2009 02:06

Many "Received: from" in header.
 
Hi!

I have just installed ISPConfig3 using the "The Perfect Server - Ubuntu 9.04 [ISPConfig 3]".

Everything works great but my mail source looks like this when sending mail using the smtp-server:

Code:

From - Fri Jun 19 23:07:31 2009
X-Account-Key: account2
X-UIDL: UID6959-1208296696
X-Mozilla-Status: 0001
X-Mozilla-Status2: 00000000
X-Mozilla-Keys:                                                                               
Return-Path: <niklas@xxxx.nu>
Delivered-To: niklas@xxxx.se
Received: (qmail 57484 invoked from network); 19 Jun 2009 21:07:23 -0000
Received: from xxxx.nu (HELO server1.xxxx.nu) ([xx.xx.xx.xx])
          (envelope-sender <niklas@xxxx.nu>)
          by s60.loopia.se (qmail-ldap-1.03) with SMTP
          for <niklas@xxxx.se>; 19 Jun 2009 21:07:23 -0000
Received: from localhost (localhost.localdomain [127.0.0.1])
        by server1.xxxx.nu (Postfix) with ESMTP id 256E15A245E4
        for <niklas@xxxx.se>; Fri, 19 Jun 2009 23:07:23 +0200 (CEST)
X-Virus-Scanned: Debian amavisd-new at server1.xxxx.nu
Received: from server1.xxxx.nu ([127.0.0.1])
        by localhost (server1.xxxx.nu [127.0.0.1]) (amavisd-new, port 10024)
        with ESMTP id 2czgkYeOf9Vj for <niklas@xxxx.se>;
        Fri, 19 Jun 2009 23:07:22 +0200 (CEST)
Received: from [192.168.1.100] (90-xxx-xxx-xxx-xxx.xxx.xxx.com [90.xxx.xxx.xxx])
        (Authenticated sender: niklas@xxxx.nu)
        by server1.xxxx.nu (Postfix) with ESMTPSA id 57E3E5A245E3
        for <niklas@xxxx.se>; Fri, 19 Jun 2009 23:07:22 +0200 (CEST)
Message-ID: <4A3BFDF2.3000906@xxxx.nu>
Date: Fri, 19 Jun 2009 23:06:58 +0200
From: Niklas xxxxxx<niklas@xxxx.nu>
User-Agent: Thunderbird 2.0.0.21 (Windows/20090302)
MIME-Version: 1.0
To: Niklas xxxxxx<niklas@xxxx.se>
Subject: test
Content-Type: text/plain; charset=ISO-8859-1; format=flowed
Content-Transfer-Encoding: 7bit
X-Antivirus: AVG for E-mail 8.5.339 [270.12.80/2187]

test!

Is it possible to remove some of the "Received: from"-stuff? I cant see why the information about localhost and 127.0.0.1 should be there?

Thunderbird and AVG-adds some local stuff. :)

Edit:
One more thing.
I have two IPs. I have used the right IP in ISPConfig but Postfix seems to use the other one:
Received: from xxxx.nu (HELO server1.xxxx.nu) ([xxx.xxx.xxx.73])

If i put smtp_bind_address = xxx.xxx.xxx.184 i get "Jun 20 01:13:49 server1 amavis[1471]: (01471-02) (!)DENIED ACCESS from IP xxx.xxx.xxx.184, policy bank '' " in mail.log.

What now? :) Thanks!

till 20th June 2009 11:43

The received headers are ok and this is normal when you use the antivirus and spam scanner scanner like amavisd.

To your IP problem:

http://www.mail-archive.com/amavis-u.../msg10471.html

Nicke 20th June 2009 23:44

Quote:

Originally Posted by till (Post 195529)
The received headers are ok and this is normal when you use the antivirus and spam scanner scanner like amavisd.

To your IP problem:

http://www.mail-archive.com/amavis-u.../msg10471.html

Thanks!

Btw.. my /var/log/ispconfig/ispconfig.log is empty.. what should be logged?

till 21st June 2009 13:44

errors. so if its empty, its fine.


All times are GMT +2. The time now is 08:37.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.