HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Server Operation (http://www.howtoforge.com/forums/forumdisplay.php?f=5)
-   -   Postfix, Dovecot, MySQL users - issue with SASL (http://www.howtoforge.com/forums/showthread.php?t=36613)

silviap 16th June 2009 15:40

Postfix, Dovecot, MySQL users - issue with SASL
 
Hello,

I installed on a CentOS 5 machine Postfix and Dovecot with MySQL users (I mainly followed this tutorial: http://wiki.dovecot.org/HowTo/Doveco...tfixAdminMySQL). This setup worked for me in the past, but now, I notice I can send emails out, but I cannot receive any.
In maillog I have:

postfix/smtpd: warning: SASL: Connect to private/auth failed: Connection refused
postfix/smtpd: fatal: no SASL authentication mechanisms
postfix/master: warning: process /usr/libexec/postfix/smtpd pid 7632 exit status 1
postfix/master: warning: /usr/libexec/postfix/smtpd: bad command startup -- throttling

Any suggestions?
Thanks!

falko 17th June 2009 13:08

Did you install any updates recently?
Have you tried to restart Postfix and saslauthd? What's in your smtpd.conf?

silviap 17th June 2009 13:22

Yes, the server was updated recently (not by me). I restarted all the services, I even re-installed Postfix and Dovecot.
The /usr/lib/sasl2/smtpd.conf file had the following line:
pwcheck_method: saslauthd

The output for "saslauthd -v" is:
saslauthd 2.1.22
authentication mechanisms: getpwent kerberos5 pam rimap shadow ldap

I tried adding mech_list: plain login, but nothing happened.

Thank you for your help!

falko 18th June 2009 14:11

Quote:

Originally Posted by silviap (Post 194827)
Yes, the server was updated recently (not by me). I restarted all the services, I even re-installed Postfix and Dovecot.

Ok, then you have to rebuild Postfix with MySQL support.


All times are GMT +2. The time now is 19:07.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.