HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=27)
-   -   /etc/postfix/aliases still not working. Please help! (http://www.howtoforge.com/forums/showthread.php?t=36353)

ignasigarcia 12th June 2009 09:45

/etc/postfix/aliases still not working. Please help!
 
Hi there! Hope someone can help me out with this becasuse I'm getting really desperate...

I have ISPC3 3.0.1.2 running on ubuntu 8.10. Everything's working great but local aliases, which are not processed at all. Postfix knows about the aliases file, with entries in main.cf:

alias_maps = hash:/etc/postfix/aliases
alias_database = hash:/etc/postfix/aliases

These are the contents of /etc/postfix/aliases

postmaster: adminisp@otherdomainiannotherserver.ltd

If I send a message to postmaster@anyvirtualdomaininispc3.ltd I get this in the log:

NOQUEUE: reject: RCPT from externaldomain.ltd[1.2.3.4]: 550 5.1.1 <postmaster@virtualdomaininispc3.ltd>: Recipient address rejected: User unknown in virtual mailbox table; from=<myaccount@externaldomain.ltd> to=<postmaster@virtualdomaininispc3.ltd> proto=ESMTP helo=<mailserver.externaldomain.ltd>

If I do add a malformed entry in /etc/postfix/aliases and run newaliases without any options I do get warnings/errors, so postfix IS looking at the right file.

On an opensuse server without ISPC3 (but with virtual users as well in a LDAP database), an aliases file such as this one in ubuntu works well.

Can anybody help me, please?

TIA,

Ignacio

rdv25772 12th June 2009 10:44

The aliases database is only used for the local server.

If your server is called server.mydomain.com an email send to postmaster@server.mydomain.com in your case will be forwarded to adminisp@otherdomainiannotherserver.ltd.

When you are sending an email to postmaster@anyvirtualdomaininispc3.ltd Postfix will not check the aliases database. You need to add the postmaster user to the virtual mailbox table of anyvirtualdomaininispc3.ltd. In that case you will be able to send it as you pleased.

What you were trying was to send an email to an unknown user in virtual mailbox table of the anyvirtualdomaininispc3.ltd domain. So the message is correct. Keep in mind that the aliases database is only for local use and not for a virtual mailbox.


All times are GMT +2. The time now is 06:23.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.