HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=16)
-   -   ruby errors (http://www.howtoforge.com/forums/showthread.php?t=36295)

-crisstm- 11th June 2009 15:08

ruby errors
 
i install centos 5.3 x86_64 and i have one error after install ruby cmd make

apachelib.c: In function ‘ap_chdir_file’:
apachelib.c:149: warning: ignoring return value of ‘chdir’, declared with attribute warn_unused_result
apachelib.c:154: warning: ignoring return value of ‘chdir’, declared with attribute warn_unused_result
apachelib.c: In function ‘rb_init_apache’:
apachelib.c:374: error: ‘OPT_INCNOEXEC’ undeclared (first use in this function)
apachelib.c:374: error: (Each undeclared identifier is reported only once
apachelib.c:374: error: for each function it appears in.)
make: *** [apachelib.o] Error 1

after that i cannot use apache because doesn't find mod_ruby.so file
can anyone help me?

-crisstm- 12th June 2009 14:25

solution
 
i found solution

cd /tmp
wget http://www.modruby.net/archive/mod_ruby-1.3.0.tar.gz
tar zxvf mod_ruby-1.3.0.tar.gz
cd mod_ruby-1.3.0/
./configure.rb --with-apr-includes=/usr/include/apr-1
then open /tmp/mod_rubyx.x.x folder
and there you have one file named apachelib.h
open that file put this '#define OPT_INCNOEXEC 32' after '#define APACHELIB_H'
and all working fine with make and make install comand. no error output anymore


All times are GMT +2. The time now is 10:23.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.