HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=27)
-   -   Newb: Update warning behind 'Monitor' tab (http://www.howtoforge.com/forums/showthread.php?t=36011)

Slowhand 5th June 2009 11:33

Newb: Update warning behind 'Monitor' tab
 
Hi,

I'm on Ubuntu 8.04 LTS...

Behind the 'Monitor' tab in ISPc 3 I get an amber warning flag saying:

Code:

Reading package lists...
Building dependency tree...
Reading state information...
The following NEW packages will be installed:
linux-image-2.6.24-24-server linux-ubuntu-modules-2.6.24-24-server
The following packages will be upgraded:
linux-image-server linux-server
2 upgraded, 2 newly installed, 0 to remove and 0 not upgraded.
Inst linux-image-2.6.24-24-server (2.6.24-24.53 Ubuntu:8.04/hardy-updates)
Inst linux-ubuntu-modules-2.6.24-24-server (2.6.24-24.39 Ubuntu:8.04/hardy-updates)
Inst linux-server [2.6.24.23.25] (2.6.24.24.26 Ubuntu:8.04/hardy-updates) []
Inst linux-image-server [2.6.24.23.25] (2.6.24.24.26 Ubuntu:8.04/hardy-updates)
Conf linux-image-2.6.24-24-server (2.6.24-24.53 Ubuntu:8.04/hardy-updates)
Conf linux-ubuntu-modules-2.6.24-24-server (2.6.24-24.39 Ubuntu:8.04/hardy-updates)
Conf linux-image-server (2.6.24.24.26 Ubuntu:8.04/hardy-updates)
Conf linux-server (2.6.24.24.26 Ubuntu:8.04/hardy-updates)

But when I do
Code:

sudo apt-get update
sudo apt-get upgrade

I get
Code:

Reading package lists... Done
Building dependency tree     
Reading state information... Done
The following packages have been kept back:
  linux-image-server linux-server
0 upgraded, 0 newly installed, 0 to remove and 2 not upgraded.

Am I doing something wrong?

I also get the flag that my ClamAV needs upgrading
Code:

WARNING: Local version: 0.94.2 Recommended version: 0.95.1
Why doesn't that get upgraded with the commands above?
Do I need to upgrade it manually for some reason?

Thanks :-)

Slowhand

Croydon 5th June 2009 12:33

Quote:

Originally Posted by Slowhand (Post 192381)
Hi,

I'm on Ubuntu 8.04 LTS...

Behind the 'Monitor' tab in ISPc 3 I get an amber warning flag saying:

Code:

Reading package lists...
Building dependency tree...
Reading state information...
The following NEW packages will be installed:
linux-image-2.6.24-24-server linux-ubuntu-modules-2.6.24-24-server
The following packages will be upgraded:
linux-image-server linux-server
2 upgraded, 2 newly installed, 0 to remove and 0 not upgraded.
Inst linux-image-2.6.24-24-server (2.6.24-24.53 Ubuntu:8.04/hardy-updates)
Inst linux-ubuntu-modules-2.6.24-24-server (2.6.24-24.39 Ubuntu:8.04/hardy-updates)
Inst linux-server [2.6.24.23.25] (2.6.24.24.26 Ubuntu:8.04/hardy-updates) []
Inst linux-image-server [2.6.24.23.25] (2.6.24.24.26 Ubuntu:8.04/hardy-updates)
Conf linux-image-2.6.24-24-server (2.6.24-24.53 Ubuntu:8.04/hardy-updates)
Conf linux-ubuntu-modules-2.6.24-24-server (2.6.24-24.39 Ubuntu:8.04/hardy-updates)
Conf linux-image-server (2.6.24.24.26 Ubuntu:8.04/hardy-updates)
Conf linux-server (2.6.24.24.26 Ubuntu:8.04/hardy-updates)

But when I do
Code:

sudo apt-get update
sudo apt-get upgrade

I get
Code:

Reading package lists... Done
Building dependency tree     
Reading state information... Done
The following packages have been kept back:
  linux-image-server linux-server
0 upgraded, 0 newly installed, 0 to remove and 2 not upgraded.

Am I doing something wrong?

I also get the flag that my ClamAV needs upgrading
Code:

WARNING: Local version: 0.94.2 Recommended version: 0.95.1
Why doesn't that get upgraded with the commands above?
Do I need to upgrade it manually for some reason?

Thanks :-)

Slowhand

try
apt-get dist-upgrade

For adding a volatile repository to apt (includes newer security updates for clamav) look at
http://www.debian.org/volatile/ maybe there's something like that for ubuntu too

Slowhand 5th June 2009 12:47

Quote:

Originally Posted by Croydon (Post 192405)
try
apt-get dist-upgrade

For adding a volatile repository to apt (includes newer security updates for clamav) look at
http://www.debian.org/volatile/ maybe there's something like that for ubuntu too

Hi mate ;-)

apt-get dist-upgrade certainly got me an upgrade but the error in ISPc is still there. Even after login out/in again.

Spurious error?

I'll look in to the clamAV thing you suggested. Thanks.

S

Slowhand 5th June 2009 13:09

Croydon,

The system update error disappeared when I restarted apache.

Thanks! :-)

S

Croydon 6th June 2009 19:54

Quote:

Originally Posted by Slowhand (Post 192417)
Croydon,

The system update error disappeared when I restarted apache.

Thanks! :-)

S

It didn't disappear because of the apache restart ;)
The update status is checked once an hour.


All times are GMT +2. The time now is 01:58.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.