HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=16)
-   -   ISPConfig & Bind chroot not starting (http://www.howtoforge.com/forums/showthread.php?t=3593)

awd.pt 9th April 2006 18:26

ISPConfig & Bind chroot not starting
 
Hi all,

Running CentOS 4.3, bind-chroot (rpm) this info might help you.

I think I've found an issue in /root/ispconfig/isp/conf/named.conf.master. Each time a change is made to DNS ISPConfig restarts BIND and copy that file (root/ispconfig/isp/conf/named.conf.master) to /etc/named.conf (simlink to /var/chroot/etc/named.conf), however there is a configuration mistake in named.conf.master, where is writen :
pid-file "/var/named/chroot/var/run/named/named.pid";
should be changed to :
pid-file "/var/run/named/named.pid";
because BIND is running in a chroot mode.
or
you HAVE TO:
cd /var/named/chroot/
mkdir -p var/named/chroot/var/run/named/
chmod 770 var/named/chroot/var/run/named/
chown root.named var/named/chroot/var/run/named/
or bind wil not work.

Please review this and correct me if I'm wrong.

Thanks
srosa

public_domain 29th January 2008 03:14

Running CentOS 4.3, bind-chroot (rpm) this info might help you.
 
get a reply? am having problem in centos 5.1 with bind chrooted

till 29th January 2008 10:28

Please configure the permissions of the bind directories as described in the perfect setup guide. Then make sure that the path for the bind config files is set correctly in ISPConfig under managament > server > settings.


All times are GMT +2. The time now is 19:22.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.