HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=16)
-   -   Rouge MX Record (http://www.howtoforge.com/forums/showthread.php?t=35865)

z33k3r 2nd June 2009 23:27

Rouge MX Record - [SOLVED]
 
Quick help topic:

I had a domain full functional and working, but then I realized that the mail server was set to Localhost when it was in actuality a remote server. So I changed it over to remote and saved. Now if I dig from the command line, I still get the localserver as the MX record. I need to clear it so that it looks to the outside world for direction...

How would one go about doing this?

till 3rd June 2009 09:09

MX records have nothing to do with the remote server setting. To change the mx server you have to change the dns settings for the domain

z33k3r 3rd June 2009 09:12

Ok, so...
 
Ok, I see you and raise you a, "Where/what do I change to maket his work?"

falko 3rd June 2009 16:53

You have to modify the DNS records on the authoritative nameservers for your domain. You can out these nameservers by running
Code:

dig ns yourdomain.com

z33k3r 3rd June 2009 18:45

So I have checked my sources and from the server, it states that the name servers are in the right place (off site). Using MXtoolbox.com, tested and verified that the MX pointed to a mail.domain.tld and then that resolved IP had a correct reverse DNS entry.

But... when I "dig type mx domain.tld" i get the sever's IP address... Thus my rouge record...

z33k3r 4th June 2009 08:16

Anybody have pointers here? I am not a DNS guy by any means...

till 4th June 2009 08:29

Please post the exact dig command you used and the completeoutput that you got.

z33k3r 4th June 2009 19:00

Sorry to change directions here, but I check DNS and it has updated fully. Now I started looking in the mail logs and I am getting the following in my Postfix logs (edited for privacy):

Code:

Jun  4 09:08:56 ts1 postfix/pickup[12452]: 26662C3409F: uid=33 from=<www-data>
Jun  4 09:08:56 ts1 postfix/cleanup[13168]: 26662C3409F: message-id=<20090604160856.26662C3409F@server.domain.tld>
Jun  4 09:08:56 ts1 postfix/qmgr[654]: 26662C3409F: from=<www-data@server.domain.tld>, size=1694, nrcpt=1 (queue active)
Jun  4 09:08:56 ts1 postfix/local[13261]: 26662C3409F: to=<user@targetdomain.tld>, relay=local, delay=0.06, delays=0.05/0/0/0.01, dsn=5.1.1, status=bounced (unknown user: "user")
Jun  4 09:08:56 ts1 postfix/cleanup[13168]: 36348C340BC: message-id=<20090604160856.36348C340BC@server.domain.tld>
Jun  4 09:08:56 ts1 postfix/bounce[13289]: 26662C3409F: sender non-delivery notification: 36348C340BC

As you can see, it's trying to deliver locally instead of on the appropriate remote server...

z33k3r 4th June 2009 19:22

Do I need to add a slave record or something in the DNS manager (I don't host the dns, though i have the req. DNS software installed for ISPC)?

falko 5th June 2009 13:17

Is targetdomain.tld listed in /etc/postfix/local-host-names?
What's in /etc/resolv.conf?


All times are GMT +2. The time now is 18:40.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.