HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=27)
-   -   Newb: ISPConfig not showing @ :8080 (http://www.howtoforge.com/forums/showthread.php?t=35785)

Slowhand 1st June 2009 14:27

Newb: ISPConfig not showing @ :8080
 
Hi,

I just completed the 'Perfect server install Ubuntu 8.04 TLS" install and the ISPConfig install.

I'm using the 64 bit version of 8.04 TLS if it makes a difference...

I'm getting "It works!" at 192.168.0.55 but nothing at 192.168.0.55:8080

These were the errors I got during the ISPConfig install:

I didn't install Courier or Bind.

Code:

>> Initial configuration 

Operating System: Debian Lenny/Sid or compatible

    Following will be a few questions for primary configuration so be careful.
    Default values are in [brackets] and can be accepted with <ENTER>.
    Tap in "quit" (without the quotes) to stop the installer.


Select language (en,de) [en]:

Installation mode (standard,expert) [standard]:

Full qualified hostname (FQDN) of the server, eg server1.domain.tld  [name.mynetwork]:

MySQL server hostname [localhost]:

MySQL root username [root]:

MySQL root password []: (Password here)

MySQL database to create [dbispconfig]:

MySQL charset [utf8]:

Generating a 2048 bit RSA private key
..+++
...+++
writing new private key to 'smtpd.key'
-----
You are about to be asked to enter information that will be incorporated
into your certificate request.
What you are about to enter is what is called a Distinguished Name or a DN.
There are quite a few fields but you can leave some blank
For some fields there will be a default value,
If you enter '.', the field will be left blank.
-----
Country Name (2 letter code) [AU]:UK
State or Province Name (full name) [Some-State]:I completed this
Locality Name (eg, city) []:I completed this
Organization Name (eg, company) [Internet Widgits Pty Ltd]:I completed this
Organizational Unit Name (eg, section) []:.
Common Name (eg, YOUR name) []:I completed this
Email Address []:I completed this
Configuring Jailkit
Configuring SASL
Configuring PAM
Configuring Courier
chmod: cannot access `/etc/courier/authmysqlrc~': No such file or directory

Warning: fopen(/etc/courier/authdaemonrc): failed to open stream: No such file or directory in /tmp/ispconfig3_install/install/lib/install.lib.php on line 244

Warning: filesize(): stat failed for /etc/courier/authdaemonrc in /tmp/ispconfig3_install/install/lib/install.lib.php on line 247
Configuring Spamassassin

Warning: fopen(/etc/default/spamassassin): failed to open stream: No such file or directory in /tmp/ispconfig3_install/install/lib/install.lib.php on line 244

Warning: filesize(): stat failed for /etc/default/spamassassin in /tmp/ispconfig3_install/install/lib/install.lib.php on line 247
Configuring Amavisd
adduser: The user `clamav' does not exist.
Configuring Getmail
Configuring Pureftpd
sh: /etc/pure-ftpd/conf/ChrootEveryone: No such file or directory
sh: /etc/pure-ftpd/conf/BrokenClientsCompatibility: No such file or directory
Configuring MyDNS
Configuring Apache
Configuring Firewall
Installing ISPConfig
ISPConfig Port [8080]:

Configuring DBServer
Installing Crontab
no crontab for root
no crontab for getmail
Restarting services ...
 * Stopping MySQL database server mysqld
  ...done.
 * Starting MySQL database server mysqld
  ...done.
 * Checking for corrupt, not cleanly closed and upgrade needing tables.
 * Stopping Postfix Mail Transport Agent postfix
  ...done.
 * Starting Postfix Mail Transport Agent postfix
  ...done.
 * Stopping SASL Authentication Daemon saslauthd
  ...done.
 * Starting SASL Authentication Daemon saslauthd
  ...done.
 * Restarting web server apache2
  ...fail!
Installation completed.

Nothing too serious to my newb eyes :-)

I'm also getting:

Code:

/var/log/apache2$ sudo tail error.log
[sudo] password for Me:
[Mon Jun 01 12:24:55 2009] [notice] Apache/2.2.8 (Ubuntu) PHP/5.2.4-2ubuntu5.6 with Suhosin-Patch mod_ssl/2.2.8 OpenSSL/0.9.8g configured -- resuming normal operations
[Mon Jun 01 12:32:16 2009] [error] [client 192.168.0.6] PHP Fatal error:  Allowed memory size of 262144 bytes exhausted (tried to allocate 8192 bytes) in /usr/local/ispconfig/interface/lib/classes/db_mysql.inc.php on line 1
[Mon Jun 01 12:59:47 2009] [notice] caught SIGWINCH, shutting down gracefully
[Mon May 26 01:01:25 2008] [notice] suEXEC mechanism enabled (wrapper: /usr/lib/apache2/suexec)
PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/lib/php5/20060613/imap.so' - /usr/lib/php5/20060613/imap.so: cannot open shared object file: No such file or directory in Unknown on line 0
PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/lib/php5/20060613/htscanner.so' - /usr/lib/php5/20060613/htscanner.so: cannot open shared object file: No such file or directory in Unknown on line 0
[Mon May 26 01:01:26 2008] [notice] Apache/2.2.8 (Ubuntu) PHP/5.2.4-2ubuntu5.6 with Suhosin-Patch mod_ssl/2.2.8 OpenSSL/0.9.8g configured -- resuming normal operations
[Mon May 26 01:02:00 2008] [error] [client 192.168.0.6] PHP Fatal error:  Allowed memory size of 262144 bytes exhausted (tried to allocate 8192 bytes) in /usr/local/ispconfig/interface/lib/classes/db_mysql.inc.php on line 1
[Mon May 26 01:02:13 2008] [error] [client 192.168.0.6] PHP Fatal error:  Allowed memory size of 262144 bytes exhausted (tried to allocate 8192 bytes) in /usr/local/ispconfig/interface/lib/classes/db_mysql.inc.php on line 1
[Mon Jun 01 14:59:52 2009] [error] [client 192.168.0.6] PHP Fatal error:  Allowed memory size of 262144 bytes exhausted (tried to allocate 8192 bytes) in /usr/local/ispconfig/interface/lib/classes/db_mysql.inc.php on line 1

What did I do wrong?

Slowhand

Slowhand 1st June 2009 16:09

Sorry, that's ISPConfig 3.0.1.3

Slow

till 2nd June 2009 10:43

Please edit the file /etc/php5/apache2/php.ini and change the memory limit to

memory_limit = 64M

and then restart apache.

Slowhand 2nd June 2009 11:20

Quote:

Originally Posted by till (Post 191557)
Please edit the file /etc/php5/apache2/php.ini and change the memory limit to

memory_limit = 64M

and then restart apache.

Till,

Thanks for your time...

I did exactly that a few minutes before your post. I actually set the mem to 128 and the max execution time to 180 secs but I'm still getting nothing at :8080.

The log says:
Code:

[Tue Jun 02 09:42:57 2009] [notice] caught SIGWINCH, shutting down gracefully
[Tue Jun 02 09:43:07 2009] [notice] suEXEC mechanism enabled (wrapper: /usr/lib/apache2/suexec)
PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/lib/php5/20060613/imap.so' - /usr/lib/php5/20060613/imap.so: cannot open shared object file: No such file or directory in Unknown on line 0
PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/lib/php5/20060613/htscanner.so' - /usr/lib/php5/20060613/htscanner.so: cannot open shared object file: No such file or directory in Unknown on line 0
[Tue Jun 02 09:43:07 2009] [notice] Apache/2.2.8 (Ubuntu) PHP/5.2.4-2ubuntu5.6 with Suhosin-Patch mod_ssl/2.2.8 OpenSSL/0.9.8g mod_perl/2.0.3 Perl/v5.8.8 configured -- resuming normal operations
[Tue Jun 02 09:43:22 2009] [error] [client 192.168.0.6] PHP Fatal error:  Allowed memory size of 262144 bytes exhausted (tried to allocate 8192 bytes) in /usr/local/ispconfig/interface/lib/classes/db_mysql.inc.php on line 1

Any ideas?

Slowhand

Croydon 2nd June 2009 11:24

Quote:

Originally Posted by Slowhand (Post 191577)
Allowed memory size of 262144 bytes exhausted

That looks like 256KB instead of 128MB of memory limit.
Did you change the correct php.ini?


In addition to that: it's "only" a warning in the log, but did you forget to install php-imap?

Slowhand 2nd June 2009 12:04

Quote:

Originally Posted by Croydon (Post 191579)
That looks like 256KB instead of 128MB of memory limit.
Did you change the correct php.ini?

In addition to that: it's "only" a warning in the log, but did you forget to install php-imap?

Hi mate,

I definitely changed /etc/php5/apache2/php.ini. Under 'Resource limits'.

I installed php5-imap. and restarted apache2. Still nothing.

Logs now:
Code:

/var/log/apache2$ sudo tail error.log
PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/lib/php5/20060613/imap.so' - /usr/lib/php5/20060613/imap.so: cannot open shared object file: No such file or directory in Unknown on line 0
PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/lib/php5/20060613/htscanner.so' - /usr/lib/php5/20060613/htscanner.so: cannot open shared object file: No such file or directory in Unknown on line 0
[Tue Jun 02 10:55:21 2009] [notice] Apache/2.2.8 (Ubuntu) PHP/5.2.4-2ubuntu5.6 with Suhosin-Patch mod_ssl/2.2.8 OpenSSL/0.9.8g mod_perl/2.0.3 Perl/v5.8.8 configured -- resuming normal operations
[Tue Jun 02 10:57:26 2009] [notice] caught SIGWINCH, shutting down gracefully
[Tue Jun 02 10:57:36 2009] [notice] suEXEC mechanism enabled (wrapper: /usr/lib/apache2/suexec)
PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/lib/php5/20060613/htscanner.so' - /usr/lib/php5/20060613/htscanner.so: cannot open shared object file: No such file or directory in Unknown on line 0
[Tue Jun 02 10:57:36 2009] [notice] Apache/2.2.8 (Ubuntu) PHP/5.2.4-2ubuntu5.6 with Suhosin-Patch mod_ssl/2.2.8 OpenSSL/0.9.8g mod_perl/2.0.3 Perl/v5.8.8 configured -- resuming normal operations
[Tue Jun 02 10:58:16 2009] [error] [client 192.168.0.6] PHP Fatal error:  Allowed memory size of 262144 bytes exhausted (tried to allocate 8192 bytes) in /usr/local/ispconfig/interface/lib/classes/db_mysql.inc.php on line 1
[Tue Jun 02 10:58:19 2009] [error] [client 192.168.0.6] PHP Fatal error:  Allowed memory size of 262144 bytes exhausted (tried to allocate 8192 bytes) in /usr/local/ispconfig/interface/lib/classes/db_mysql.inc.php on line 1
[Tue Jun 02 11:02:57 2009] [error] [client 192.168.0.6] PHP Fatal error:  Allowed memory size of 262144 bytes exhausted (tried to allocate 8192 bytes) in /usr/local/ispconfig/interface/lib/classes/db_mysql.inc.php on line 1

Sorry to be making a meal of this...

Slowhand

Croydon 2nd June 2009 12:30

I am confused about the error message of 256K memory limit. This is really weird.

Could you post the output of:
grep -r 'memory_limit' /etc/php5/*

Slowhand 2nd June 2009 12:33

Solved!
 
Well, I don't know what's going on...

I thought I'd made a typo in the php.ini file when I saw it said 128M in the memory allocation so I changed it to 128MB.

I then re-downloaded php onto my Mac and checked the php.ini.recommended file. This said 128M.

When I changed the file back to 128M on my Ubuntu box and restarted apache2, the ISPConfig login page appeared!

Nothing really changed from previously as it said 128M before...

Go figure :-)

Thanks :-)

Slowhand

Slowhand 2nd June 2009 12:39

Quote:

Originally Posted by Croydon (Post 191597)
I am confused about the error message of 256K memory limit. This is really weird.

Could you post the output of:
grep -r 'memory_limit' /etc/php5/*

Croydon,

I get

Code:

sudo grep -r 'memory_limit' /etc/php5/*
/etc/php5/apache2/php.ini:memory_limit = 128M      ; Maximum amount ofmemory a script may consume (16MB)
/etc/php5/cli/php.ini:memory_limit = 128MB    ; Maximum amount of memory a script may consume (32MB)

Now my error is gone, should I try to lower the memory until it triggers again or is 128MB considered normal?

The 'Perfect server' tut suggested 32MB...?

Slowhand

Croydon 2nd June 2009 12:58

/etc/php5/cli/php.ini:memory_limit = 128MB ; Maximum amount of memory a script may consume (32MB)

I think this could lead to problems with the server cli script. It should be 128M.

I don't think it hurts having 128M there, but you could lower it to 32M if you don't think there will be memory consuming scripts.
I would'nt lower the cli version, just the apache.


All times are GMT +2. The time now is 12:12.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.