HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=27)
-   -   SMTP Auth fail (http://www.howtoforge.com/forums/showthread.php?t=35678)

0x1a4 29th May 2009 18:53

SMTP Auth fail
 
OK, I have this mostly working. I can use webmail fine. I can receive mail through POP fine. I can get to the ISPConfig web page fine. When I try to send mail from Outlook, I just keep getting the login password box. I am running ispconfig 3.0.1.1. I followed http://www.howtoforge.com/perfect-se...10-ispconfig-3

I also can't login via ftp, but I'm not as concerned about that. Let me know if you need other information, and Thanks!

uname -a:
Quote:

Linux xxx.xxxx.com 2.6.27.21-170.2.56.fc10.x86_64 #1 SMP Mon Mar 23 23:08:10 EDT 2009 x86_64 x86_64 x86_64 GNU/Linux
/var/log/secure:
Quote:

mail saslauthd[2309]: pam_mysql - SELECT returned no result.
/var/log/maillog:
Quote:

May 29 10:30:52 mail postfix/smtpd[3094]: connect from unknown[xxx.xxx.xxx.xxx]
May 29 10:30:52 mail postfix/smtpd[3094]: warning: unknown[xxx.xxx.xxx.xxx]: SASL LOGIN authentication failed: authentication failure
May 29 10:30:52 mail postfix/smtpd[3094]: lost connection after AUTH from unknown[xxx.xxx.xxx.xxx]
/var/log/messages:
Quote:

May 29 10:30:41 mail saslauthd[2310]: do_auth : auth failure: [user=xxxx] [service=smtp] [realm=xxxxxx.com] [mech=pam] [reason=PAM auth error]
And here's some config files:

/etc/pam.d/smtp
Quote:

auth required pam_mysql.so user=ispconfig passwd=xxxxxxxxxxxxxxxxxxx host=localhost db=dbispconfig table=mail_user usercolumn=email passwdcolumn=password crypt=1
account sufficient pam_mysql.so user=ispconfig passwd=xxxxxxxxxxxxxxxxxx host=localhost db=dbispconfig table=mail_user usercolumn=email passwdcolumn=password crypt=1

/usr/lib64/sasl2/smtpd.conf
Quote:

pwcheck_method: saslauthd
mech_list: plain login
/etc/postfix/main.cf
Quote:

queue_directory = /var/spool/postfix
command_directory = /usr/sbin
daemon_directory = /usr/libexec/postfix
data_directory = /var/lib/postfix
mail_owner = postfix
inet_interfaces = all
mydestination = xxxx.xxxxx.com, localhost, localhost.localdomain
unknown_local_recipient_reject_code = 550
alias_maps = hash:/etc/aliases
alias_database = hash:/etc/aliases
debug_peer_level = 2
debugger_command =
PATH=/bin:/usr/bin:/usr/local/bin:/usr/X11R6/bin
ddd $daemon_directory/$process_name $process_id & sleep 5
sendmail_path = /usr/sbin/sendmail.postfix
newaliases_path = /usr/bin/newaliases.postfix
mailq_path = /usr/bin/mailq.postfix
setgid_group = postdrop
html_directory = no
manpage_directory = /usr/share/man
sample_directory = /usr/share/doc/postfix-2.5.5/samples
readme_directory = /usr/share/doc/postfix-2.5.5/README_FILES
inet_protocols = all
myhostname = xxx.xxxxx.com
mynetworks = 127.0.0.0/8
virtual_alias_domains =
virtual_alias_maps = proxy:mysql:/etc/postfix/mysql-virtual_forwardings.cf, mysql:/etc/postfix/mysql-virtual_email2email.cf
virtual_mailbox_domains = proxy:mysql:/etc/postfix/mysql-virtual_domains.cf
virtual_mailbox_maps = proxy:mysql:/etc/postfix/mysql-virtual_mailboxes.cf
virtual_mailbox_base = /var/vmail
virtual_uid_maps = static:5000
virtual_gid_maps = static:5000
smtpd_sasl_auth_enable = yes
broken_sasl_auth_clients = yes
smtpd_sasl_authenticated_header = yes
smtpd_recipient_restrictions = permit_mynetworks, permit_sasl_authenticated, check_recipient_access mysql:/etc/postfix/mysql-virtual_recipient.cf, reject_unauth_destination
#smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject _unauth_destination
smtpd_use_tls = yes
smtpd_tls_security_level = may
smtpd_tls_cert_file = /etc/postfix/smtpd.cert
smtpd_tls_key_file = /etc/postfix/smtpd.key
transport_maps = proxy:mysql:/etc/postfix/mysql-virtual_transports.cf
relay_domains = mysql:/etc/postfix/mysql-virtual_relaydomains.cf
virtual_create_maildirsize = yes
virtual_maildir_extended = yes
virtual_mailbox_limit_maps = proxy:mysql:/etc/postfix/mysql-virtual_mailbox_limit_maps.cf
virtual_mailbox_limit_override = yes
virtual_maildir_limit_message = "The user you are trying to reach is over quota."
virtual_overquota_bounce = yes
proxy_read_maps = $local_recipient_maps $mydestination $virtual_alias_maps $virtual_alias_domains $virtual_mailbox_maps $virtual_mailbox_domains $relay_recipient_maps $relay_domains $canonical_maps $sender_canonical_maps $recipient_canonical_maps $relocated_maps $transport_maps $mynetworks $virtual_mailbox_limit_maps
smtpd_sender_restrictions = check_sender_access mysql:/etc/postfix/mysql-virtual_sender.cf
smtpd_client_restrictions = check_client_access mysql:/etc/postfix/mysql-virtual_client.cf
maildrop_destination_concurrency_limit = 1
maildrop_destination_recipient_limit = 1
virtual_transport = maildrop
header_checks = regexp:/etc/postfix/header_checks
mime_header_checks = regexp:/etc/postfix/mime_header_checks
nested_header_checks = regexp:/etc/postfix/nested_header_checks
body_checks = regexp:/etc/postfix/body_checks
content_filter = amavis:[127.0.0.1]:10024
receive_override_options = no_address_mappings
relayhost =
mailbox_size_limit = 0
message_size_limit = 0
smtpd_sasl_local_domain =
smtpd_sasl_security_options = noanonymous

0x1a4 29th May 2009 21:40

From reading and trying a few things, killing saslauthd and starting it using:

Code:

saslauthd -a pam  -n 5  -V -c -m /var/spool/postfix/var/run/saslauthd -r -d
from the command line works. I'm guesing it's the -r that I need. not sure how to make this automatic, though.

Edit:
OK, got it. In /etc/sysconfig/saslauthd I added -r to the flags line. Any drawbacks to doing this?

Quote:

# Directory in which to place saslauthd's listening socket, pid file, and so
# on. This directory must already exist.
SOCKETDIR=/var/run/saslauthd

# Mechanism to use when checking passwords. Run "saslauthd -v" to get a list
# of which mechanism your installation was compiled with the ablity to use.
MECH=pam

# Additional flags to pass to saslauthd on the command line. See saslauthd(8)
# for the list of accepted flags.
FLAGS=-r

falko 30th May 2009 12:28

Strange - I didn't have to do this when I wrote the tutorial...
Anyways, I'm glad that it's working now for you. :)

0x1a4 2nd June 2009 17:54

Thanks! and a great tutorial as well!

denni 1st July 2009 17:29

Vas unable to send and recive after fresh installation - but solved
 
Did fallow the tutorial http://howtoforge.com/perfect-server...04-ispconfig-2
and everything worked out well but I was unable to send and recive e-mail and.

The solution was to delete previous certificates and make new ones according to http://howtoforge.com/perfect-server...ispconfig-2-p5

Did also try out the ispconfig3 setup but the email did not work. Must be because unable to config the internet interface with the static ip address and have to use dhcp

/etc/network/interfaces
#######
# The primary network interface
auto eth1
iface eth1 inet dhcp
#######


All times are GMT +2. The time now is 12:57.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.