HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=4)
-   -   Postfix Will Receive but NOT Send Mail (http://www.howtoforge.com/forums/showthread.php?t=35572)

techy7636 27th May 2009 13:19

Postfix Will Receive but NOT Send Mail
 
Hey All

I'm having problems with my Postfix setup - it will currently only send and receive through SquirrelMail but will only receive and NOT send via Outlook or other mail clients.

Every time I try to send I receive the following message:

Sending failed; Reason:554 5.7.1 : Relay access denied

My config is set up as follows:

myhostname = mail.mydomainxxx.com
mynetworks_style = subnet
alias_maps = hash:/etc/aliases
alias_database = hash:/etc/aliases
myorigin = /etc/mailname
mydestination = mydomainxxx.com, $myhostname, localhost.$mydomain, localhost, $mydomain
relayhost =
mydomain = mydomainxxx.com
mailbox_command = procmail -a "$EXTENSION"
mailbox_size_limit = 0
recipient_delimiter = +
broken_sasl_auth_clients = yes
smtpd_recipient_restrictions = permit_sasl_authenticated permit_mynetworks reject_unauth_destination permit permit_inet_interfaces
smtpd_tls_auth_only = no
smtp_use_tls = yes
smtp_tls_note_starttls_offer = yes
smtpd_tls_loglevel = 1
smtpd_tls_received_header = yes
smtpd_tls_session_cache_timeout = 3600s
tls_random_source = dev:/dev/urandom
virtual_alias_maps = hash:/etc/postfix/virtual
message_size_limit = 20480000
smtpd_sasl_security_options =
inet_interfaces = all
inet_protocols = all
smtpd_sasl_auth_enable = yes

And my log records the following:

May 27 12:06:05 mydomainxxx postfix/smtpd[25959]: connect from sender1.othermail.com[72.5.230.103]
May 27 12:06:05 mydomainxxx postfix/smtpd[25959]: NOQUEUE: reject: RCPT from sender1.othermail.com[72.5.230.103]: 554 5.7.1 <other@yahoo.com>: Relay access denied; from=<rich@mydomainxxx.com> to=<other@yahoo.com> proto=ESMTP helo=<172.31.252.89>
May 27 12:06:06 mydomainxxx postfix/smtpd[25959]: disconnect from sender1.othermail.com[72.5.230.103]

Any help would be greatly appreciated,


Rich

falko 28th May 2009 11:41

You must enable "Server requires authentication" in your email client.

techy7636 28th May 2009 11:59

Hey Falko

I've tried that but without success.

Out of interest do I need a TLS certificate installed for SMTP relay?


Rich

falko 29th May 2009 18:29

No, that's not necessary.

dalitso 29th May 2009 20:34

Try assigning your ISP's SMTP server in your postifix config

relayhost = smtp.domain.com

tukangnggame 2nd June 2009 12:33

comment your relayhost if you don't use it

#relayhost =


All times are GMT +2. The time now is 20:51.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.