HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=27)
-   -   sql error - monitor show jobqueue (http://www.howtoforge.com/forums/showthread.php?t=35509)

marciliomcm 26th May 2009 07:59

sql error - monitor show jobqueue
 
Hi,

I try monitor jobqueue and see this error at click.

Ispconfig 3.0.1.12
Monitor
show jobqueue

Error:
You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'AND sys_perm_user like '%r%') OR (sys_groupid IN (0) AND sys_perm_group like '%' at line 1


Debian 5.0.1 x64
ii mysql-client 5.0.51a-24+lenny1 MySQL database client (metapackage depending on the latest ver
ii mysql-client-5.0 5.0.51a-24+lenny1 MySQL database client binaries
ii mysql-common 5.0.51a-24+lenny1 MySQL database common files
ii mysql-server 5.0.51a-24+lenny1 MySQL database server (metapackage depending on the latest ver
ii mysql-server-5.0 5.0.51a-24+lenny1 MySQL database server binaries

thks,

Marcilio

till 26th May 2009 13:37

I will check that.

till 27th May 2009 15:07

I'am not able to reproduce this on Debiab Lenny 32 Bit with the same mysql version. It looks like you either edited your admin user manually or used a manually created admin user to login to ispconfig were you did not set the default group correctly.

virtualm 11th July 2009 10:11

Still don't fixed in 3.0.1.3
Also my thread here: http://www.howtoforge.com/forums/sho...sys_perm_group

After little debuging when I select Show Jobqueue the session var $_SESSION["s"]["user"]["userid"] is empty, causing the $sql var to be ((sys_userid= AND... which cause the error. Another call to getAuthSQL from login or other menus works ok, only when called from Show jobqueue have this error.

Ubuntu 9.04 64 bit, ispconfig 3.0.1.3

Regards,
VM

virtualm 25th July 2009 06:51

Possible problem
 
Fund the problem:

In datalog_list.php when you loop through servers (foreach ($servers as $s)...) the $s variable somehow alters the session $_SESSION["s"] variable. I don't know why this is happening.. Changing the name to $temps for ex solves the problem.
Sorry for the delay but i was away for a few weeks.

Regards,
VM


All times are GMT +2. The time now is 18:18.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.