HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   General (http://www.howtoforge.com/forums/forumdisplay.php?f=25)
-   -   Ipplan moved from ispconfig 2 to ispconfig 3 login problem (http://www.howtoforge.com/forums/showthread.php?t=35305)

baskin 21st May 2009 17:53

Ipplan moved from ispconfig 2 to ispconfig 3 login problem
 
I have a working installation of ipplan on a ispconfig 2 system (opensuse 10.0).

I have moved the installation to a newly created ispconfig 3 system (opensuse 11.1). I moved the files and export-import the database.

All seems well and when i access the home page of ipplan (http://www.mydomain/ipplan) everything looks normal.

The problem is that i cannot login to ipplan neither with the accounts created in the database or the admin account that exists in the config.php file of ipplan.

From the faq of ipplan:

Quote:

* Q: I have another .htaccess file higher up in my web server tree which confuses IPplan’s authentication - how can I use both?

A: Use external authentication to obtain the previous login credentials of the superior directory - see the documentation.

A: Create an .htaccess file in the IPplan subdirectory consisting of only one line:

Order Deny,Allow

This will make the authentication that was made by a superior-directory .htaccess gone.
It seems that something is confusing ipplan's authentication although i have made an .htaccess file in the ipplan's folder as stated in the faq.

Any help is appreciated.

falko 22nd May 2009 16:20

Can you post the vhost configuration?

baskin 22nd May 2009 17:49

Sure. Here is the requested vhost configuration:

Quote:

<Directory /srv/www/cywn.gr>
AllowOverride None
Order Deny,Allow
Deny from all
</Directory>

<VirtualHost *:80>
DocumentRoot /srv/www/cywn.gr/web

ServerName cywn.gr
ServerAdmin webmaster@cywn.gr

ErrorLog /var/log/ispconfig/httpd/cywn.gr/error.log

ErrorDocument 400 /error/400.html
ErrorDocument 401 /error/401.html
ErrorDocument 403 /error/403.html
ErrorDocument 404 /error/404.html
ErrorDocument 405 /error/405.html
ErrorDocument 500 /error/500.html
ErrorDocument 503 /error/503.html

<Directory /srv/www/cywn.gr/web>
Options FollowSymLinks
AllowOverride Indexes AuthConfig Limit
Order allow,deny
Allow from all

# ssi enabled
AddType text/html .shtml
AddOutputFilter INCLUDES .shtml
Options +Includes
</Directory>
<Directory /srv/www/clients/client2/web4/web>
Options FollowSymLinks
AllowOverride Indexes AuthConfig Limit
Order allow,deny
Allow from all

# ssi enabled
AddType text/html .shtml
AddOutputFilter INCLUDES .shtml
Options +Includes
</Directory>

# cgi enabled
<Directory /srv/www/clients/client2/web4/cgi-bin>
Order allow,deny
Allow from all
</Directory>
ScriptAlias /cgi-bin/ /srv/www/clients/client2/web4/cgi-bin/
AddHandler cgi-script .cgi
AddHandler cgi-script .pl
# suexec enabled
SuexecUserGroup web4 client2
# php as fast-cgi enabled
<Directory /srv/www/cywn.gr/web>
AddHandler fcgid-script .php .php3 .php4 .php5
FCGIWrapper /srv/www/php-fcgi-scripts/web4/.php-fcgi-starter .php
Options +ExecCGI
AllowOverride all
Order allow,deny
Allow from all
</Directory>


</VirtualHost>

falko 23rd May 2009 13:50

Can you change all
Code:

AllowOverride Indexes AuthConfig Limit
lines to
Code:

AllowOverride All
and restart Apache? Does it work then?

baskin 25th May 2009 20:07

Sorry for the late reply, i was away from civilization.

No is not working. I have the same behavior as before. It keeps asking for username and password.

baskin 27th May 2009 19:27

After the latest update (3.0.1.3) my vhost configuration is:

Quote:

<Directory /srv/www/cywn.gr>
AllowOverride None
Order Deny,Allow
Deny from all
</Directory>

<VirtualHost *:80>
DocumentRoot /srv/www/cywn.gr/web

ServerName cywn.gr
ServerAdmin webmaster@cywn.gr

ErrorLog /var/log/ispconfig/httpd/cywn.gr/error.log

Alias /error/ "/srv/www/cywn.gr/error/"

ErrorDocument 400 /error/400.html
ErrorDocument 401 /error/401.html
ErrorDocument 403 /error/403.html
ErrorDocument 404 /error/404.html
ErrorDocument 405 /error/405.html
ErrorDocument 500 /error/500.html
ErrorDocument 503 /error/503.html

<Directory /srv/www/cywn.gr/web>
Options FollowSymLinks
AllowOverride Indexes AuthConfig Limit FileInfo
Order allow,deny
Allow from all

# ssi enabled
AddType text/html .shtml
AddOutputFilter INCLUDES .shtml
Options +Includes
</Directory>
<Directory /srv/www/clients/client2/web4/web>
Options FollowSymLinks
AllowOverride Indexes AuthConfig Limit FileInfo
Order allow,deny
Allow from all

# ssi enabled
AddType text/html .shtml
AddOutputFilter INCLUDES .shtml
Options +Includes
</Directory>

# cgi enabled
<Directory /srv/www/clients/client2/web4/cgi-bin>
Order allow,deny
Allow from all
</Directory>
ScriptAlias /cgi-bin/ /srv/www/clients/client2/web4/cgi-bin/
AddHandler cgi-script .cgi
AddHandler cgi-script .pl
# suexec enabled
SuexecUserGroup web4 client2
# php as fast-cgi enabled
<Directory /srv/www/cywn.gr/web>
AddHandler fcgid-script .php .php3 .php4 .php5
FCGIWrapper /srv/www/php-fcgi-scripts/web4/.php-fcgi-starter .php
Options +ExecCGI
AllowOverride all
Order allow,deny
Allow from all
</Directory>

</VirtualHost>
I have also tried to change all

Quote:

AllowOverride Indexes AuthConfig Limit FileInfo
to

Quote:

AllowOverride All
with no luck.

I have also checked that ipplan is working when i moved it to a test server without ispconfig and vhosts (just one site).


All times are GMT +2. The time now is 02:31.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.