HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=27)
-   -   Website disappers when SSL is added (http://www.howtoforge.com/forums/showthread.php?t=35185)

ago2guy 19th May 2009 19:01

Website disappers when SSL is added
 
I had a site up and running and then decide to add an SSL cert to the site. After going through the process the website now only displays the “It Works” page.
It does however display the correct website if I enter the IP address but not the domain name.


It appears that the apache default page is the page I see while requesting the www.domain.tld but it gets that correct site when entering the IP address.

A dig at the host name server gives the correct IP to domain name translation.

Thoughts?

till 19th May 2009 23:24

Please make sure that you selected the correct IP address in the website settings in ispconfig and not *, as * can not be used together with SSL certificates with the apache webserver.

ago2guy 19th May 2009 23:32

Thanks Till

Yes, It was a unique IP. I have since dropped the cert and am just trying to get it running again.
sites-available is correct.

if I run apache2ctl restart I get
[warn] VirtualHost 10.0.0.121:80 overlaps with VirtualHost 10.0.0.121:80, the first has precedence, perhaps you need a NameVirtualHost directive

If I run a2ensite domain.tld I get
ERROR: Site domain.tld does not exist!

It reolves to the IP but I get the apache default index.html if I try the www.domain.tld itself.

As stated this was working before I tried to add a cert on a website with a static exclusive IP address.

Thoughts?

ago2guy 19th May 2009 23:55

Oh No...I think I upset till in the gerneal fourm ... sorry.

ago2guy 20th May 2009 01:02

[Tue May 19 18:59:02 2009] [warn] NameVirtualHost 10.0.0.120:443 has no VirtualHosts
/usr/share/getmail4/getmailcore/baseclasses.py:26: DeprecationWarning: the sets module is deprecated
import sets
Error: configuration file /etc/getmail/*.conf does not exist

ago2guy 20th May 2009 01:21

Oh man its getting worse

root@glue:/etc/apache2/sites-available# apache2ctl restart
[Tue May 19 19:20:05 2009] [warn] NameVirtualHost 10.0.0.120:80 has no VirtualHosts
[Tue May 19 19:20:05 2009] [warn] NameVirtualHost 10.0.0.120:443 has no VirtualHosts
[Tue May 19 19:20:05 2009] [warn] NameVirtualHost 10.0.0.121:443 has no VirtualHosts

ago2guy 20th May 2009 01:45

Well thats it...now it completely does not work.
I deleted all ips but two one for ispconfig and one for my domain
my site will resolve to the IP only

All because I tried to add an SSL Cert.

ago2guy 20th May 2009 02:18

Delete and reinstall

bummer...not ready for production for sure.

Thanks

till 20th May 2009 09:57

Not sure what you did because adding a ssl cert does not cuse any problems on my servers, I'am doing that frequently. I use it in production for over a year without any problems.

ago2guy 22nd May 2009 00:32

Looks like I am not alone...Read down on this link...same issue

http://www.howtoforge.com/forums/showthread.php?t=35207


Quote:

Originally Posted by bryand1 (Post 189761)
Thank you for your response Falko, but now I have a more serious problem.

I am using ISPConfig 3. When enter my State, Locality, Organization, Organizational Unit, and Country information, I then hit "Create Certificate" but nothing generates...

I tried to do this a couple of times, and then I lost connection to my server and something went wrong? All of the sites on my server went down. Now I cannot get apache to work.

I tried to reboot the server and I am getting an error when I try to start the httpd.

What happened and how can I get my sites back up?



All times are GMT +2. The time now is 19:01.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.