HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=27)
-   -   Pure-ftp problem (http://www.howtoforge.com/forums/showthread.php?t=34933)

trexen 13th May 2009 14:47

Pure-ftp problem
 
Hi, cant log in to FTP true Router, but itīs no problem when login true LAN.

Syslog:
May 13 14:30:15 s08 pure-ftpd: (?@?) [ERROR] Sorry, invalid address given

i got port 20 & 21 open to the server.

rgds
//M

tio289 13th May 2009 16:00

Hi, ftp uses more ports that two(20,21). It uses random ports for passive connections. You must open/forward more ports..range of ports and configure these ports on pureftpd server. Or you can turn on on your router DMZ function --> All queries will be forwarded to IP in DMZ setting. For example:

http://downloads.best-top.sk/files/dmz.jpg

that is if your server is on LAN side. (IF you have public IP that you can optionaly use active mode). IF your server is on WAN side you must have turned on passive mode in your ftp client

BTW, this post more fall to general that ispconfig....moderator, would you move this post?:)

trexen 14th May 2009 19:36

Hi,
Thanks for replay.

whare do i put -p 5000-6000 som it always start whit that options som passive mode works, maybe in /etc/init.d/pure-ftp some whare ?
im using Debian5 Lenny.

//M

tio289 14th May 2009 19:38

better solution is turn on DMZ

trexen 14th May 2009 21:16

im testing ISPC3 on a temp site behind a router, so i cant move it to DMZ.

need help to start pure-ftp whit -p 5000-6000 =)

thanks
//M

--------------
Anyone ?

tio289 15th May 2009 12:53

can you draw, how look you network? router, server, client pc

trexen 15th May 2009 13:47

plz
 
Need help how to start pure-ftp whit -p 5000-6000 ?plz

trexen 16th May 2009 15:50

Need help how to start pure-ftp whit -p 5000-6000 ?plz
:confused:

trexen 18th May 2009 13:59

I still got problem, any help plz ? =)

//M :)

trexen 25th May 2009 17:25

I still got problem, any help plz ? =)

//M

50% Solution =)

add /etc/pure-ftpd/conf/PassivePortRange
and put 5000 6000 in the PassivePortRange file i create

and restart /etc/init.d/pure-ftpd-mysql restart

I now can login whit FTP but not upload any file =(


All times are GMT +2. The time now is 21:02.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.