HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=16)
-   -   Can Send email but not receive it using sendmail on debian (http://www.howtoforge.com/forums/showthread.php?t=3489)

ZeroDni 3rd April 2006 17:15

Can Send email but not receive it using sendmail on debian
 
every thing works great except for the reciveing of email it send out fine but not geting email back at all here is my mail.log


Apr 3 10:59:25 mxtest5 imaplogin: LOGOUT, user=web1_mishi, ip=[::ffff:127.0.0.1], headers=0, body=0, time=1
Apr 3 10:59:25 mxtest5 imaplogin: Connection, ip=[::ffff:127.0.0.1]
Apr 3 10:59:25 mxtest5 imaplogin: LOGIN, user=web1_mishi, ip=[::ffff:127.0.0.1], protocol=IMAP
Apr 3 10:59:25 mxtest5 imaplogin: LOGOUT, user=web1_mishi, ip=[::ffff:127.0.0.1], headers=0, body=0, time=0
Apr 3 10:59:27 mxtest5 imaplogin: Connection, ip=[::ffff:127.0.0.1]
Apr 3 10:59:27 mxtest5 imaplogin: LOGIN, user=web1_mishi, ip=[::ffff:127.0.0.1], protocol=IMAP
Apr 3 10:59:27 mxtest5 imaplogin: LOGOUT, user=web1_mishi, ip=[::ffff:127.0.0.1], headers=0, body=0, time=0
Apr 3 11:00:01 mxtest5 sm-msp-queue[6268]: File descriptors missing on startup: stdin; Bad file descriptor
Apr 3 11:05:39 mxtest5 sendmail[11333]: k33F5bMh011333: <mishi@virginiawebhost.com>... User unknown
Apr 3 11:05:39 mxtest5 sendmail[11333]: k33F5bMh011333: from=<webserviotest@gmail.com>, size=0, class=0, nrcpts=0, proto=ESMTP, daemon=Daemon0, relay=xproxy.gmail.com [66.249.82.205]
Apr 3 11:16:16 mxtest5 sendmail[21579]: k33FGFAL021579: <mishi@virginiawebhost.com>... User unknown
Apr 3 11:16:16 mxtest5 sendmail[21579]: k33FGFAL021579: from=<webserviotest@gmail.com>, size=0, class=0, nrcpts=0, proto=ESMTP, daemon=Daemon0, relay=xproxy.gmail.com [66.249.82.205]
Apr 3 11:16:22 mxtest5 sendmail[21580]: k33FGFhe021580: from=<webserviotest@gmail.com>, size=1369, class=0, nrcpts=1, msgid=<de5ab4130604030817i38d1b315kfbf40461891ef61 6@mail.gmail.com>, proto=ESMTP, daemon=Daemon0, relay=xproxy.gmail.com [66.249.82.204]
Apr 3 11:16:22 mxtest5 smrsh: uid 10001: attempt to use "procmail -f-" (stat failed)
Apr 3 11:16:22 mxtest5 sendmail[21673]: k33FGFhe021580: SYSERR(root): putbody: write error: Broken pipe
Apr 3 11:16:22 mxtest5 sendmail[21673]: k33FGFhe021580: 0: fl=0x0, mode=20666: CHR: dev=8/1, ino=650287, nlink=1, u/gid=0/0, size=0
Apr 3 11:16:22 mxtest5 sendmail[21673]: k33FGFhe021580: 1: fl=0x1, mode=20666: CHR: dev=8/1, ino=650287, nlink=1, u/gid=0/0, size=0
Apr 3 11:16:22 mxtest5 sendmail[21673]: k33FGFhe021580: 2: fl=0x1, mode=20666: CHR: dev=8/1, ino=650287, nlink=1, u/gid=0/0, size=0
Apr 3 11:16:22 mxtest5 sendmail[21673]: k33FGFhe021580: 3: fl=0x2, mode=140777: SOCK localhost->[[UNIX: /dev/log]]
Apr 3 11:16:22 mxtest5 sendmail[21673]: k33FGFhe021580: 5: fl=0x0, mode=100640: dev=8/1, ino=601926, nlink=1, u/gid=0/107, size=375
Apr 3 11:16:22 mxtest5 sendmail[21673]: k33FGFhe021580: 6: fl=0x8000, mode=100640: dev=8/1, ino=813275, nlink=1, u/gid=0/107, size=12288
Apr 3 11:16:22 mxtest5 sendmail[21673]: k33FGFhe021580: 7: fl=0x8000, mode=100640: dev=8/1, ino=813275, nlink=1, u/gid=0/107, size=12288
Apr 3 11:16:22 mxtest5 sendmail[21673]: k33FGFhe021580: 8: fl=0x8000, mode=100640: dev=8/1, ino=813284, nlink=1, u/gid=107/107, size=12288
Apr 3 11:16:22 mxtest5 sendmail[21673]: k33FGFhe021580: 9: fl=0x8000, mode=100640: dev=8/1, ino=813284, nlink=1, u/gid=107/107, size=12288
Apr 3 11:16:22 mxtest5 sendmail[21673]: k33FGFhe021580: 10: fl=0x1, mode=100640: dev=8/1, ino=601928, nlink=1, u/gid=0/107, size=1574
Apr 3 11:16:22 mxtest5 sendmail[21673]: k33FGFhe021580: 11: fl=0x1, mode=10600: FIFO: dev=0/5, ino=178222, nlink=1, u/gid=0/107, size=0
Apr 3 11:16:22 mxtest5 sendmail[21673]: k33FGFhe021580: 12: fl=0x0, mode=10600: FIFO: dev=0/5, ino=178223, nlink=1, u/gid=0/107, size=0
Apr 3 11:16:22 mxtest5 sendmail[21673]: k33FGFhe021580: MCI@0x0: NULL
Apr 3 11:16:22 mxtest5 sendmail[21673]: k33FGFhe021580: MCI@0x0: NULL
Apr 3 11:16:22 mxtest5 sendmail[21673]: k33FGFhe021580: to="|/usr/bin/procmail -f-", ctladdr=<web1_mishi@virginiawebhost.com> (10001/10001), delay=00:00:01, xdelay=00:00:00, mailer=prog, pri=31597, dsn=5.0.0, stat=Service unavailable
Apr 3 11:16:22 mxtest5 sendmail[21673]: k33FGFhe021580: k33FGMhe021673: DSN: Service unavailable
Apr 3 11:16:22 mxtest5 sendmail[21673]: k33FGMhe021673: to=<webserviotest@gmail.com>, delay=00:00:00, xdelay=00:00:00, mailer=esmtp, pri=30000, relay=gmail-smtp-in.l.google.com. [64.233.185.114], dsn=2.0.0, stat=Sent (OK 1144077434 38si2249150wrl)

any help would be greatly appreciated
Thanks

falko 3rd April 2006 18:50

Quote:

Originally Posted by ZeroDni
Apr 3 11:16:22 mxtest5 sendmail[21673]: k33FGFhe021580: to="|/usr/bin/procmail -f-", ctladdr=<web1_mishi@virginiawebhost.com> (10001/10001), delay=00:00:01, xdelay=00:00:00, mailer=prog, pri=31597, dsn=5.0.0, stat=Service unavailable
Apr 3 11:16:22 mxtest5 sendmail[21673]: k33FGFhe021580: k33FGMhe021673: DSN: Service unavailable
Apr 3 11:16:22 mxtest5 sendmail[21673]: k33FGMhe021673: to=<webserviotest@gmail.com>, delay=00:00:00, xdelay=00:00:00, mailer=esmtp, pri=30000, relay=gmail-smtp-in.l.google.com. [64.233.185.114], dsn=2.0.0, stat=Sent (OK 1144077434 38si2249150wrl)

any help would be greatly appreciated
Thanks

You must have received a DSN (Delivery Status Notification). What's in it?

ZeroDni 3rd April 2006 19:36

this is what i got when i email with out the prefix
 
This is an automatically generated Delivery Status Notification

Delivery to the following recipient failed permanently:

mishi@virginiawebhost.com

Technical details of permanent failure:
PERM_FAILURE: SMTP Error (state 9): 550 5.1.1 <mishi@virginiawebhost.com>... User unknown

----- Original message -----

Received: by 10.70.14.7 with SMTP id 7mr2294806wxn;
Mon, 03 Apr 2006 10:28:52 -0700 (PDT)
Received: by 10.70.36.16 with HTTP; Mon, 3 Apr 2006 10:28:52 -0700 (PDT)
Message-ID: <de5ab4130604031028m4b3f4f7cr33785a9f940eaced@mail .gmail.com>
Date: Mon, 3 Apr 2006 13:28:52 -0400
From: "web servio" <webserviotest@gmail.com>
To: mishi@virginiawebhost.com
Subject: test
MIME-Version: 1.0
Content-Type: multipart/alternative;
boundary="----=_Part_18530_1388312.1144085332263"

------=_Part_18530_1388312.1144085332263
Content-Type: text/plain; charset=ISO-8859-1
Content-Transfer-Encoding: quoted-printable
Content-Disposition: inline

test

------=_Part_18530_1388312.1144085332263
Content-Type: text/html; charset=ISO-8859-1
Content-Transfer-Encoding: quoted-printable

----- Message truncated -----


and btw thank you so much for helping me

ZeroDni 3rd April 2006 19:37

and this is what i get with the prefix
 
----- The following addresses had permanent fatal errors -----
"|/usr/bin/procmail -f-"
(reason: Service unavailable)
(expanded from: <web1_mishi@virginiawebhost.com>)

----- Transcript of session follows -----
smrsh: "procmail" not available for sendmail programs (stat failed)
554 5.0.0 Service unavailable


Final-Recipient: RFC822; web1_mishi@virginiawebhost.com
X-Actual-Recipient: X-Unix; |/usr/bin/procmail -f-
Action: failed
Status: 5.5.0
Diagnostic-Code: X-Unix; 69
Last-Attempt-Date: Mon, 3 Apr 2006 13:35:15 -0400

falko 3rd April 2006 20:11

The DSN means that mishi@virginiawebhost.com doesn't exist on your server. web1_mishi@virginiawebhost.com exists, so you must create an email alias mishi for the user web1_mishi in ISPConfig.

Quote:

----- The following addresses had permanent fatal errors -----
"|/usr/bin/procmail -f-"
(reason: Service unavailable)
(expanded from: <web1_mishi@virginiawebhost.com>)

----- Transcript of session follows -----
smrsh: "procmail" not available for sendmail programs (stat failed)
554 5.0.0 Service unavailable


Final-Recipient: RFC822; web1_mishi@virginiawebhost.com
X-Actual-Recipient: X-Unix; |/usr/bin/procmail -f-
Action: failed
Status: 5.5.0
Diagnostic-Code: X-Unix; 69
Last-Attempt-Date: Mon, 3 Apr 2006 13:35:15 -0400
Please post the output of
Code:

ls -l /usr/bin/procmail
and
Code:

ls -la /etc/smrsh

ZeroDni 3rd April 2006 20:27

here you go
 
-rwsr-sr-x 1 root mail 71640 2005-03-01 10:37 /usr/bin/procmail

ls: /etc/smrsh: No such file or directory

on the smrsh i tryed to find the package but couldnt find it is it apart of another package thanks so much for helping me

falko 4th April 2006 18:38

Can you post the output of
Code:

ls -l /etc
?

why@ic-tech.ca 25th June 2006 06:04

smrsh limits programs to those in /usr/adm/sm.bin"
 
Also look at "/usr/adm/sm.bin", does it have "procmail" in it (usually a link to "/usr/bin/procmail")? If not, then add it otherwise "procmail" can't run. Of course the man page for "smrsh" does state this is a bad thing, as "procmail" allows users to run arbitrary programs in their procmailrc(5).


All times are GMT +2. The time now is 20:48.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.