HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Server Operation (http://www.howtoforge.com/forums/forumdisplay.php?f=5)
-   -   Strange folder permissions from PHP scripts. (http://www.howtoforge.com/forums/showthread.php?t=34803)

FeraTechInc 10th May 2009 21:31

Strange folder permissions from PHP scripts.
 
PHP Version - 5.2.4-2ubuntu5.5
MySQL Version - 5.0.51a-3ubuntu5.4
Server API Version - apache2handler
OS Version - Ubuntu 8.10
ISPConfig 2.2.x

So several sites that I have use PHP scripts to create folders in an uploads gallery. However, once these folders are created they aren't writable by the site.

The scripts are set to chmod the folders to 777 but these created folders have the following permissions:

owner:
www-data
permission:
755

The owner should be obviously webX where X is the number of the site.

bernholdt 11th May 2009 00:50

You need to use install suphp if you want the server to create folders as webX.

I had the same issue some time ago but after suphp everything is fine there is a great tutorial here somwhere about configureing suphp on your IspConfig server.

http://http://www.howtoforge.com/ins...2.20-and-above

FeraTechInc 11th May 2009 01:58

Thank you so much...

A couple followup questions, how do I check the version of ISPconfig?

Can I add this with other sites already configured?

Lastly does it work with ISPConfig 3?

falko 11th May 2009 13:30

Quote:

Originally Posted by FeraTechInc (Post 187631)
A couple followup questions, how do I check the version of ISPconfig?

Tools > Software Version

Quote:

Originally Posted by FeraTechInc (Post 187631)
Can I add this with other sites already configured?

Yes.

Quote:

Originally Posted by FeraTechInc (Post 187631)
Lastly does it work with ISPConfig 3?

ISPConfig 3 supports suPHP out of the box. All you have to do is set up your server using one of the "Perfect Server" guides for ISPConfig 3.

FeraTechInc 11th May 2009 13:37

Thanks for the reply but the howto ended up breaking my server.

None of the PHP scripts work. I can still access ISPConfig and html pages but when I try to access a PHP site on the server it downloads a PHTML or PHP file...

Any help would be appreciated.

falko 11th May 2009 13:40

Take a look at the logs.

FeraTechInc 11th May 2009 13:50

It works. There was some information missing in the howto.

I needed to remove php_admin entries from my /etc/apache2/vhosts/Vhosts_ispconfig.conf file.

Man I hate technology, lol.

I was getting scarred because I have a very big client that uses a couple of my sites on a daily bases.

Thanks, I appreciate it.

bernholdt 11th May 2009 14:33

As always there is a fix here on howtoforge :)

please read here http://www.howtoforge.com/forums/sho...ighlight=suphp

When i get home i can pm you the fix that solved the same prop on my server.

FeraTechInc 11th May 2009 15:03

Well I got the server back up and running. PHP scripts are running fine.

However, a new problem. While uploading files was a bit sketchy before. Sometimes it would work and others not. Now uploading doesn't work at all.

I can't upload anything.

2 questions, are there some configuration settings that need changing?

Can whatever I did be simply undone?

FeraTechInc 11th May 2009 16:16

I have tried messing around with suPHP settings to no avail. I can't seem to get any file uploads to work at all.

Any help would be greatly appreciated. I tried researching the issue and there doesn't seem to be any solution.


All times are GMT +2. The time now is 14:58.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.