HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=16)
-   -   More RoundCube user@www.domain.com Questions (http://www.howtoforge.com/forums/showthread.php?t=34561)

jonwatson 5th May 2009 21:25

More RoundCube user@www.domain.com Questions
 
Hi All,

I see other threads dealing with the RC user@www.domain.com issue, but the concerns of those threads are not the same concerns I am having.

When a newly created ISPConfig user logs into RC for the first time, his identity is set as user@www.domain.com. This is problematic because those domains whose MX and WWW server differ, end up sending out their emails with an erroneous return address. People replying to those emails end up replying to user@www.domain.com and if the MX server is not the same as the WWW server, then the return emails bounce.

I have been unable to determine whether this is something that I need to fix in ISPConfig or within RC.

Can someone shed any light on how RC constructs this default identity and where I would need to go to affect it?

Thanks

Jon

till 6th May 2009 19:37

This identity is constructed by roundcube and not ispconfig, so you will have to change it in roundcube. As far as I know there is some kind of plugin in roundcube that does this based in the virtusertable file of postfix.

jonwatson 10th May 2009 17:23

Hi Till,

I see that the /etc/postfix/virtusertable has entries such as:

user@www.domain.com

As many of the users on this ISPConfig system do not host their mail on the same server as their web, there is no need for this entry. I also believe this is what is screwing RoundCube up because it seems to be picking the first entry in the virtusertable for any given user and that first entry always has the 'www' part in it.

How do I stop ISPConfig from writing the www version of the address to the /etc/postfix/virtusertable file?

The mailing list from RouncCube evidently has no idea. I've had no response at all to my question and my most recent prompt has now been returned from their mailing list with a 'recipient address rejected' error.

Thanks

jonwatson 10th May 2009 17:28

Ah, got it.

I have to set those domains to 'External Mailserver'

Thanks

Jon

jonwatson 10th May 2009 17:47

Actually, Till or Falko - can you confirm that using the External Mailserver setting is the correct thing to do?

When I set a domain to External Mailserver, the /etc/postfix/virtusertable file is written correctly. It contains no 'www' parts of the email address, and RoundCube then shows the correct user@domain.com in its identities field. Incoming and outgoing email work and look correct. It seems, then, that this is the correct setting for what we need.

However, when I look at the help for the Mailserver option, it says:

Code:

If you select "external Mailserver" no entries for the local MTA will be created
This doesn't seem to be correct, though, because records are created in the /etc/postfix/virtusertable file.

So, basically, I am saying that my solutions seems to work, but because of the help text I am not sure if I am missing something.

Thanks

Jon

till 10th May 2009 17:58

Quote:

Actually, Till or Falko - can you confirm that using the External Mailserver setting is the correct thing to do?
Yes, thats correct.

Quote:

If you select "external Mailserver" no entries for the local MTA will be created

This doesn't seem to be correct, though, because records are created in the /etc/postfix/virtusertable file.
Why? Thats absolutley correct if you set the main domain of a site (www.domain.com) to external mailserver and the co-dpmain (domain.com) is set to local server then only entrys for ...@domain.com will be created.

jonwatson 10th May 2009 18:19

Quote:

Originally Posted by till (Post 187532)
Why? Thats absolutley correct if you set the main domain of a site (www.domain.com) to external mailserver and the co-dpmain (domain.com) is set to local server then only entrys for ...@domain.com will be created.

I meant that it doesn't seem correct because mail records are actually written, but I see now that I wasn't thinking of it properly.

When I go to the main domain (the www domain) and go to the mailserver settings, I am only setting the mail server for the www domain so it makes sense. If I go into co-domains, then into Options, I can set the mailserver setting for the domain.com which also makes sense.

I thought that when I went to the mailserver options for the www.domain.com, I was setting the mailserver setting for the entire domain and all co-domains and therefore the statement that no mail records would be written would be wrong because the co-domain records were still written.

But I see now that each domain and all co-domains have their own mailserver setting so it makes sense now.

Thanks

Jon

kextra1 16th June 2009 08:41

fix
 
well i fixed it by modifying something in roundcube on my last install i just ruined

I wish I could remember how i fixed it

it was within a roundcube file adding a string i found on one of the posts on here i believe....now i can't find it for the life of me

kextra1 16th June 2009 08:49

Also external mail server
 
Also,

I'm using sqlite

how can i set that to external mailserver?

till 16th June 2009 15:15

Check the rouncube config files, you should be able to define the smtp and imap server there.


All times are GMT +2. The time now is 03:38.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.