HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Server Operation (http://www.howtoforge.com/forums/forumdisplay.php?f=5)
-   -   Postfix - SMTP - authentication failed (http://www.howtoforge.com/forums/showthread.php?t=3437)

Hans 31st March 2006 20:05

Postfix - SMTP - authentication failed
 
I use my Postfix smtp-server for outgoing email.

Since today; when i send an email using my emailclient and this Postfix SMTP-server, an error occurs:

Authentication failed:
The username and/or password is not permitted.

I also discovered that i can not start the saslauthd daemon:
/etc/init.d/saslauthd start

When i do an /etc/init.d/saslauthd start

I receive this message:
Starting SASL Authentication Daemon: (failed).

What can be wrong?

I hope someone knows.


Hans

till 31st March 2006 20:33

Please have a look at your mail log and post the errors here.

Hans 31st March 2006 20:44

A piece of my mail log:
 
Mar 31 19:03:19 server1 postfix/smtpd[17383]: TLS connection established from MYHOSTNAME[MYIPADDRESS]: TL$
Mar 31 19:03:19 server1 postfix/smtpd[17383]: warning: SASL authentication problem: unable to open Berkeley db /etc/sasldb2:$
Mar 31 19:03:19 server1 postfix/smtpd[17383]: warning: SASL authentication problem: unable to open Berkeley db /etc/sasldb2:$
Mar 31 19:03:19 server1 postfix/smtpd[17383]: warning: SASL authentication failure: no secret in database
Mar 31 19:03:19 server1 postfix/smtpd[17383]: warning: MYHOSTNAME[MYIPADDRESS]: SASL CRAM-MD5 authenticat$
Mar 31 19:03:19 server1 postfix/smtpd[17383]: disconnect from MYHOSTNAME[MYIPADDRESS]

Hans

Hans 31st March 2006 23:47

The problem is solved now by Falko's solution:
 
http://www.howtoforge.com/forums/sho...aslauthd+start

Hans 2nd April 2006 10:30

saslauthd problems continue
 
I thought that i solved the problem.
But the problem still remains.

When i kill all processes as mentioned in Falko's solution,
saslauthd is is starting up indeed, but when i give the command:

/etc/init.d/saslauthd restart

The system responds:

Stopping SASL Authentication Daemon: (not running).
Starting SASL Authentication Daemon: (failed).

So, my conclusion is: saslauthd is not running at all and maybe it also explains a bit my problem with authentication using smtp, as descibed in thread called "Can not receive e-mail - Postfix" from yesterday.

I do not know what to do now,

Some support would be great!


Hans


All times are GMT +2. The time now is 23:43.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.