HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   General (http://www.howtoforge.com/forums/forumdisplay.php?f=25)
-   -   Auto responder empty "FROM:" (http://www.howtoforge.com/forums/showthread.php?t=34217)

redeprotegida 27th April 2009 20:39

Auto responder empty "FROM:"
 
Hello,

The messages comming from the ispconfig3's are without the "From:"

look on this header:

From:
Message-Id: <200904271825.n3RIPZ9t031468@xxx.xxx.xxxx>
X-Authentication-Warning: xxxxx.xxx.xxxxxxx: vmail set sender to <> using -f
Subject: Auto Response: from
To: diego@xxxxxx.com.br
Precedence: junk
Auto-Submitted: auto-replied
Mime-Version: 1.0
Content-Transfer-Encoding: quoted-printable
Content-Type: text/plain; charset="iso-8859-1"


is it a bug or have something that I can do to fix it?

thanks.

Diego

redeprotegida 28th April 2009 17:25

Can you please give me some way to place something on the from:
if i cant place the real sender i can place something like

autoreply@mydomain.com

just to fill the From:
i need something there if i leave it in blank the antispam will move it to junk.

thanks.

redeprotegida 5th May 2009 14:52

no one knows how to place something on the From: ???

itīs causing bulk mail :(

till 5th May 2009 14:55

You can take a look at the maildrop script in /var/vmail/mailfilters/.... which handle the autoresponder.

redeprotegida 5th May 2009 16:01

i fixed it changing the .autoresponder file

`test -f /var/vmail/mailfilters/$HOST/$USER/.vacation.msg && exit 1 || exit 0`
if ($RETURNCODE==1)
{
{
if (!/^List-Unsubscribe:.*/:h )
{
if (!/^X-Spam-Flag: YES/:h )
{
RESPOND="/var/vmail/mailfilters/$HOST/$USER/.vacation.msg"
RESPONDDB="/var/vmail/mailfilters/$HOST/$USER/.vacation.lst"

# The following must be one contiguous line
cc "| mailbot -t $RESPOND -d $RESPONDDB -D 1 \
-A 'From: diego@redeprotegida.com.br' -s 'Auto Response: from $RECIPIENT' \
/usr/sbin/sendmail -t -f ''"
}
}
}
}


i found a bug...
the From: was $RECIPIENT, so this variable is imput...

please tellme wich php file generate this .autoresponder then ill edit it to generate a line like this:

-A 'From: vacation@redeprotegida.com.br' -s 'Auto Response: from Redeprotegida.com.br' \

cause i need smt automatic, i cant go there and edit the file for all clients that want to enable autoresponder..

thanks ;)

till 5th May 2009 16:14

But the variable $RECIPIENT contains normally the recipient of the email, so the script is correct. If $RECIPIENT is not set on your server then you can either check main.cf to make sure that the second parameter of the maildrop script returns the recipient or you use the $HOST and $USER variables to built the recipient like this:

-A 'From: $USER@$HOST' -s 'Auto Response: from $USER@$HOST' \

redeprotegida 5th May 2009 16:47

i think it is a bug, im running ispconfig on 5 different servers...

2 running on fedora 8 (i know i cant do that, but i did)

3 running on fedora 10

all of my servers i tested autoresponder and it worx, but without the FROM, with the variable empty.

all of then i just found these infos on main.cf about maildrop

maildrop_destination_concurrency_limit = 1
maildrop_destination_recipient_limit = 1
virtual_transport = maildrop


could you please tell me where is the file on ispconfig that generate the .autoresponder o i can edit it, then the next generations will be correct, maybe i can use the example that you gave me using $user@$host

or, maybe something that i can place on my main.cf to start filling the $RECIPIENT var.


thanks *again*

redeprotegida 6th May 2009 14:12

im still working on this, and not found nothing...
just work if i edit the .autoresponder file

someone give me a help please...

to help me:

what is the script that creates the .autoresponder file?

or

what i do to fill the $RECIPIENT that is empty?

thanks.

till 6th May 2009 17:19

Please try what I suggested to you in post #6 of this thread. All templates are in /usr/local/ispconfig/server/conf/

redeprotegida 6th May 2009 20:03

subject: Auto-resposta de diego@redeprotegida.com.br
from: diego@redeprotegida.com.br Add contact
to: teste@appsistemas.com.br Add contact
date: 06.05.2009 15:02


thanks very much till

i just changed the autoresponder script that you said
i changed the $RECIPIENT TO $USER@HOST


All times are GMT +2. The time now is 20:54.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.