HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=4)
-   -   Cant instal ubuntu 8.04 with software raid (http://www.howtoforge.com/forums/showthread.php?t=34205)

Meskis 27th April 2009 16:48

Cant instal ubuntu 8.04 with software raid
 
Hi, I have red the HOW TO create software raid on Ubuntu in this net, but I cant create the raid by folowing this how to. I have spare mashine P4 with Abit AL8 motherboard and 2 SATA WD1200 HDD, it looks cool for my needs. I want to crate raid 1 on it with Ubuntu 8.04 server. But when I creating partitions on sda and sdb (40GB, 1.2GB, 78.8GB) and want to configure raid (creating md devices), I geting error - there is no linux raid partitions, or they in use (or something). When I try to delet md devices, that already apears for some reason, /dev/md0 device, it contains sdb[0] and sda[1] inactive partitions (I do not created that device) geting error: "there was an error deleting the multidisk device. It may be in use.". After I deleting some parttition and creating it again I can specify the md devices (sda1 sdb1, sda2 sdb2, sda3 sdb3), after I pres finish the md devices do not apears.
Where is the problem, does Ubuntu do not suport that motherboard or hdd.
Thanks for your answers.

falko 28th April 2009 16:32

You can try this tutorial: http://www.howtoforge.com/software-r...ot-debian-etch
Should work on Ubuntu as well.

tebokkel 29th April 2009 11:59

After you create a partition, don't forget to set the type to "Linux raid autodetect" (type FD).

Paul

jonfleck88 11th August 2009 07:14

Software RAID
 
I had a similar problem when installing Fedora on a software RAID 1. The solution to my problem was making sure that my swap partitions weren't in a RAID. I just created a separate swap partition on each drive and that solved my problem.

atjensen11 12th August 2009 21:26

I can attest that I followed the How To mentioned in the previos post by Falko. Although it was written for Debian Etch, it worked fine for my Ubuntu 8.04 LTS 64 bit server configuration.

I did run into some issues on a second install with the same drives where it appeared that there were remnants of the previous raid configuration. If I remember correctly, I just reformatted the drives before continuing on with the installation.


All times are GMT +2. The time now is 00:16.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.