HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=27)
-   -   ISPConfig stopped working after update (http://www.howtoforge.com/forums/showthread.php?t=34103)

wxman 24th April 2009 16:42

ISPConfig stopped working after update
 
I ran aptitude update then aptitude safe-upgrade on a new server I'm building, and completely lost ISPConfig. I can't get Apache to start anymore either from the command line. When I try I get:
Code:

[error] VirtualHost *:80 -- mixing * ports and non-* ports with a NameVirtualHost address is not supported, proceeding with undefined results
I found one post here showing this error, http://www.howtoforge.com/forums/showthread.php?t=31803. Till's response is to edit the "apache default host file". Where is the apache default host file on an ISPConfig 3 install, and what needs to be changed?

till 24th April 2009 20:11

This error is uncritical and can be ignored.

Which error message do you get when you start apache?

wxman 24th April 2009 20:32

Quote:

Originally Posted by till (Post 184147)
This error is uncritical and can be ignored.

Which error message do you get when you start apache?

I actually just got Apache to start a few minutes ago - don't ask me how!
I'm running them on Xen virtual servers, and I'm still getting the bugs out. I've never used virtual before now. When I do /etc/init.d/apache2 restart, it gves me that same error twice:
Code:

* Restarting web server apache2                                                                                          [Fri Apr 24 14:30:48 2009] [error] VirtualHost *:80 -- mixing * ports and non-* ports with a NameVirtualHost address is not supported, proceeding with undefined results
[Fri Apr 24 14:30:58 2009] [error] VirtualHost *:80 -- mixing * ports and non-* ports with a NameVirtualHost address is not supported, proceeding with undefined results

In a related question. Should I have installed ISPConfig 3 using the expert install in the second server? I'm running two physical machines, both having two virtual ones running HAProxy/heartbeat in one, and ISPConfig3/Apache in the other. I'll be using a bridge and crossover to do replication and rsync.


All times are GMT +2. The time now is 03:12.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.