HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=27)
-   -   Apache problem (http://www.howtoforge.com/forums/showthread.php?t=34031)

Cracklefish 22nd April 2009 20:17

Apache problem
 
I must hold the world record for installs of suse11.1/perfect server/ispconfig3 but still I can't get apache to work properly

After install ispconfig loads as does phpmyadmin and squirrelmail. I an add clients and mailboxes and all is ok. If I add a website I can open its pages but I loose access to phpmyadmin and squirrelmail. Disabling the site has no effect but deleting it gives me back phpmyadmin and squirrelmail.

If I add a second website any call to that opens the index page of first site.

I am using domain registrars DNSs.

tebokkel 22nd April 2009 23:10

Sounds to me you might have one VirtualHost to much in the Apache-config you got with your distribution.. Does the command
apache2ctl configtest
give warnings about overlapping (name)virtualhosts?
I could very well be wrong about this.. ;-)

Paul

Cracklefish 23rd April 2009 12:40

I've finally got it to work...
 
No but thanks for the tip about apache2ctl. It has saved me from slashing my wrists as I'd run out of hair to tear out.

Revitalised for another days hacking I think I have now managed to get it to work but I had to make some changes.

I have added another vhost file in sites available and a symlink to it in sites enabled.

I get no error messages from apache2 or apache2ctl, I can access ispconfig, phpmyadmin and squirrelmail and all the websites I create.

I have also put an index file in srv/www/htdocs just for the hell of it. I'll take it out if somebody gives me a good reason.

Code:

NameVirtualHost *:80

<VirtualHost _default_:80>
    DocumentRoot /srv/www/htdocs
 
    ServerName golf1.greenway.co.uk
    ServerAdmin webmaster@localhost

    <Directory /srv/www/golf1.greenway.co.uk>
        Options FollowSymLinks
        AllowOverride Indexes AuthConfig Limit
        Order allow,deny
        Allow from all
        <Files ~ '.php[s3-6]{0,1}$'>
            Order allow,deny
            Deny from all
            Allow from none
        </Files>
    </Directory>
   
</VirtualHost>

Incidentally, I don't know if this is significant but the <!--ADDRESS//--> and <!--SUPPORT//--> tags in index.html don't work.

Perhaps somebody could tell me if this is a bodge a bugfix or have I just added something that got lost!

falko 23rd April 2009 23:55

Quote:

Originally Posted by Cracklefish (Post 183833)
Incidentally, I don't know if this is significant but the <!--ADDRESS//--> and <!--SUPPORT//--> tags in index.html don't work.

These are just comments inside the HTML source code.


All times are GMT +2. The time now is 18:27.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.