HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Developers' Forum (http://www.howtoforge.com/forums/forumdisplay.php?f=18)
-   -   ./setup doesnt check if mysql libs exists (http://www.howtoforge.com/forums/showthread.php?t=33901)

Norman 20th April 2009 04:31

./setup doesnt check if mysql libs exists
 
./setup exits with success status even though mysql couldn't be compiled properly after one debian of mine didnt have libmysqlclient15-dev packages.

Maybe a check to see if mysql is compilable?

falko 20th April 2009 13:15

Are you sure there were absolutely no error messages?

Norman 20th April 2009 16:34

No errors previous to compiling mysql headers.
It then completed by cleaning out the /tmp/install_ispconfig but setup script still continued and tried to unpack spamassassin, apr.tar.gz and many other packages after mysql.

Setup exited with a ispconfig installation complete message and proceeded to launch ispconfig. But it failed to start normal apache since cronolog wasn't compiled and had been removed out of /root/ispconfig . A lot of other directories under that directory were also empty.

The backup files created by setup were also removed from /tmp since setup script had succeded (at least it thought so), luckily I always proceed to store another backup before upgrades so I could restore my SSL conf.

Then I installed the mysql library package through apt-get, ran the setup again. Finished without errors, only thing I had to do was restore my SSL conf since that's the only thing I run custom.

But Im guessing I would've had a lot of issues if the setup hadn't upgraded mysql tables properly if there had been changes from previous versions.
Is there a way I can check to see if mysql table layout is correct?

till 20th April 2009 20:07

Install the mysql database dump which is in the ispconfig installer into a new empty mysql database and compare the tables.

Norman 15th May 2009 07:09

The installer removed the install directory after it had exited with a success status (even though it wasnt actually successful).

An installation of the libs and re-run of another extracted install archive worked though. It never touched the DB's so it works as supposed.

I still think there's some issue there when it finds mysql-server but cant verify if there are some other libraries missing.


All times are GMT +2. The time now is 02:31.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.