HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=27)
-   -   Permissions with jailkit (http://www.howtoforge.com/forums/showthread.php?t=33507)

Thomas Jensen 11th April 2009 00:13

Permissions with jailkit
 
Hi all,

I'm a newbie in linux, but already love it!
Yesterday i installed ISPconfig 3, really just a great work!

Now i have created a website to a friend, he also created a shell user (in jailkit), and wanted to use it for an eggdrop bot. When he tries to run the ./configure command (he used the guide at http://www.egghelp.org/setup.htm), he gets a permission denied error.

How can i give him permission to run his eggdrop?

Thanks!

till 11th April 2009 11:34

A jailed account is always limited to some basic functions to use the shell to manage and edit files. It does not include all applications to develop or compile software in c and c++ to prevent that the users take over your server. What you are trying to do is to compile a application in a jailed account which is not possible due to the limits. You can try to add more applications that you need for this to the jail, take a look at the jailkit documentation for this or you compile the eggdrop bot for him and install it in his website.

Thomas Jensen 11th April 2009 15:41

Okay, thanks.

If you buy a shell at someplace, you will be able to compile your own eggdrop, so i would like to make my users able to do that too (it's only for friends, so the security does'nt matter that much).

Some specific commands would be nice, i'm not that good at linux yet :)

Thanks!

Thomas Jensen 11th April 2009 15:58

I just tried to compile the eggdrop as root, but i still gets the "permission denied" error. Even if i placed the files in /home/

till 11th April 2009 18:26

Normally you can not get a permission denied error when you are logged in as root. Most likely you were not root or you executed the command with sudo which will not work for most compile scripts.

Thomas Jensen 11th April 2009 19:10

I WAS logged in as root and i used nothing else than "./configure"
Now i've found out that i could do it with "sh ./configure", but now i can't do the "make config":
server1:/home/eggdrop1.6.19# make config
make: execvp: ./misc/modconfig: Permission denied
make: *** [config] Error 127

Just to ensure you:

server1:/home/eggdrop1.6.19# whoami
root
server1:/home/eggdrop1.6.19# ./configure
-bash: ./configure: Permission denied

falko 12th April 2009 15:37

What's the output of
Code:

cd /home/eggdrop1.6.19
ls -la

?

Thomas Jensen 12th April 2009 16:03

server1:/home/eggdrop1.6.19# ls -la
total 1.1M
drwxr-xr-x 10 root root 4.0K 2009-04-11 15:03 .
drwxr-xr-x 4 root root 4.0K 2009-04-11 14:56 ..
-rw-r--r-- 1 root root 38K 2008-04-19 05:21 aclocal.m4
-rw-r--r-- 1 root root 347K 2004-06-14 06:00 ChangeLog
-rw-r--r-- 1 root root 11K 2009-04-11 15:03 config.h
-rw-r--r-- 1 root root 9.9K 2006-11-20 12:38 config.h.in
-rw-r--r-- 1 root root 83K 2009-04-11 15:03 config.log
-rwxr-xr-x 1 root root 41K 2009-04-11 15:03 config.status
-rw-r--r-- 1 root root 319K 2008-04-19 05:21 configure
-rw-r--r-- 1 root root 4.4K 2008-02-18 23:25 configure.ac
-rw-r--r-- 1 root root 1.7K 2008-02-16 22:40 CONTENTS
-rw-r--r-- 1 root root 18K 2006-03-27 07:48 COPYING
-rw-r--r-- 1 root root 409 2002-06-04 06:11 disabled_modules
drwxr-xr-x 5 root root 4.0K 2009-04-11 15:03 doc
-rw-r--r-- 1 root root 51K 2008-02-16 21:15 eggdrop.conf
-rw-r--r-- 1 root root 2.5K 2008-02-16 22:40 FEATURES
drwxr-xr-x 4 root root 4.0K 2009-04-11 14:50 help
-rw-r--r-- 1 root root 5.7K 2008-02-16 22:40 INSTALL
drwxr-xr-x 2 root root 4.0K 2009-04-11 14:50 language
drwxr-xr-x 2 root root 4.0K 2009-04-11 14:50 logs
-rw-r--r-- 1 root root 92 2009-04-11 15:03 lush.h
-rw-r--r-- 1 root root 13K 2009-04-11 15:03 Makefile
-rw-r--r-- 1 root root 13K 2004-08-28 07:43 Makefile.in
drwxr-xr-x 2 root root 4.0K 2009-04-11 14:50 misc
-rw-r--r-- 1 root root 7.9K 2008-02-16 22:40 NEWS
-rw-r--r-- 1 root root 25K 2008-02-16 22:40 README
drwxr-xr-x 3 root root 4.0K 2009-04-11 15:03 scripts
drwxr-xr-x 5 root root 4.0K 2009-04-11 15:03 src
drwxr-xr-x 2 root root 4.0K 2009-04-11 14:52 text

falko 13th April 2009 18:14

Please run
Code:

chmod 755 configure
and run
Code:

./configure
again.

Thomas Jensen 13th April 2009 19:00

Yes it worked, untill the next step "make config". again i used "chmod 755 /misc/modconfig" in order to make it work, but then a bunch of errors came up:
Configuring module 'compress'.
/bin/sh: line 6: .././compress.mod/configure: Permission denied

Configuring module 'dns'.
/bin/sh: line 6: .././dns.mod/configure: Permission denied

Again i used "chmod 755 /src/mod/dns.modconfigure" and "chmod 755 /src/mod/compress.modconfigure", and then both modules compiled correct.

Next step was to do "make", which worked without problem.

Now i'm going to do "make install" and has the opportunity to change the destination. What am i going to do now? Use the destination from his jail?

I searched at google and found a debian package with eggdrop, which is pretty simple to install, but my question is then; if one of the users from a jail uses /usr/bin/eggdrop to launch his eggdrops, where is the log files other files etc. then stored? Is it a good solution? And how do i compile the eggdrop with other modules if it's installed from "apt-get install"?

I would still appreciate if there was a way to make my jail users able to do more commands, like if they had bought a shell at a professionel hosting company.

Hope it's not too much, but i'm starting to love the way unix works! And that just leads to more questions :D


All times are GMT +2. The time now is 00:10.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.