HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Server Operation (http://www.howtoforge.com/forums/forumdisplay.php?f=5)
-   -   Unknown MX record and Reverse PTR question for Google Apps email (http://www.howtoforge.com/forums/showthread.php?t=33065)

safoo 30th March 2009 22:05

Unknown MX record and Reverse PTR question for Google Apps email
 
I have 2 questions and I think they are both related and should be simple answers.

I run ISPConfig on a server with a couple of domains and DNS is setup through my registrar. Now I have set up google apps for email. The individual websites also send emails (order notifications etc). I followed the google directions for changing the mx records at my registrar but I still see one old mx record:

Check "case-mod.com":

Quote:

Your MX records that were reported by your nameservers are:

0 mail.anaselectronics.com No A Record (no glue either)
10 aspmx.l.google.com 72.14.221.27 (no glue)
20 alt1.aspmx.l.google.com 209.85.217.47 (no glue)
30 alt2.aspmx.l.google.com 209.85.143.27 (no glue)
40 aspmx2.googlemail.com 209.85.135.27 (no glue)
50 aspmx3.googlemail.com 209.85.199.27 (no glue)
1. Where is this old 0 priority record coming from? I have not yet changed reverse PTRs, did reverse PTR automatically add a mx record? or does ispconfig broadcast dns?

Note that the email is coming through fine since there is no A record for mail.anas so the correct google records get used, but google thinks my dns is not setup correctly and also the blackberry service doesn't recognize this email address as a google account. I think clearing out that first record will correct both these issues.

2. What should be the correct reverse ptr for my IP(s) now that I am using google apps for email; my server does send emails using sendmail.

falko 31st March 2009 17:26

Quote:

Originally Posted by safoo (Post 178567)
I have 2 questions and I think they are both related and should be simple answers.

I run ISPConfig on a server with a couple of domains and DNS is setup through my registrar. Now I have set up google apps for email. The individual websites also send emails (order notifications etc). I followed the google directions for changing the mx records at my registrar but I still see one old mx record:

Check "case-mod.com":



1. Where is this old 0 priority record coming from? I have not yet changed reverse PTRs, did reverse PTR automatically add a mx record? or does ispconfig broadcast dns?

Note that the email is coming through fine since there is no A record for mail.anas so the correct google records get used, but google thinks my dns is not setup correctly and also the blackberry service doesn't recognize this email address as a google account. I think clearing out that first record will correct both these issues.

I'm also getting this, so this record must be on the authoritative nameservers (ns46.domaincontrol.com and ns45.domaincontrol.com).

Quote:

Originally Posted by safoo (Post 178567)
2. What should be the correct reverse ptr for my IP(s) now that I am using google apps for email; my server does send emails using sendmail.

Doesn't matter as long as the hostname in return points to the correct IP.


All times are GMT +2. The time now is 20:35.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.