HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   General (http://www.howtoforge.com/forums/forumdisplay.php?f=25)
-   -   Should I fix "[warn] NameVirtualHost 'ip' has no VirtualHosts (http://www.howtoforge.com/forums/showthread.php?t=33015)

HellMind 29th March 2009 19:51

Should I fix "[warn] NameVirtualHost 'ip' has no VirtualHosts
 
/etc/cron.daily/logrotate:
[Sun Mar 29 06:25:09 2009] [warn] NameVirtualHost 190.210.x.x:80 has no VirtualHosts
[Sun Mar 29 06:25:09 2009] [warn] NameVirtualHost 190.210.x.x:443 has no VirtualHosts

Should/Can I fix it?

till 30th March 2009 12:27

There is no need to do anything, but you can remove the ip's from the ip list as you dont have virtual hosts with these IP's.

HellMind 30th March 2009 18:21

Then I create a site I use IP * is that bad?

till 30th March 2009 19:01

No, why should that be bad? By the way, If you would have created a site with that Ip the error message would not have been appeared.

HellMind 30th March 2009 19:43

I think that error appear because I configured ispconfig with that ip but not the in sites.

HellMind 1st November 2009 18:13

Quote:

Originally Posted by till (Post 178432)
There is no need to do anything, but you can remove the ip's from the ip list as you dont have virtual hosts with these IP's.

Where is that ip list you are talking about?

till 2nd November 2009 09:31

System > Server IP addresses.

defconjuan 26th May 2011 04:45

I know this is old but I came accross this and it bugged the heck out of me (I hate error messages).

[warn] NameVirtualHost *:443 has no VirtualHosts

Simply Put: Apache is listening on 443 but there are no VirtualHosts (websites) defined on that port. (See /etc/apache2/ports.conf):
Code:

NameVirtualHost *:80
Listen 80

<IfModule mod_ssl.c>
    NameVirtualHost *:443
    Listen 443
</IfModule>

<IfModule mod_gnutls.c>
    NameVirtualHost *:443
    Listen 443
</IfModule>

You have two options to get rid of the harmless error message:

Option 1 - Enable the default SSL config (Preferred, less destructive)
Define a site on 443 (the easiest way is to run the following code):
Code:

ln -s /etc/apache2/sites-available/default-ssl 000-default-ssl
# then restart apache
/etc/init.d/apache2 restart

Option 2 - Unbind Apache from Port 443
Comment out the "NameVirtualHost *:443" and "Listen 443" lines of /etc/apache2/ports.conf (e.g. add a # symbol in from of those lines so the new ports config file looks something like:)
Code:

NameVirtualHost *:80
Listen 80

<IfModule mod_ssl.c>
    # NameVirtualHost *:443
    # Listen 443
</IfModule>

<IfModule mod_gnutls.c>
    # NameVirtualHost *:443
    # Listen 443
</IfModule>



All times are GMT +2. The time now is 09:21.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.