HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   General (http://www.howtoforge.com/forums/forumdisplay.php?f=25)
-   -   Domain point issue (http://www.howtoforge.com/forums/showthread.php?t=32967)

DizzyD 27th March 2009 23:26

Domain point issue
 
I've just recently installed ISPconfig in Centos 5.2 and everything went smooth. However, I added a few 'sites' 3 to be exact but all domains point to the same directory, the first site that was created to be exact. I checked via webmin and viewed the virtual hosts and all directives were correct. I restarted apache just to be safe and even stopped and restarted but all to no avail. Any ideas?

till 27th March 2009 23:30

1) Make sure that all domains point with a dns A-Record to the IP address of the server and that they dont use any kind of redirects.
2) make sure that you selected this ip (the ip were the domains point to) in the website settings.

DizzyD 27th March 2009 23:54

Thanks for the prompt reply. I have both * and www A Records pointing to the servers IP and the vhost file and directives have the correct ip settings as well, hence my confusion :(

till 27th March 2009 23:58

When did you change the A Records? It may take ut to 48 hours until the changes are propagated to all dns servers.

DizzyD 28th March 2009 00:02

I made the changes yesterday via my domain registrar. I know the changes took affect becuase the domain now points to my server. It just isn't pointing to its directory like it should. None of them are. I run several different servers so this isn't a totally new concept but when all my "i's" are dotted and my "T's" are crossed, it doens't make sense when it doesn't work.

till 28th March 2009 00:07

Does all domains point to the first website you created in ispconfig or to which website they point?

DizzyD 28th March 2009 00:12

Yes they point to the first site I created.

till 28th March 2009 00:23

Please try to set all sites to '*' in the site settings instead of the IP Address.

DizzyD 28th March 2009 00:27

Still no avail....

till 28th March 2009 00:29

Then I have no idea. Without knowing the exact domain names and vhost config files involved its just guessing.


All times are GMT +2. The time now is 04:55.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.