HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Developers' Forum (http://www.howtoforge.com/forums/forumdisplay.php?f=33)
-   -   ERROR: Unable to load SQL-Dump into database table. (http://www.howtoforge.com/forums/showthread.php?t=32965)

rrhode 27th March 2009 22:01

ERROR: Unable to load SQL-Dump into database table.
 
Hello there,

I get this error when trying to install ISPConfig 3 following the Perfect Server for CentOS 5.2.

Quote:

MySQL database to create [dbispconfig]:

MySQL charset [utf8]:

ERROR: Unable to load SQL-Dump into database table.
[root@server1 install]#
I can connect to the database through phpmyadmin and from the command prompt.

ispconfig_install.log says:

Quote:

Fri Mar 27 11:07:44 EDT 2009 - [ISPConfig] - /tmp/trunk/install/lib/installer_base.lib.php, Line 156: WARNING: could not read in ispconfig3.sql
I can manually import that sql file into the database (which it actually creates before giving the error and quitting) but then it says there are already tables in the database and quits.

This is what my mysql.user table looks like.

Code:

localhost                root        xxxxxxxxxxxxxxxx        Y        Y        Y        Y        Y        Y        Y        Y        Y        Y        Y        Y        Y        Y        Y        Y        Y        Y        Y        Y        Y        Y        Y        Y        Y        Y                  [BLOB - 0 B]        [BLOB - 0 B]        [BLOB - 0 B]        0        0        0        0
server1.mydomain.com        root        xxxxxxxxxxxxxxxx        Y        Y        Y        Y        Y        Y        Y        Y        Y        Y        Y        Y        Y        Y        Y        Y        Y        Y        Y        Y        Y        Y        Y        Y        Y        Y                  [BLOB - 0 B]        [BLOB - 0 B]        [BLOB - 0 B]        0        0        0        0
127.0.0.1                root                                  Y        Y        Y        Y        Y        Y        Y        Y        Y        Y        Y        Y        Y        Y        Y        Y        Y        Y        Y        Y        Y        Y        Y        Y        Y        Y                  [BLOB - 0 B]        [BLOB - 0 B]        [BLOB - 0 B]        0        0        0        0

I tried deleting all of them but one and setting its host to % but that still gives the same error. I have tried quite a number of things but obviously nothing thats right yet.

The only thing that is probably related is when I was on page 5 (http://www.howtoforge.com/perfect-se...ispconfig-3-p5) near the top on the 2nd step it did the first command but the 2nd command said I had no access. Then neither commands would work anymore.

This command failed saying there were no permissions.
mysqladmin -h server1.mydomin.com -u root password mypassword

Any idea what I should do?

Thanks for your time =)

till 27th March 2009 22:27

Make sure that you used the mysql root user and not any other user and that the mysql root password does not contain any special chars or contrl characters.

rrhode 28th March 2009 01:10

Hi Till,

Thank you for your quick response =)

Well I am pretty sure its the mysql root user that I am using. I was able to modify the password for it on the first line of the command on page 5: mysqladmin -u root password yourrootsqlpassword

My password has only letters and numbers.

At that point line 2 told me access was denied or something. Maybe this was it: error: 'Access denied for user 'root'@'server1.mydomain.com' (using password: NO)'

It is the same one I used to log into phpmyadmin and to test the connection via the command line. I did mysql -h localhost -u root -p and it asked me to type my password so I typed it and this is its output:

Quote:

Enter password:
Welcome to the MySQL monitor. Commands end with ; or \g.
Your MySQL connection id is 142
Server version: 5.0.45 Source distribution

Type 'help;' or '\h' for help. Type '\c' to clear the buffer.

mysql>
So I don't really know why it would connect this way and phpmyadmin but not in the install.

I did manage to get a different message for you that might help. But it still doesn't make sense because I can import the entire thing perfectly fine in phpmyadmin.

However when I go to the command line and type this:
Quote:

mysql -h server1.mydomain.com -u root -pmypassword 'dbispconfig' < '/tmp/trunk/install/sql/ispconfig3.sql'
It produces this error:
Quote:

ERROR 1072 (42000) at line 47: Key column 'id' doesn't exist in table
I am pretty much clueless about that error. I haven't modified the sql file at all.

Anyway I managed to get past it by removing code inside installer_base.lib.php inside the configure_database function. (Lines 148-161 and line 167)

I now have ISPConfig 3!!! woohoo =)

Leow 28th March 2009 07:50

My question goes to the original first question by this poster. (rrhode)

Unable to load SQL-Dump into database table


While I was installing ISPConfig 3..

I am not sure about the solution as said by rrhode:

Anyway I managed to get past it by removing code inside installer_base.lib.php inside the configure_database function. (Lines 148-161 and line 167)


How am I exactly going to do that and maybe there are other ways? Thank you very much..
:o

till 28th March 2009 09:44

First, which is the exact ISPConfig version are you using? Please be aware that the svn version can only be used on servers were you are actively programming in ispconfig as it can be broken at any time. So please post only issues from released versions or beta / rc versions or at least say that you used the svn version and then post to the development forum as your problems are not realted to any version that was released.

Removing these lines simply results in a incomplete setup. Now you have ISPConfig with an empty or not updated database which is completely useless.

till 28th March 2009 09:52

Quote:

Originally Posted by lee-lee (Post 178095)
My question goes to the original first question by this poster. (rrhode)

Unable to load SQL-Dump into database table


While I was installing ISPConfig 3..

I am not sure about the solution as said by rrhode:

Anyway I managed to get past it by removing code inside installer_base.lib.php inside the configure_database function. (Lines 148-161 and line 167)


How am I exactly going to do that and maybe there are other ways? Thank you very much..
:o

He used a debelopment version (SVN), so what he said is not related to any released version or to any production setup of ISPConfig. Also his solution leaves a unusable and broken system as commenting out the code that ibstalls the database is not a solution of course.

If you encounter this problem, make sure thyt you downloaded the latest non svn relaese from sipconfig.org.

Leow 28th March 2009 10:55

Hi till,

Thanks I am going to get the non-SVN version, sorry I did not mention it.

Could you post some link maybe including the command needed to install the ISPConfig?

I have a link which have not tried yet, I will do it now..and post back if the problem persists which I do not think so since it is the SVN fault. Thank you.

No more issue with ISPConfig 3 after downloaded from non-SVN. The error message did not come up..

Thanks..

rrhode 28th March 2009 15:16

Ohhh I get it now. I downloaded the release version of ISPConfig 3.0.1 but I did the svn export to the install directory as in the Perfect Server guide. I guess I did not read clearly enough. I just did the steps and didn't realize there was an option at that point.

I manually imported the sql file to phpmyadmin. The lines I removed from the file seem to only try to import the database. I don't believe they do any sort of updates to it but if they do then I guess my install is messed up anyway.

So far ISPConfig seems to be working. There are some issues with it but I have no doubt they will be fixed in upcoming releases. And since I apparently have an SVN version thats why there are issues.

Thanks for clearing that up for me =)

till 28th March 2009 15:45

Quote:

I manually imported the sql file to phpmyadmin. The lines I removed from the file seem to only try to import the database. I don't believe they do any sort of updates to it but if they do then I guess my install is messed up anyway.
This will not work because the installer changes several values in the datbase after the import so that ispconfig knows the details of your server configuration. You should uninstall ispconfig with the unistall.php script that you can find in the install folder and then reinstall ispconfig 3.0.1 from the tar.gz

rrhode 28th March 2009 16:04

Thank you again =)

There were some issues with the uninstall which I am guessing the reason is because I am running CentOS and not Debian but I don't know Debian.

uninstall.php had: /etc/init.d/mysql
my system had: /etc/init.d/mysqld

uninstall.php had: /etc/apache2
my system had: /etc/httpd/conf


All times are GMT +2. The time now is 20:45.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.