HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   General (http://www.howtoforge.com/forums/forumdisplay.php?f=15)
-   -   Perl and cgi script installation (http://www.howtoforge.com/forums/showthread.php?t=3275)

linuxuser1 22nd March 2006 11:35

Perl and cgi script installation
 
Dear all,

I am trying trying to install a cgi script that provides free e-mail on my debian
server. I need to install some perl modules to get this to work. I have already installed ISPConfig, mysql and phpMyAdmin on my server as described in perfect setup debian and this is working quite fine.

I have also already installed ActivePerl on the server. It installed in /opt/Perl.
Going through the setup documentation,"Install some Perl Modules needed by SpamAssassin (comes with ISPConfig)

Installation using the Perl Shell

Login to your command line as root and run the following command to start the Perl shell:

perl -MCPAN -e shell"
. It seems that Perl is already installed on my server

How i can

(1) install DBI
(2) install DBD-Mysql
(3) How do i set /opt/Perl as a path on the server. I understand i need to set the
system path for Perl so that it can be easily used by all users.
(4) How do i set Perl as path on the server
(5) What do i need to do so that my server can run cgi scripts for myself and for
others
(6) Can i upgrade my php4 to the latest release.

By the way am running the 2.02 of ISPConfig

Thanks for your kind help

till 22nd March 2006 11:48

First, i recommend to uninstall active perl. ActivePerl is not needed at all because Debian has its own perl packages.

If you followed the howto, perl is already installed and configured on your server. Install the additional perl module with the apt-get command.

To install DBI and DBD-Mysql:

apt-get install libdbi-perl libdbd-mysql-perl

6) run:

apt-get update
apt-get -u upgrade

to update your server.

linuxuser1 22nd March 2006 12:23

Thanks Till,

Will do that.

One other thing I want to confirm is that is my server now configured to run cgi and pl scripts? Can my customers (when i have one ) - also run cgi scripts securely as it is. The server is installed as par the perfect set up documents.

2) What do you think I should do to make my Debian server more secure now that am going to be allowing scripts to be run on it.

I am newbie to linux so your ISPConfig and this forum has gone a long way to help me to learn a lot. So thank you and Falko so much.



Thanks as always.

falko 22nd March 2006 17:03

Quote:

Originally Posted by linuxuser1
One other thing I want to confirm is that is my server now configured to run cgi and pl scripts? Can my customers (when i have one ) - also run cgi scripts securely as it is. The server is installed as par the perfect set up documents.

Yes, if you followed the "Perfect Setup". Also have a look at the test files: http://www.howtoforge.com/forums/showthread.php?t=171

Quote:

Originally Posted by linuxuser1
2) What do you think I should do to make my Debian server more secure now that am going to be allowing scripts to be run on it.

You can use suExec if you're using /var/www as web root for web sites created with ISPConfig. To do so, you must enable suExec under Management -> Server -> Setting -> Web.

linuxuser1 27th March 2006 10:19

Dear Falko,

Thanks for your response.

I have tried to test with the test script at http://www.howtoforge.com/forums/showthread.php?t=171 and am getting 500 error - Internal Server Error!. You can see the url at http://www.alpharadiotv.org.uk/cgi-bin/hello_world.pl. I have enabled "Suexec" and I used this to build my server. - http://www.falkotimme.com/howtos/per...arge/index.php.

I have also tried this http://www.alpharadiotv.org.uk/cgi-b...Change_Setings. I also got Error 500.

The only thing I have done outside the setup documentation is that I installed - apt-get install libdbi-perl libdbd-mysql-perl

6) run:

apt-get update

Thanks for your kind help.

falko 27th March 2006 14:09

Can you post the full path to the hello_world.pl script? Can you also post
Code:

ls -la /path/to/hello_world.pl
?
Might be a permissions problem. The script must be owned by the site admin and the web group.

linuxuser1 27th March 2006 21:14

Hi Falko,

Here we go

Can you post the full path to the hello_world.pl script? - /var/www/web1/cgi-bin/hello_world.pl
ls output -rwxr-xr-x 1 root root 379 2004-06-04 18:11 /var/www/web1/cgi-bin/hello_world.pl l

Another script out put is :
-rwxr-xr-x 1 root root 91358 2006-03-26 23:29 /var/www/web1/cgi-bin/messenger/messenger.cgi

Thanks.

falko 28th March 2006 10:55

The problem is your scripts belong to root:root instead of the owner and group of the web. You must change this because you have enabled suExec.

Please post the output of
Code:

ls -la /var/www/web1

linuxuser1 28th March 2006 11:48

Hi Falko,

Many thanks as always.

How do i change this permission. I am using WinSCP. When I looked at the properties of the script, I saw that is owed by root but I can only change the chmod numbers. The place to change the owner is greyed out. I will come back to you about the output of ls -la /var/www/web1

Thanks.

falko 28th March 2006 20:11

You should try an SSH client like PuTTY so that you can work on the command line.
The command to change a file's ownership is
Code:

chown <user>:<group> /path/to/file


All times are GMT +2. The time now is 01:03.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.