HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   HOWTO-Related Questions (http://www.howtoforge.com/forums/forumdisplay.php?f=2)
-   -   courier-authlib-mysql not working (http://www.howtoforge.com/forums/showthread.php?t=32709)

countzerocrc 22nd March 2009 16:46

courier-authlib-mysql not working
 
Hi,

im trying to set up virtual domains with postfix etc. (on Ubuntu 8.04)
But i have a problem with getting courier-authlib-mysql running.

Packages courier-authlib and courier-authlib-mysql are installed (from sources) but whenever i try to auth via imap i get the following error in my syslog:

Code:

Mar 22 15:22:25 my-servername authdaemond.plain: Unknown module 'authmysql' skipped
snip authdaemonrc
Code:

authmodulelist="authmysql authpam"
when i remove authpam here no process is spawned.

any ideas? tried removing all courier packages and reinstalling but no change.

authdaemonrc
Code:

authmodulelist="authmysql authpam"

authmodulelistorig="authcustom authcram authuserdb authldap authpgsql authmysql authpam"

daemons=5

version=""

authdaemonvar=/var/run/courier/authdaemon

DEBUG_LOGIN=2

tried setting version = authdaemond.mysql results in:
Mar 22 15:38:20 my-servername authdaemond.mysql: exec: No such file or directory

checked the lib directory:
Code:

ls /usr/lib/courier/authlib/ -la
total 63
drwxr-xr-x 2 root root  1024 Mar 15 10:34 .
drwxr-xr-x 6 root root  1024 Mar 22 15:19 ..
-rwxr-xr-x 1 root root 15228 Jun  8  2006 authdaemon
-rwxr-xr-x 1 root root  520 Jun  8  2006 authdaemond
-rwxr-xr-x 1 root root 43816 Jun  8  2006 authdaemond.plain

seems like the authdaemond.mysql file is missing. (/me not sure here :confused:)

any help would be highly appreciated :)

countzerocrc 22nd March 2009 17:07

solved - changed startscript
 
problem solved by fixing the startscript of the authd :D


All times are GMT +2. The time now is 09:40.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.