HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   HOWTO-Related Questions (http://www.howtoforge.com/forums/forumdisplay.php?f=2)
-   -   OpenVZ for debian how-to problem (http://www.howtoforge.com/forums/showthread.php?t=3233)

blueice 20th March 2006 08:17

OpenVZ for debian how-to problem
 
Hi,
i have do the how-to but i have receive this error:

**********************
websrv2:~# vzctl set 101 --onboot yes --save
Unable to open /usr/lib/libopcodes-2.15.so: /usr/lib/libopcodes-2.15.so: undefined symbol: bfd_get_arch
Unable to open /usr/lib/libpthread.so: /usr/lib/libpthread.so: invalid ELF header
Unable to open /usr/lib/libc.so: /usr/lib/libc.so: invalid ELF header
Unable to open /usr/lib/librt.so: /usr/lib/librt.so: symbol __librt_disable_asynccancel, version GLIBC_PRIVATE not defined in file libc.so.6 with link time reference
Unable to open /usr/lib/libthread_db.so: /usr/lib/libthread_db.so: undefined symbol: ps_pglobal_lookup
Saved parameters for VPS 101
***********************

How i can fix this?
Thanks

till 20th March 2006 08:29

Is this a 32Bit or 64Bit DEBIAN linux installation?

Please post also the output of:

uname -m

blueice 20th March 2006 19:18

Quote:

Originally Posted by till
Is this a 32Bit or 64Bit DEBIAN linux installation?

Please post also the output of:

uname -m

Hi,
it is 32 bit.
Here is the info:

server:~# uname -m
i686
server:~# uname -a
Linux server 2.6.8-022stab064-up #1 Wed Mar 8 11:53:09 CET 2006 i686 GNU/Linux

Thanks for your help.

Guido64 20th March 2006 20:08

Same here
 
I have the same problems.
I changed the sources.list from:
"deb http://debian.systs.org/ stable main"
to
"deb http://debian.systs.org/ stable openvz"

Then "apt-get update && apt-get upgrade"

From then on when i do vzctl stop 101
I get this result:

-----------------------
dmz-srv3:~# vzctl stop 101
Unable to open /usr/lib/libopcodes-2.15.so: /usr/lib/libopcodes-2.15.so: undefined symbol: bfd_get_arch
Unable to open /usr/lib/libpthread.so: /usr/lib/libpthread.so: invalid ELF header
Unable to open /usr/lib/libc.so: /usr/lib/libc.so: invalid ELF header
Unable to open /usr/lib/librt.so: /usr/lib/librt.so: symbol __librt_disable_asynccancel, version GLIBC_PRIVATE not defined in file libc.so.6 with link time reference
Unable to open /usr/lib/libthread_db.so: /usr/lib/libthread_db.so: undefined symbol: ps_pglobal_lookup
Stopping VPS ...
VPS was stopped
VPS is unmounted
dmz-srv3:~#
-----------------------

when i start i get this

-----------------------
dmz-srv3:~# vzctl start 101
Unable to open /usr/lib/libopcodes-2.15.so: /usr/lib/libopcodes-2.15.so: undefin ed symbol: bfd_get_arch
Unable to open /usr/lib/libpthread.so: /usr/lib/libpthread.so: invalid ELF heade r
Unable to open /usr/lib/libc.so: /usr/lib/libc.so: invalid ELF header
Unable to open /usr/lib/librt.so: /usr/lib/librt.so: symbol __librt_disable_asyn ccancel, version GLIBC_PRIVATE not defined in file libc.so.6 with link time refe rence
Unable to open /usr/lib/libthread_db.so: /usr/lib/libthread_db.so: undefined sym bol: ps_pglobal_lookup
Starting VPS ...
VPS is mounted
Adding IP address(es): 192.168.166.5
Setting CPU units: 500
Set hostname: vps101.********.lan
File resolv.conf was modified
VPS start in progress...
dmz-srv3:~#
-----------------------

uname -m
i686

uname -a
Linux dmz-srv3.*******.lan 2.6.8-022stab064-up #1 Thu Mar 9 21:14:32 CET 2006 i686 GNU/Linux

till 20th March 2006 21:03

You got these problems first after you changed the sources list to "deb http://debian.systs.org/ stable openvz" and updated the scripts? Before the update the vzctl scripts are working fine?

blueice 20th March 2006 21:07

Quote:

Originally Posted by till
You got these problems first after you changed the sources list to "deb http://debian.systs.org/ stable openvz" and updated the scripts? Before the update the vzctl scripts are working fine?

Me have change the main to openvz because with the main the apt-get update give me errors.
If you check and this page:
http://debian.systs.org/doku.php?id=download
you can see that the right is with openvz

till 20th March 2006 21:10

Quote:

Originally Posted by blueice
Me have change the main to openvz because with the main the apt-get update give me errors.
If you check and this page:
http://debian.systs.org/doku.php?id=download
you can see that the right is with openvz

I tested the howto a few days ago with the settings described in the howto and everything worked fine.

Either the guys at debian.systs.org reorganized their pacakges or they uploaded broken packages.

till 20th March 2006 21:14

Update:

It seems that debian.systs.org has updated their packages today. It looks like that the new vzctl scripts needs the latest kernel patch. Please try to recompile your openvz kernel with the latest patch:

http://download.openvz.org/kernel/02...72-combined.gz

Guido64 20th March 2006 21:19

Quote:

Originally Posted by till
I tested the howto a few days ago with the settings described in the howto and everything worked fine.

Either the guys at debian.systs.org reorganized their pacakges or they uploaded broken packages.

For me openvz worked very well also for hmm 2 weeks or so.
Now i wanted to "apt-get update && apt-get upgrade" because wel you should do that once a while right :)
There was a sources.list error so i started looking what it was. I needed to change the sources.list just like blueice wrote.
After i updated the sources.list and again run "apt-get update && apt-get upgrade" vzctl got updated and after that the problems started.

so yes, your probably right, they sended broken packages.

till 20th March 2006 21:22

Quote:

Originally Posted by Guido64
With me openvz worked very well also for hmm 2 weeks or so.
Now i wanted to "apt-get update && apt-get upgrade" because wel you should do that once a while right :)
There was a sources.list error so i started looking what it was. I needed to change the sources.list just like blueice wrote.
After i updated the sources.list and again run "apt-get update && apt-get upgrade" vzctl got updated and after that the problems started.

so yes, your probably right, they sended broken packages.

Ok, thanks for reporting that. I will try to find out if the packages are broken or if a newer kernel patch is needed and update the howto... :(


All times are GMT +2. The time now is 21:59.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.