HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Developers' Forum (http://www.howtoforge.com/forums/forumdisplay.php?f=33)
-   -   ISPConfig 3 - Vhost and DocumentRoot (http://www.howtoforge.com/forums/showthread.php?t=32135)

Mouton 5th March 2009 13:57

ISPConfig 3 - Vhost and DocumentRoot
 
Hello,

I changed the default configuration for documentroot folder from /var/www/... to /home/www/... but not all the paths in the vhost files are changed. Could this be a bug ? Am I doing something wrong ?

Config: Debian Lenny / Ispconfig 3.0.0.9 RC2



Here is the vhost file:



Code:

<VirtualHost *:80>
      DocumentRoot /var/www/domain.tld/web

    ServerName domain.tld
    ServerAlias www.domain.tld
    ServerAdmin webmaster@domain.tld

    ErrorLog /var/log/ispconfig/httpd/domain.tld/error.log

    ErrorDocument 400 /error/400.html
    ErrorDocument 401 /error/401.html
    ErrorDocument 403 /error/403.html
    ErrorDocument 404 /error/404.html
    ErrorDocument 405 /error/405.html
    ErrorDocument 500 /error/500.html
    ErrorDocument 503 /error/503.html

    <Directory /var/www/domain.tld/web>
        Options FollowSymLinks
        AllowOverride Indexes AuthConfig Limit FileInfo
        Order allow,deny
        Allow from all
    </Directory>

    # mod_php enabled
    AddType application/x-httpd-php .php .php3 .php4 .php5
        php_admin_value sendmail_path "/usr/sbin/sendmail -t -i -fwebmaster@domain.tld"
    php_admin_value upload_tmp_dir /home/www/web2/tmp
    php_admin_value session.save_path /home/www/web2/tmp
    #php_admin_value open_basedir /home/www/web2:/usr/share/php5


</VirtualHost>


And of course, restarting apache leads to
Code:

/home/www# /etc/init.d/apache2 restart
Restarting web server: apache2Warning: DocumentRoot [/var/www/domain.tld/web] does not exist
 ... waiting Warning: DocumentRoot [/var/www/domain.tld/web] does not exist
.


till 5th March 2009 14:36

If you change the path to /home/www several functions like suexec will not work anymore because the suexec path /var/www is compiled into the apache binaries from debian. If you dont need functions like suexec and can live with a limited functionality in ISPConfig, you can use /home/www but you might have to change also the vhost templete in /usr/local/ispconfig/server/conf/

Mouton 5th March 2009 15:02

It's ok for me to have ISPConfig to be placed into/var/www, but not for domains handled in ISPConfig.

It's strange that we can redefine the "Website path" param in the system-> server config in ISPConfig interface but that it doesn't work anymore after changing this. ?

The thing is my main drive is mounted in /home/. Cannot I use this space for websites without reviewing all my server config ?

till 5th March 2009 15:48

Quote:

The thing is my main drive is mounted in /home/. Cannot I use this space for websites without reviewing all my server config ?
You can do this if you do what I explained above.


All times are GMT +2. The time now is 19:25.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.