HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   HOWTO-Related Questions (http://www.howtoforge.com/forums/forumdisplay.php?f=2)
-   -   XBMC on Fedora 10 Dual head with nVidia (http://www.howtoforge.com/forums/showthread.php?t=32131)

Pandora PCs 5th March 2009 12:22

XBMC on Fedora 10 Dual head with nVidia
 
I just Compiled and installed XBMC on a fedora 10 unit running 2 displays in clone mode. Display 1 is a 32" HDTV LCD, and display 2 is my integrated notebook display. I used this guide http://www.howtoforge.com/installing...-fedora-9-i386. everything went fine and I was able to build and install with no errors or warnings. However when I try to run XBMC, the window opens for a split second and then Xwindows does a full restart. Thats it no message in dmesg or the Xorg log file. Ny thoughts would be appreciated.

GeForce4 Ti 4200 Go AGP 8x

falko 6th March 2009 13:37

Any errors in the other logs?

Pandora PCs 8th March 2009 12:19

Ok, I don't see anything I even deleted all the log files and then tried running XBMC and looked in /var/log and there where only 2 files created.

pm-powersave.log
Xorg.0.log

Where else should I look.

falko 9th March 2009 17:51

Is SELinux disabled?

Pandora PCs 9th March 2009 23:27

Actually no it is not. and it has been causing samba issues but I have been putting that off cause it is not important right now. I'll disable it and see if that helps.

Pandora PCs 10th March 2009 23:06

Yep disable SElinux and still the same issue. Im gonna try this
http://iamceres.wordpress.com/2008/1...-on-fedora-10/

Pandora PCs 11th March 2009 11:21

Duh..... Sorry thats for Elisa which also is not working but for a different reason I am working out.

id10t 11th March 2009 14:32

Have you tried editing your xorg.conf and setting the external monitor to be the primary there?

Pandora PCs 12th March 2009 12:33

By External I take that to mean my HDTV conected to the doc. I think it allready is primary here is my xorg file.

# Xorg configuration created by livna-config-display

Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
EndSection

Section "Files"
FontPath "/usr/share/fonts/default/Type1"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "type1"
Load "freetype"
Load "glx"
EndSection

Section "ServerFlags"
Option "AIGLX" "on"
EndSection

Section "InputDevice"

# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/input/mice"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

# generated from data in "/etc/sysconfig/keyboard"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbLayout" "us"
Option "XkbModel" "pc105"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Unknown"
ModelName "Unknown"
HorizSync 30.0 - 110.0
VertRefresh 50.0 - 150.0
Option "DPMS"
EndSection

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
EndSection
Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
Option "TwinView" "True"
Option "MetaModes" "1024x768, 1024x768"
Option "TwinViewOrientation" "Clone"
SubSection "Display"
Depth 24
Modes "1600x1200" "1280x1024" "1280x800" "1024x768" "800x600"
EndSubSection
EndSection

Section "Extensions"
Option "Composite" "Enable"
EndSection

id10t 12th March 2009 12:56

Option "TwinViewOrientation" "Clone"

This is where is saying clone the display on both monitors, try replacing Clone with "Left" or "Right" - not sure if the built in monitor will be primary still or not. Any way to open the box and physically disconnect the broken monitor?


All times are GMT +2. The time now is 16:45.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.