HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   HOWTO-Related Questions (http://www.howtoforge.com/forums/forumdisplay.php?f=2)
-   -   Postfix not delivering Email (http://www.howtoforge.com/forums/showthread.php?t=32041)

Threk 4th March 2009 00:29

Postfix not delivering Email
 
I had a mail server blow up on me last night, Hard drive is completely dead.
Someone else configured this whole system and the part that died (email storage, IMAP and POP for most of the domains) is the part I knew the least about. I know it was authenticating against our LDAP server, as are the inbound routing server and the outbound SMTP server. So I quickly grabbed the most recent server CD I had handy (Ubuntu 8.10) and installed Postfix, and Dovecot.

I found some tutorials on LDAP, Postfix and Dovecot and tried to modify them to match our existing LDAP schema (I'd rather not be trying to re-configure the remaining servers.)

Everything seems to be working now except mail never gets delivered to the mailboxes.

Here is my /etc/postfix/main.cf

Quote:

smtpd_banner = $myhostname ESMTP $mail_name (Ubuntu)
biff = no

# appending .domain is the MUA's job.
append_dot_mydomain = no

# Uncomment the next line to generate "delayed mail" warnings
#delay_warning_time = 4h

readme_directory = no

# TLS parameters
smtpd_tls_cert_file=/etc/ssl/certs/ssl-cert-snakeoil.pem
smtpd_tls_key_file=/etc/ssl/private/ssl-cert-snakeoil.key
smtpd_use_tls=no
smtpd_tls_session_cache_database = btree:${data_directory}/smtpd_scache
smtp_tls_session_cache_database = btree:${data_directory}/smtp_scache

# See /usr/share/doc/postfix/TLS_README.gz in the postfix-doc package for
# information on enabling SSL in the smtp client.

myhostname = <hostname>
myorigin = /etc/mailname
mydestination = localhost
relayhost =
mynetworks = 127.0.0.0/8 [::ffff:127.0.0.0]/104 [::1]/128
mailbox_size_limit = 0
recipient_delimiter = +
inet_interfaces = all
smtpd_sasl_type = dovecot
smtpd_sasl_path = private/auth
mailbox_transport = dovecot
dovecot_destination_recipient_limit = 1
mailbox_command = /usr/lib/dovecot/deliver
permit_sasl_authenticated = yes

ldap_bind_dn = cn=<adminuser>,dc=extantsolutions,dc=net
ldap_bind_pw = <adminpassword>
ldap_search_base = ou=%d,ou=MailAuth,dc=extantsolutions,dc=net
ldap_domain = dc=extantsolutions,dc=net
ldap_server_host = <ldaphost>
ldap_server_port = 389
ldap_version = 3

# Accounts
accounts_server_host = $ldap_server_host
accounts_search_base = $ldap_search_base
accounts_query_filter = (&(&(uid=%n)))
accounts_result_attribute = uid
accounts_cache = no
accounts_bind = yes
accounts_bind_dn = $ldap_bind_dn
accounts_bind_pw = $ldap_bind_pw
accounts_version = $ldap_version

# virtual accounts for delivery
virtual_mailbox_domains = /etc/postfix/virtual_mailbox_domains
virtual_mailbox_base = /home/vmail
virtual_mailbox_maps = ldap:accounts
virtual_minimum_uid = 1001
virtual_uid_maps = static:1001
virtual_gid_maps = static:1001

local_recipient_maps = proxy:unix:passwd.byname, $virtual_mailbox_maps

That server died just before I was going to go to bed last night so I haven't slept in 34 hours or so. I might be missing something obvious, and any help would be appreciated.

Threk 4th March 2009 02:37

libpostfix-global.so.1.0.1 is broken

I finally though to check syslog and found that every time postfix tries to deliver an email libpostfix-global.so.1.0.1 segfaults.

just !!#$% wonderfull

Threk 4th March 2009 05:42

I think the segfault is due to a problem in my configuration, I installed OpenBSD on the server and with pretty much the same configuration it gives the same error.

Any hints/ideas would be VERY welcome

falko 4th March 2009 14:03

Quote:

Originally Posted by Threk (Post 173119)
I think the segfault is due to a problem in my configuration, I installed OpenBSD on the server and with pretty much the same configuration it gives the same error.

In this case it seems to be a hardware problem...
Have you tried memtest to check the RAM?

Threk 6th March 2009 01:34

Actually it was the configuration

uid=%n works in dovecot, but not postfix


All times are GMT +2. The time now is 11:39.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.