HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Kernel Questions (http://www.howtoforge.com/forums/forumdisplay.php?f=6)
-   -   Intel 945GM Chipset. (http://www.howtoforge.com/forums/showthread.php?t=3198)

Layn 18th March 2006 17:07

Intel 945GM Chipset.
 
Hello i have this video card:
Code:

0000:00:02.0 VGA compatible controller: Intel Corporation Mobile Integrated Graphics Controller (rev 03)
0000:00:02.1 Display controller: Intel Corporation Mobile Integrated Graphics Controller (rev 03)

dmesg |grep agp
Linux agpgart interface v0.101 (c) Dave Jones
agpgart: Detected an Intel 945GM Chipset.
agpgart: Detected 7932K stolen memory.
agpgart: AGP aperture is 256M @ 0xd0000000

My kernel is 2.6.16-rc5, i am using xorg 6.9.0.dfsg.1-4, i810. The driver of this xorg, for my intel video card, dont run, so i have compile the xorg 7.0 i810 driver, but either run. So finally i have compile dri freedesktop 20060317 module for i810 and this work fine.

Now i can start Xs without vesa driver, and use i810 driver but no more that 8 mb of videoram, xort log:
Code:

(--) I810(0): Chipset: "945GM"
(--) I810(0): Linear framebuffer at 0xD0000000
(--) I810(0): IO registers at addr 0xFE000000
(II) I810(0): 2 display pipes available.
(II) I810(0): detected 7932 kB stolen memory.
(EE) GARTInit: Unable to open /dev/agpgart (No such file or directory)
(WW) I810(0): /dev/agpgart is either not available, or no memory is available
for allocation.  Using pre-allocated memory only.
(II) I810(0): Monitoring connected displays enabled
(WW) I810(0): VideoRAM reduced to 7932 kByte (limited to available sysmem)
(--) I810(0): Pre-allocated VideoRAM: 7932 kByte
(--) I810(0): VideoRAM: 7932 kByte
(==) I810(0): video overlay key set to 0x101fe
(**) I810(0): page flipping disabled
(==) I810(0): Using gamma correction (1.0, 1.0, 1.0)
(II) I810(0): BIOS Build: 1264
(==) I810(0): Device Presence: disabled.
(==) I810(0): Display Info: enabled.
(II) I810(0): Broken BIOSes cause the system to hang here.
              If you encounter this problem please add
                Option "DisplayInfo" "FALSE"
              to the Device section of your XF86Config file.

my /dev/agpgart exist:
Code:

crw-rw----  1 root video 10, 175 2006-03-18 17:37 /dev/agpgart
My user is in video group (but root either run), agpgart module is load into de kernel. intel_agp module is load too.
In my xorg.conf i have put:
Code:

        VideoRam        65536
Any idea about how can i get the maximun VideoRAM ?

Thanks and regards.
Layn.


All times are GMT +2. The time now is 01:34.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.