HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   HOWTO-Related Questions (http://www.howtoforge.com/forums/forumdisplay.php?f=2)
-   -   Virtual Users And Domains With Postfix, Courier, MySQL And SquirrelMail Ubuntu 8.10 (http://www.howtoforge.com/forums/showthread.php?t=31935)

slohning 1st March 2009 14:00

Virtual Users And Domains With Postfix, Courier, MySQL And SquirrelMail Ubuntu 8.10
 
Hi all,
I am trying to set up postfix mail as per the Virtual Users And Domains With Postfix, Courier, MySQL And SquirrelMail (Ubuntu 8.10) tutorial.
I have the following error
warning: do not list domain xxxx.com in BOTH virtual_alias_domain and virtual_mailbox_domains.

This is what it sends back in email messages
This is the mail system at host daijisuanji.oxnee.com.

I'm sorry to have to inform you that your message could not
be delivered to one or more recipients. It's attached below.

For further assistance, please send mail to postmaster.

If you do so, please include this problem report. You can
delete your own text from the attached returned message.

The mail system

<slohning@oxnee.com> (expanded from <stephen.lohning@oxnee.com>): mail for
192.168.1.150 loops back to myself

Any one go any ideas what I am doing wrong?

falko 2nd March 2009 13:54

What's in your main.cf?

slohning 3rd March 2009 12:56

main.cf
 
Hi all,
I have posted the result of postconf -n
hope you can see my mistake, thanks
------------------------------------------------------------------------------
alias_database = hash:/etc/aliases
alias_maps = hash:/etc/aliases
biff = no
broken_sasl_auth_clients = yes
config_directory = /etc/postfix
content_filter = amavis:[127.0.0.1]:10024
html_directory = /usr/share/doc/postfix/html
inet_interfaces = all
inet_protocols = all
mailbox_command =
mailbox_size_limit = 0
mydestination = localhost, localhost.localdomain
mydomain = oxnee.com
myhostname = daijisuanji.oxnee.com
mynetworks = 127.0.0.0/8,192.168.1.0/24
myorigin = /etc/mailname
proxy_interfaces = 220.245.128.252
proxy_read_maps = $local_recipient_maps $mydestination $virtual_alias_maps $virtual_alias_domains $virtual_mailbox_maps $virtual_mailbox_domains $relay_recipient_maps $relay_domains $canonical_maps $sender_canonical_maps $recipient_canonical_maps $relocated_maps $transport_maps $mynetworks $virtual_mailbox_limit_maps
readme_directory = /usr/share/doc/postfix
receive_override_options = no_address_mappings
recipient_delimiter = +
relayhost =
smtp_tls_session_cache_database = btree:${data_directory}/smtp_scache
smtpd_banner = $myhostname ESMTP $mail_name (Ubuntu)
smtpd_client_restrictions = permit_mynetworks,
smtpd_recipient_restrictions = permit_mynetworks, permit_sasl_authenticated, reject_unauth_destination
smtpd_sasl_auth_enable = yes
smtpd_sasl_authenticated_header = yes
smtpd_tls_cert_file = /etc/postfix/smtpd.cert
smtpd_tls_key_file = /etc/postfix/smtpd.key
smtpd_tls_session_cache_database = btree:${data_directory}/smtpd_scache
smtpd_use_tls = yes
transport_maps = proxy:mysql:/etc/postfix/mysql-virtual_transports.cf
virtual_alias_domains =
virtual_alias_maps = proxy:mysql:/etc/postfix/mysql-virtual_forwardings.cf, mysql:/etc/postfix/mysql-virtual_email2email.cf
virtual_gid_maps = static:5000
virtual_mailbox_base = /home/vmail
virtual_mailbox_domains = proxy:mysql:/etc/postfix/mysql-virtual_domains.cf
virtual_mailbox_limit = 51200000
virtual_mailbox_limit_maps = proxy:mysql:/etc/postfix/mysql-virtual_mailbox_limit_maps.cf
virtual_mailbox_limit_override = yes
virtual_mailbox_maps = proxy:mysql:/etc/postfix/mysql-virtual_mailboxes.cf
virtual_maildir_limit_message = "The user you are trying to reach is over quota."
virtual_minimum_uid = 5000
virtual_overquota_bounce = yes
virtual_transport = virtual
virtual_uid_maps = static:5000

falko 4th March 2009 13:29

Looks ok. But why do you have
proxy_interfaces = 220.245.128.252?

slohning 5th March 2009 04:51

proxy_interfaces
 
Hi Falko,
I though from reading the documentation that it may require this as the mail server is sitting behind a router which is natting the real IP address.

Internet -->220.245.128.252[router ]---> 192.168.1.150

falko 5th March 2009 19:08

No, please disable that line and try again.


All times are GMT +2. The time now is 21:51.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.