HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   General (http://www.howtoforge.com/forums/forumdisplay.php?f=15)
-   -   Issues reloading apache config (http://www.howtoforge.com/forums/showthread.php?t=31931)

Norman 1st March 2009 11:38

Issues reloading apache config
 
Happened on two of my machines tonight, either a new debian update or something has caused this.

Machine 1 (Linux Debian etch):
Running a suPHP setup. When a user deletes a site and doesnt clear his thrashbin the apache server refuses to reload with "bad group" error.
Apache fails to start.

Another machine complained about (Linux Debian Lenny):
Unable to open logs
(2)No such file or directory: apache2: could not open error log file /var/www/web91/log/error.log.
when someone manually moved a log/ folder to the wrong place.

Anyone know why apache has become overzealous of all settings and fail to start for such "minor" things?

till 1st March 2009 12:37

Please take a look in the ispconfig.log if any errors have been reported there. It seems as ispconfig was not able to restart apache after the configuration was changed.

Norman 1st March 2009 13:21

No error in ispconfig.log

But apache refused to restart on the apache2ctl script or the /etc/init.d upstart script.

It was pretty much overzealous of group and log path being there.
Is there a way to make apache not care too much about such minor issues and still start?

till 1st March 2009 13:53

Quote:

Is there a way to make apache not care too much about such minor issues and still start?
No, as this is a major issue for apache. ISPconfg checks for these problems before apache is restarted normally if you did not disable these checks in config.inc.php.

Norman 1st March 2009 23:05

Nope, did not change any of these checks.
What is so odd is that two different issues happened on two different machines starting at the same time in the morning. All related to conf issue caused by ispconfig .

Odd

till 2nd March 2009 13:14

Maybe the configuration process was interrupted or so. I have not seen it on another system befoe so I can only guess what might have been the cause.


All times are GMT +2. The time now is 07:16.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.