HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Server Operation (http://www.howtoforge.com/forums/forumdisplay.php?f=5)
-   -   How to Publish/Register DNS Servers (http://www.howtoforge.com/forums/showthread.php?t=319)

skeeta 18th August 2005 16:53

How to Publish/Register DNS Servers
 
I have setup ISPConfig, fine tuned my DNS and tested everything locally with no major problems.

Now I have to let the world know about my name servers.

I have changed the name servers on my domain record to point to my servers but cannot figure out how to publish/register these server names.

ie Primary Name Server = ns1.xyz.com.au
Secondary Name Server = ns2.xyz.com.au

How do I publicly register that xyz.com.au points to my Static IP.

Thanks in advance for you help.

falko 18th August 2005 18:26

You have to tell the world that your new name servers are authoritative for your domain. Go to the control panel of the ISP where you registered your domain and change the name servers listed there to your new name servers.

skeeta 19th August 2005 07:39

Thanks for your prompt reply.

I have already done that.
So how do I "register" to the world that the name server is on a specific IP.

ie. "ns1.xyz.com.au" and "ns2.xyz.com.au" are on IP "123.123.123.123"

skeeta 19th August 2005 09:13

Problem Solved.

I have to request my domain registrar to insert my IP address against my name servers that I listed on "my" record.

ALSO I had not opened the neccessary ports on my ADLS modem/Router :mad:

Thanks for your help.

Balinder Walia 14th April 2007 13:16

DNS Server
 
Hello everyone,

I have setup Ubuntu 6.06 LTS Server (Dapper Drake) with DNS Server and ISPConfig. I have entered Name Servers for the server ns0.tenthmatrix.net & ns1.tenthmatrix.net as A Record pointing to IP of this ubuntu server. But I am not able to defined these name servers for other client domains as it says invalid name servers defined. Do I have to define these domain names in BIND config or something else I might be missing?

Many thanks in advance

falko 14th April 2007 15:37

Is 83.104.129.88 your server's IP address?

I see that both ns0 and ns1 are pointing to the same IP address. That might be a problem. Some registrars don't allow different name servers to point to the same IP.

Balinder Walia 14th April 2007 16:53

Thanks for your reply Falko.

hhhmmm! so I need to point ns1.tenthmatrix.net to different DNS server IP which I can do actually. I'll keep you posted.

Cheers

falko 15th April 2007 12:28

These tutorials might help you:
http://www.howtoforge.com/ispconfig_dns_godaddy
http://www.howtoforge.com/ispconfig_...domain_schlund

Balinder Walia 19th April 2007 01:40

Thank you soooooo much!
 
Thanks you for your help Falko. You are dead right my domain registrant (tenthmatrix.net) didn't allow full DNS mgmt. or may be no same ip for both name servers. So I registered a new domain called dnsvalley.com which is working. If I can offer you anything please don't hesitate to contact me. You can use CMS system I have written for hosting & managing your site if you want: Try http://demo.calibanweb.com


All times are GMT +2. The time now is 10:15.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.