HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=16)
-   -   Site not working (dns problem?) (http://www.howtoforge.com/forums/showthread.php?t=3189)

gadgetitus 18th March 2006 12:47

Site not working (dns problem?)
 
I cannot get a site to show from the internet, it show ok from my local net.

ive set the name servers at the registrar to server1.madvanman.co.uk and www.madvanman.co.uk (managed dns entries at the registrar pointing to my external ip)
the internal ip of the site is 192.168.1.101
but dig shows the ip (that should be my external ip?) as 192.168.1.102 despite ispconfig dns manager tab showing it as my external ip, i have waited 24 hours to allow it to to go through the whois system
dig ouput:
Quote:

; <<>> DiG 9.3.1 <<>> ukstreetvans.org.uk
;; global options: printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 53329
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 1, ADDITIONAL: 1

;; QUESTION SECTION:
;ukstreetvans.org.uk. IN A

;; ANSWER SECTION:
ukstreetvans.org.uk. 49204 IN A 192.168.1.102

;; AUTHORITY SECTION:
ukstreetvans.org.uk. 49204 IN NS www.madvanman.co.uk.

;; ADDITIONAL SECTION:
www.madvanman.co.uk. 49198 IN A 83.244.130.13

;; Query time: 55 msec
;; SERVER: 193.174.32.18#53(193.174.32.18)
;; WHEN: Fri Mar 17 22:26:07 2006
;; MSG SIZE rcvd: 102


this is my named.conf:
Quote:


options {
pid-file "/var/run/named/named.pid";
directory "/var/named";
auth-nxdomain no;
/*
* If there is a firewall between you and nameservers you want
* to talk to, you might need to uncomment the query-source
* directive below. Previous versions of BIND always asked
* questions using port 53, but BIND 8.1 uses an unprivileged
* port by default.
*/
// query-source address * port 53;
};

//
// a caching only nameserver config
//
zone "." {
type hint;
file "named.ca";
};

zone "0.0.127.in-addr.arpa" {
type master;
file "named.local";
};

zone "162.149.81.in-addr.arpa" {
type master;
file "pri.162.149.81.in-addr.arpa";
};
zone "1.168.192.in-addr.arpa" {
type master;
file "pri.1.168.192.in-addr.arpa";
};


zone "ukstreetvans.org.uk" {
type master;
file "pri.ukstreetvans.org.uk";
};
zone "madvanman.co.uk" {
type master;
file "pri.madvanman.co.uk";
};



//// MAKE MANUAL ENTRIES BELOW THIS LINE! ////


falko 18th March 2006 23:11

Please check that you really used the public IP address in the DNS-Manager for ukstreetvans.org.uk.

Also post the content of /var/named/pri.ukstreetvans.org.uk here.

gadgetitus 19th March 2006 02:36

sorted it out- ip was incorrect in dns manager , my browser was displaying a cached page and not refreshing. (windoze problem not linux problem) thanks


All times are GMT +2. The time now is 19:44.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.