HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   General (http://www.howtoforge.com/forums/forumdisplay.php?f=15)
-   -   php/mysql errors?? (http://www.howtoforge.com/forums/showthread.php?t=3165)

palkat 16th March 2006 18:53

php/mysql errors??
 
My build is on a Suse9.3 with ispconfig 2.18
No Suse Updates ever done, original Suse9.3 install

i have a strange never before seen problem.

this happened to me on monday the 13th and again today.

the problem is:
- Emails get rejected
- php or mysql webpages generate errors like below

----------PHP/MYSQL ERROR---------
Warning: mysql_connect() [function.mysql-connect]: #HY000Can't create a new thread (errno 11); if you are not out of available memory, you can consult the manual for a possible OS-dependent bug in /home/www/web10/web/system/databases/mysql.class.php on line 112
Cannnot connect to DB server
-------------------------------------

- and when i log into ispconfig remotely i get the login screen and when i submit my user name and password i get 3 line of errors like the one above..(I don't have an excat copy of the 3 errors like above but they are similar and talk about php and mysql.

I have found if i restart ispconfig from my command line the problem goes away and email, php, mysql all run great!!!

but what would cause this? is there a bad module or something that now builds a stack and crashes???

oh yeah one last thing, last friday my proftp went down, and it would not comeback online via command line or ispconfig trying to turn the service back on. i had to reboot the server and it came back up. that was the only time that happened. what do you think, this is all strange on the 3 differant issues, kinda like currupt files or something.

Any input? would suse updates or ispconfig updates be of anyhelp or is this something else?

thanks!

till 16th March 2006 21:54

How much memory do you ave in your server? How much swap space?

When you get these errors again, run the "top" command and see how much memory and swap is used.

palkat 16th March 2006 22:49

Till, here is my current top readout...of course all is running okay right now.

top - 14:47:21 up 3:58, 3 users, load average: 0.61, 1.07, 1.13
Tasks: 116 total, 1 running, 115 sleeping, 0 stopped, 0 zombie
Cpu(s): 3.0% us, 0.7% sy, 0.0% ni, 96.0% id, 0.0% wa, 0.3% hi, 0.0% si
Mem: 516008k total, 456360k used, 59648k free, 51452k buffers
Swap: 1036152k total, 0k used, 1036152k free, 241192k cac

Curious to see what you think..BTW: the hardware is a dell PowerEdge 2500 512meg RAM, (single) Xeon 1.4ghz cpu.

falko 17th March 2006 11:52

Normally these errors occur if you run out of memory. So maybe you should have a look at your memory usage with
Code:

top

palkat 18th March 2006 03:57

being as im still new to linux how would the above top read out of my linux build look? good,bad, ok???

Today i also let suse do all the system updates for the first time sense i built the box 2 months ago, figures it couldn't hurt seeing there were new updates for php,apache,etc...

falko 18th March 2006 10:12

The top output looks ok. You should have a look at the load. It seems a little bit high for a new server with no big web sites, etc.
If you have big web sites, lots of email etc. on the server, then the load is ok.

The memory and swap usage is ok.

palkat 19th March 2006 04:11

Falko,

I do have about a dozen websites on the server and about 2 - 3 dozen email boxes that are in use. One website is a php chat room with a lot of traffic too but there was no traffic in the chat at the time of that TOP command.

THanks for your input on that...yesterday i did go ahead and download and install all the Suse9.3 updates that were available for the system and so far 1day 4hours on the server and okay..but usually the problem will happen after about 2-3 days so will keep ya posted.

palkat 21st March 2006 17:20

It just happened again, this time the problem is Amin for ispconfig worked ok except till i did a whois under tools and got a lot of PHP errors.

I also noticed my ftp service was OFFLINE so i did a ispconfig /restart and my ftp service restarted and came back online and my who is under ispconfig worked.

how ever connecting to the ftp via a remote client just hung and timed out...had to reboot the server and everything worked great again.

below is a TOP dump at time of error before i took actions, also it has been exactly 3days 17hours sense last issue. so this is a pattern every 3 days the server freaks out...any advice????

top - 08:51:09 up 3 days, 17:20, 3 users, load average: 0.15, 0.08, 0.02
Tasks: 119 total, 1 running, 118 sleeping, 0 stopped, 0 zombie
Cpu(s): 1.7% us, 0.7% sy, 0.0% ni, 97.7% id, 0.0% wa, 0.0% hi, 0.0% si
Mem: 516008k total, 486796k used, 29212k free, 77788k buffers
Swap: 1036152k total, 58976k used, 977176k free, 219756k cached

falko 21st March 2006 18:11

Maybe you should check your cron jobs. Maybe there's one that runs every 3 or 4 days and causes these problems...

palkat 22nd March 2006 02:55

okay php crash now and a reset of ispconfig does not fix it i have to reboot the system for a fix.

here is my current top read out at crash


top - 18:52:48 up 9:29, 3 users, load average: 0.06, 0.02, 0.00
Tasks: 111 total, 1 running, 110 sleeping, 0 stopped, 0 zombie
Cpu(s): 5.4% us, 0.3% sy, 0.0% ni, 94.3% id, 0.0% wa, 0.0% hi, 0.0% si
Mem: 516008k total, 234260k used, 281748k free, 38320k buffers
Swap: 1036152k total, 65764k used, 970388k free, 72736k cached


here is the php errors i get (these errors are when you try to login to ispconfig ):

Warning: mysql_connect() [function.mysql-connect]: Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (111) in /home/admispconfig/ispconfig/lib/classes/ispconfig_db_mysql.lib.php on line 76

Warning: mysql_connect() [function.mysql-connect]: Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (111) in /home/admispconfig/ispconfig/lib/classes/ispconfig_db_mysql.lib.php on line 76

Warning: Cannot modify header information - headers already sent by (output started at /home/admispconfig/ispconfig/lib/classes/ispconfig_db_mysql.lib.php:76) in /home/admispconfig/ispconfig/web/login/login.php on line 56


so what do you think is causing this type of problem with my server???
(this sytem was built on Feb 1st and ran GREAT till march 10th when all this started, strange what would cause these problems all of a sudden. no new domains were added sense the 1st just the same 9 domains that were put on back on feb 1st)

please advice.


All times are GMT +2. The time now is 03:20.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.