HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=27)
-   -   myDNS & Bind slaves - ISPConfig3 (http://www.howtoforge.com/forums/showthread.php?t=31483)

Murder4Al 18th February 2009 20:57

myDNS & Bind slaves - ISPConfig3
 
Hi,

I'm doing some testing with the great ISPConfig3 and I ran into some questions with myDNS. As it's very light in docs I resort to here.

I have several off-site dns backups who run bind (not discussable) and I want them to AXFR their stuff of the main myDNS server.
I have added 'allow-axfr = yes' to the mydns.conf, and I have verified this actually working after adding my slave dns-ip's to the xfer field.

What I'm not getting is the notify part.
If I got it correctly myDNS does not sent notifies to the slaves whenever updates are performed (it's not aware of such a change since only the underlying table is updated and the deamon is not notified), thus creating an potential problem.
But the documentation states that that is the setting 'notify-enabled' is true then notifies will be generated on startup, this is something that I can't confirm to be working.
I find that updating the slaves in a timely matter is important for good service.

Any ideas ?

Greets
Kobe

till 19th February 2009 10:50

I see two options:

1) Rund mydns on the slaves too and use the mysql replication faetures in ispconfig to replicate the dns records to the other instances.

2) Restart the mydns on the master by cron from time to time, e.g. once an hour.

Murder4Al 20th February 2009 12:20

Till,

Running myDNS on the slaves is not an option (those servers are not mine and re slaving several thousands of other domains from other sources).

Upon restarting myDNS NOTIFIES are not sent out currently (for a reason unknown to me). Is this a possible bug in myDNS or am I missing something?
In case of a bug I'll have a look in the source ;-)

till 20th February 2009 12:28

Quote:

Originally Posted by Murder4Al (Post 170669)
Till,

Running myDNS on the slaves is not an option (those servers are not mine and re slaving several thousands of other domains from other sources).

Upon restarting myDNS NOTIFIES are not sent out currently (for a reason unknown to me). Is this a possible bug in myDNS or am I missing something?
In case of a bug I'll have a look in the source ;-)

I'am not suere if its a bug as I'am not a mydns developer. Maybe its just a missing feature? mydns isteslf is not under development anymore as far as I know but the successor project is mydns-ng which can be found at sourceforge and which is used for ispconfig as well. Maybe you might ask the developers in their mailing list if they know a solution for this.

Murder4Al 20th February 2009 14:17

A look in the source learned that 'allow-update' also needs to be enabled for the notify-on-start feature to kick-in.

Since bind is trying to be smart it uses IXFR's as a response it seems, so I just need to figure out how to enable that.

BTW, I'm using the -ng version evidently.

theamoeba 23rd February 2009 08:48

What I am struggling to understand is, why did u decide to change over to mydns when bind seemed to be working just fine. i will grant u that mydns is easier to understand.

i am running fedora 9 (i know this experimental, and no i am not changing to ubuntu/debian). mydns starts beautifully using a service mydns start, but it refuses to start on boot - it gives an error 111 mysql connection error.

can someone please help with this as all of the mysql details are correct and it loads nicely once the box has booted and i do a service start manually.

it just occurred to me that since it is moaning about a mysql.sock error, is it not possible that mydns is starting before mysqld and therefore cannot connect?

J

theamoeba 23rd February 2009 09:11

Quote:

Originally Posted by theamoeba (Post 171221)
What I am struggling to understand is, why did u decide to change over to mydns when bind seemed to be working just fine. i will grant u that mydns is easier to understand.

i am running fedora 9 (i know this experimental, and no i am not changing to ubuntu/debian). mydns starts beautifully using a service mydns start, but it refuses to start on boot - it gives an error 111 mysql connection error.

can someone please help with this as all of the mysql details are correct and it loads nicely once the box has booted and i do a service start manually.

it just occurred to me that since it is moaning about a mysql.sock error, is it not possible that mydns is starting before mysqld and therefore cannot connect?

J

i figured out my own questions.

mydns is very much easier to use than bind as it runs on sql - mysql or postgresql. so updating the records is really simple.

managed to fix the mysql issue, i was right - mydns was starting before mysqld - therefore it would never be able to connect would it? here is a forum post on changing the service boot order in fedora (i suppose this will work in any red hat variation): https://www.linuxquestions.org/quest...ervice-239886/

J

kr0hmy 1st April 2009 08:27

trying to make IXFR work
 
Hello! I'm new to ispconfig and i love it :)

I've set-up a server at ovh.com with ispconfig 3 and ubuntu 8.04. This hosting provider give me the possibility to use a secondary DNS service (i don't have any access to config or anything).

Everything is working fine when the slave (they use BIND) sync with my main DNS for the first time (AXFR type). But when i update the zone records, the slave can't get the updated records.

Like Murder4Al, i found out that BIND use IXFR to get the updated records. Since i can't modify the slave config, i modified the Mydns-ng config to activate IXFR. But to be fully fonctionnal myDNS require a database structure change :
These 2 fields are needed in the dns_rr table for myDNS to be capable of IXFR zone transfers (obtained with command : mydns --create-tables):
Code:

  stamp      timestamp NOT NULL DEFAULT CURRENT_TIMESTAMP,
  serial    INT UNSIGNED DEFAULT NULL,

I'm not sure about what ispconfig file(s) i need to modify to insert the updated serial in the dns_rr table? Since i'm not so confident about my php skills... i hope someone could help me on this :)

till 1st April 2009 08:38

You will have to modify the sql dump, the form definitions in the dns module of the interface and then add some code to the form handler scripts of the dns module of the interface to fill in the correct values.

andypl 2nd April 2009 09:24

MyDNS may instead use bind-mysql?
http://mysql-bind.sourceforge.net/


All times are GMT +2. The time now is 07:27.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.