HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   HOWTO-Related Questions (http://www.howtoforge.com/forums/forumdisplay.php?f=2)
-   -   The Perfect Server - Debian Lenny (Debian 5.0) [ISPConfig 2] - Page 3 (http://www.howtoforge.com/forums/showthread.php?t=31459)

edge 18th February 2009 12:52

The Perfect Server - Debian Lenny (Debian 5.0) [ISPConfig 2] - Page 3
 
In the "The Perfect Server - Debian Lenny (Debian 5.0) [ISPConfig 2] - Page 3" I read the following:
Quote:

We need to open /etc/rsyslog.d/bind-chroot.conf...

vi /etc/rsyslog.d/bind-chroot.conf
I did follow the howto, but do not have this file! Where did i go wrong, or... do I need to create the file bind-chroot.conf?
If so, you should maybe rename the text "We need to open /etc/rsyslog.d/bind-chroot.conf" to something like "We need to create /etc/rsyslog.d/bind-chroot.conf"

pbcartwright 18th February 2009 14:34

apache hosed
 
I was trying to follow this HOW-TO, when I got to the apache section.
I had, once before, long ago, tried to install apache using another tutorial, and I obviously hosed it up. so I uninstalled apache2, purged, it , reinstalled it, and... still it is broke. when I remove the /etc/apache2 folder and reinstall apache, it doesn't recreate that folder. I am at a loss as to what to do. when I start apache now I get this:
/etc/init.d/apache2 restart
Restarting web server: apache2(98)Address already in use: make_sock: could not bind to address [::]:80
(98)Address already in use: make_sock: could not bind to address [::]:80
(98)Address already in use: make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
Unable to open logs
failed!


suggestions??

falko 19th February 2009 20:59

Quote:

Originally Posted by edge (Post 170145)
do I need to create the file bind-chroot.conf?

Yes, create that file if it doesn't exist.

falko 19th February 2009 21:00

Quote:

Originally Posted by pbcartwright (Post 170155)
I was trying to follow this HOW-TO, when I got to the apache section.
I had, once before, long ago, tried to install apache using another tutorial, and I obviously hosed it up. so I uninstalled apache2, purged, it , reinstalled it, and... still it is broke. when I remove the /etc/apache2 folder and reinstall apache, it doesn't recreate that folder. I am at a loss as to what to do. when I start apache now I get this:
/etc/init.d/apache2 restart
Restarting web server: apache2(98)Address already in use: make_sock: could not bind to address [::]:80
(98)Address already in use: make_sock: could not bind to address [::]:80
(98)Address already in use: make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
Unable to open logs
failed!


suggestions??

Try
Code:

apt-get remove --purge apache2
and install it again afterwards.

pbcartwright 19th February 2009 21:24

apt-get remove --purge apache2-common
 
that didn't work. you also had to remove and purge apache2-common.
It is now working. great tutorial, thanks!


All times are GMT +2. The time now is 23:36.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.