HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=4)
-   -   can't get SquirrelMail work on Ubuntu 8.10 (http://www.howtoforge.com/forums/showthread.php?t=31339)

lamarty 15th February 2009 13:17

can't get SquirrelMail work on Ubuntu 8.10
 
hi,
i have followed th tutorial "http://www.howtoforge.com/virtual-users-domains-postfix-courier-mysql-squirrelmail-ubuntu8.10" till the end (a great tutorial by the way), i could access squirrelmail login page, but when i enter the mail address/pwd of a database user, i have an error that IMAP connection was dropped, did anyone had this error ?

Thanks

lamarty 15th February 2009 17:53

On the mail.log, i found that when i try to telnet the server via POP or IMAP i have:

Feb 15 16:49:32 server1 imapd: chdir test.loc/la/: No such file or directory
Feb 15 16:49:48 server1 pop3d: Connection, ip=[::ffff:192.168.0.100]
Feb 15 16:50:03 server1 pop3d: chdir test.loc/la/: No such file or directory

'test.loc' is the domain name, and 'la' is a user that i try to setup mail for : ''la@test.loc"

thanks for your help.

falko 16th February 2009 18:40

Did you send a welcome mail to that account?

lamarty 16th February 2009 19:45

sure, i sent a mail to it using mailx

falko 17th February 2009 16:42

What's in the mail log when you send such a mail?

Did you configure SquirrelMail for courier?

maczkal 3rd March 2009 14:50

I have the same problem.

I configured Squirrelmail with courier.

I will insert my log files.

This is part of my mail.log file after using "mailx sales@example.com"

Mar 2 15:24:51 ubuntu dccproc[9231]: no working DCC servers dcc1.dcc-servers.net dcc2.dcc-servers.net dcc3.dcc-servers.net ... at 208.201.249.233 209.169.14
Mar 2 15:24:51 ubuntu postfix/smtpd[9233]: connect from localhost.localdomain[127.0.0.1]
Mar 2 15:24:51 ubuntu postfix/smtpd[9233]: 5D16214819E: client=localhost.localdomain[127.0.0.1]
Mar 2 15:24:51 ubuntu postfix/cleanup[9224]: 5D16214819E: message-id=<20090302142438.EC90C14819F@server1.example.com >
Mar 2 15:24:51 ubuntu postfix/qmgr[7542]: 5D16214819E: from=<root@server1.example.com>, size=770, nrcpt=1 (queue active)
Mar 2 15:24:51 ubuntu postfix/smtpd[9233]: disconnect from localhost.localdomain[127.0.0.1]
Mar 2 15:24:51 ubuntu amavis[7340]: (07340-02) Passed CLEAN, <root@server1.example.com> -> <sales@example.com>, Message-ID: <20090302142438.EC90C14819F@server1.example.com> , mail_id: lqMclwAqoZLI, Hits: 4.305, size: 303, queued_as: 5D16214819E, 12253 ms
Mar 2 15:24:51 ubuntu postfix/smtp[9227]: EC90C14819F: to=<sales@example.com>, relay=127.0.0.1[127.0.0.1]:10024, delay=13, delays=0.27/0.05/0.02/12, dsn=2.0.0, status=sent (250 2.0.0 Ok, id=07340-02, from MTA([127.0.0.1]:10025): 250 2.0.0 Ok: queued as 5D16214819E)
Mar 2 15:24:51 ubuntu postfix/qmgr[7542]: EC90C14819F: removed
Mar 2 15:24:51 ubuntu postfix/smtp[9236]: 5D16214819E: to=<sales@example.com>, relay=none, delay=0.34, delays=0.05/0.05/0.24/0, dsn=5.4.4, status=bounced (Host or domain name not found. Name service error for name=mail.example.com type=A: Host not found)
Mar 2 15:24:51 ubuntu postfix/cleanup[9224]: B785E1481A0: message-id=<20090302142451.B785E1481A0@server1.example.com >
Mar 2 15:24:51 ubuntu postfix/qmgr[7542]: B785E1481A0: from=, size=2776, nrcpt=1 (queue active)
Mar 2 15:24:51 ubuntu postfix/bounce[9237]: 5D16214819E: sender non-delivery notification: B785E1481A0
Mar 2 15:24:51 ubuntu postfix/qmgr[7542]: 5D16214819E: removed
Mar 2 15:24:51 ubuntu postfix/cleanup[9224]: CF1DC14819E: message-id=<20090302142451.B785E1481A0@server1.example.com >
Mar 2 15:24:51 ubuntu postfix/local[9239]: B785E1481A0: to=<root@server1.example.com>, relay=local, delay=0.1, delays=0.04/0.05/0/0.01, dsn=2.0.0, status=sent (forwarded as CF1DC14819E)
Mar 2 15:24:51 ubuntu postfix/qmgr[7542]: CF1DC14819E: from=, size=2916, nrcpt=1 (queue active)
Mar 2 15:24:51 ubuntu postfix/qmgr[7542]: B785E1481A0: removed
Mar 2 15:24:55 ubuntu postfix/smtp[9236]: CF1DC14819E: to=<maczkal@wp.pl>, orig_to=<root@server1.example.com>, relay=mx.wp.pl[212.77.101.4]:25, delay=3.4, delays=0.01/0/0.13/3.2, dsn=2.0.0, status=sent (250 ok 1236003703 qp 5679)
Mar 2 15:24:55 ubuntu postfix/qmgr[7542]: CF1DC14819E: removed


maczkal@wp.pl is my email.

When i want to login with Squirrelmail i have ERROR: Connection dropped by IMAP server.

This is in mail.log

Mar 2 15:27:07 ubuntu imapd: Connection, ip=[::ffff:127.0.0.1]
Mar 2 15:27:07 ubuntu imapd: chdir example.com/sales/: No such file or directory


Any hints?

falko 4th March 2009 14:32

Did you create the sales@example.com account in your database? Is example.com in the domains table?

You might have to create an A record for mail.example.com.


All times are GMT +2. The time now is 15:36.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.